Sign in with
Sign up | Sign in
Your question
Solved

Rosewill RG-630 won't power up

Last response: in Components
Share
June 3, 2012 11:13:42 PM

Hello,

I recently went to build a budget gaming system similar to the last 2 system builder marathon budget systems with some minor upgrades:

Rosewill FBM-01 case
Rosewill RG-630 PSU
Gigabyte H77M-D3H mobo
Intel i5-3450 CPU
Radeon HD 6870 1GB
2x4GB RAM
DVD burner
2 1TB sata drives from my previous system

I had some trouble with the power supply when I first set the system up with 1 harddrive - it wouldn't even turn on the fan when I switched it on. But after reseating all the cables a couple of times and then spending 15 minutes on the phone with Rosewill's tech support, I determined that it was working by pulling all the cables and using (on their advice) a paper clip to short a black wire to a red wire on the main 24 pin DC cable. The PSU apparently detects shorts and poorly connected cables in some way and won't power up, though there's no way to tell which DC cable is responsible. In any case, I was finally able to get the system up and running and get the OS installed and such.

Today, I tried to transfer in the second hard drive. The Rosewill case made this a bit harder than it sounds, as I had to pop out the RAM in order to slide in a harddrive, had to pull the graphics card to plug in another SATA 3 cable, and had to squeeze the second harddrive in front of the main power cable to the motherboard. When I got it all put back together, I turned it on, and, once again, absolutely nothing happened. So I reseated all the cables (which again, involves pulling components out and rebuilding), and... nothing. So I pulled everything except the motherboard DC connections... nothing. So I pulled all the cables and tried the paperclip trick... nothing.

This is the most finicky PSU I've ever worked with. Is it dead, or is it detecting a failure somewhere, or is it in some kind of lock out mode after detecting a failure? I don't know, and I'm not sure how to test...

Is this a bum PSU that I need to return? Or is this normal for the RG-630's? Has anyone else run into these issues? How easy is it to blow a PSU? Is it possible I somehow blew it in the course of pulling and reseating DC cables repeatedly (with the AC power off, of course)?

Thanks,
Jason

More about : rosewill 630 power

a c 702 ) Power supply
June 3, 2012 11:21:54 PM

It is a bum PSU and you should return it and get a quality unit instead.
m
0
l

Best solution

a c 158 ) Power supply
June 3, 2012 11:41:20 PM

It's not a top tier PSU, but it's a good PSU at a great price: http://www.hardwaresecrets.com/article/Rosewill-Green-S... It sound slike you may have gotten a bad PSU or are having issues properly seating the cable connectors. You might try breadboarding to verify PSU operation while powering all your system components: http://www.tomshardware.co.uk/forum/page-262730_13_0.ht...
The paper clip trick is a valid and easy way to verify that a PSU is not completely dead, but it is an unloaded test. It also sounds like you are having a lot of space issues inside your case. Lack of space may be leading to accidentally bumping cables loose during installation. Do you have any cables that barely reach or have any strain on them? If yes, then consider cable extensions.

There are better PSUs out there and if you want to change PSUs, then the Seasonic M12II-520 is a great option right now at $70 after S/h at Newegg.
Share
Related resources
June 11, 2012 2:01:47 PM

Best answer selected by saighdiur.
m
0
l
June 11, 2012 2:25:29 PM

Cable length was not an issue, but lack of space in the case was definitely causing trouble as it was difficult to reach some cables to reseat them once I'd put all the final components in the box.

The system is now up and running fine. I'm not certain, but I think a poorly seated 24 pin power connector to the mobo made it fail to start the first time (they put the 24 pin socket at the edge of the board that overhangs the mounting screws, which made me nervous about applying enough force to get it in) but I think the case power switch connector got knocked loose on my second attempt.

I don't think I'll ever buy another microatx case without researching accessibility features. I've always had larger form factor cases in the past with swing out sections for drives and easy access to the whole so on, so I didn't realize how much of a pain a minimalist microatx case like the fbm-01 could be. I can't say I'd recommend it. I don't think I'd fault the power supply at this point, though it did make me wish that there were some sort of feedback mechanism to indicate that it is failing to power up because of a fault detection.

Thanks for the help,
Saighdiur
m
0
l
a c 158 ) Power supply
June 11, 2012 5:36:08 PM

Quote:
some sort of feedback mechanism to indicate that it is failing to power up because of a fault detection

Ye olde BIOS beeps codes did some of that, but power issues identified were limited to the CPU and the GPU error codes and didn't specify that it was a power issue. UEFI BIOS error codes like you have on your mobo are a lot more board/mfr specific; you have to check the mob manual to verify how the error codes are displayed and the meaning of the codes. The codes in UEFI are a lot more specific than theold beep codes, though.
m
0
l
!