Sign in with
Sign up | Sign in
Your question

Problems with SB Live! 5.1 Bulk

Last response: in Components
Share
March 29, 2001 12:48:21 AM

Ok, first of all it was a pain in the rear to install.

NONE of the drivers at creative worked, not even LW3.0 (which has a big SUCKS tag on the installation program btw, see the end remark).

I called the shop were i bought and they said "Aparently, there has been some problems with SB Live 5.1 and the new drivers or the LW3.0, please run the setup instalation on the bundled CD. You might run into some trobles though, but they're easy to handle, just call again if you can't sort them out" (i know, but it was a friend of mine that works at the shop).

So i did, i ran the setup on the CD and this time the drivers were installed.... NOT... they were installed but main driver had the BIG Yellow sign on it. Called the shop again. "Yeah yeah, we've been having the same problem here too, just click on the "Update drivers" button and use the drivers on the CD... that should work!"

Suprise it did work (my apreciation for Creative's products has dropped to a negative 20 points by now)!!! Well i have sound and everything but the "Creative GamePort Device" now has a the yellow sign!!!

The board is an Asus A7V133 without the onboard sound system and i disabled the AC'97 Sound Codec on the bios (which in fact doesn't exists on the board, 'twas just to be safe), and nothing, and i can't solve it, neither my friend at the shop!

I've asked creative on this... but, suprise, no reply (another negative 10 points hit, we're now at -30 points).

Can anybody help me at this?

END NOTE:
Just for the fun of it, a friend of mine couln't install the LiveWare 3.0 because it sayd he didn't had enough free space (he had like, 7gigs free), so he asked Creative on this... the reply? "Save all your documents and reformat the disk and install windows" .

What kind of answer was that (another -20 points to creative)... but my friend did what was asked, and solved........NOTHING... same problem with the fresh instalation of windows... another mail to Creative ... reply "Remove your NIC card and try again" (ANOTHER -1000 points since nothing has the do with it, since the card is working swell, he just can't install LiveWare3.0 'cause it says he doesn't have enough free space).


Really i have a TnT2Ultra from Creative and had a AWE32 and i had a major GOOD impression on Creative. Now i've downloaded the new drivers for Win98SE for the TnT2Ultra and windows crashes after 5 minutes..... What kind of BABOONS are running Creative these days???

More about : problems live bulk

March 29, 2001 3:14:11 PM

I have the same mobo and have the 5.1 retail version. I found that using the installation CD, it puts all kinds of crap on my system that slows down the boot-up, like EAX. I found this out when using the board in my old computer, so when I got the new computer, this time I did not use the installation CD, instead I went to device manager and went through the driver installation, clicked on "Have Disk" and pointed it at the CD-ROM. I had to run through this twice, once for the output and once for the input. (At the PCI level, there are only two devices, one for output that once installed will show up as both the SB Live and the legacy SB, and one for input that will show up as the joystick and MIDI.) Anyway mine works great after this, the sound and the joystick are working. If you are using Windows 9x or ME, try using the device manager and "remove hardware" for all devices associated with the SB card, then reboot and it should "find new hardware" and give you a chance to reinstall the drivers. If by some chance you have a bum set of drivers on the CD, there's not much I can say, 'cause there's no download for the 5.1 on Creative's site (I could probably copy my drivers off my CD and post it somewhere for you to download, since I know they work with the exact same basic hardware you have). Good luck!
March 29, 2001 3:17:38 PM

Ooops, sorry, I see you now have the sound working but the joystick doesn't show up. Ignore my last note, just reinstall the driver for the joystick using device manager, click on "Have Disk" and point it at the CD, and it should fix all the input devices. Remember that with the SB card there are actually *two* devices at the PCI level, and they both need drivers.
Related resources
March 30, 2001 2:55:58 PM

Thanks for your help, but i already did that...

-I just pressed update drivers and used the CD and no result.

-After that i completly deleted the driver and i re-installed it manually (using the refresh button on the device driver and then pointing it to the CD)

I'm gonna try the completly foul-proof (deleting the INF in \windows\inf\other and all the DRV*.BIN in \windows\inf\)

Let's see if it works, but i think it won't
March 30, 2001 3:57:31 PM

Ok... just as I was expecting it, it didn't work.

I've removed the drivers from the devic emanager, i've delete ALL inf files of Windows98SE from Creative AND i've deleted the hardware database (the *.bin in c:\windows\inf) to force the windows to rebuild the drivers index.

Everything was done from scratch as if i never did have a soundcard and the result.... everything works fine except for the F**KING Creative GameWhatever Joystick device...

I've even tried to set the resources manually since they were 0x200->0x207 which is very close to the base address of the Sb16 Emulation (0x220), nope not working

Why oh why did i leave my good old Creative Labs AWE32 non-PnP ISA multi-cd Surfing-Board sound card?!?!?!
I had it since my Old Pentium-60 and it never let me down! I never did changed it 'cause i was a bit sceptic about PCI-Soundcards because now and then i like to see some Demos (from the Demo scene, not game Demos) and do some ASM coding on the soundcard and i knew that PCI-Soundcards needed emulation for that!

But i figured .. "hey what the hell, the SB PCI has been around for 2 years now and the AWE32 is reallt getting old, perhaps i was wrong to judge the PCI-Sound cards"

I begin to think i was not, from crappy installation programs to hundreds of Megabytes of Data that qualify as GARBADGE that the CD installs, to this apparently unsolvable problem (the guys at creative knew what they were doing when they didn't reply to my 3 emails) i really think i was not.
March 30, 2001 7:03:20 PM

You might have a bad board. I agree with you re. the old ISA cards -- I had an AWE64 that still works great. The only problem is modern mobos don't have ISA slots anymore so I was forced to buy a PCI sound card and modem. My Live 5.1 is working great in the A7V133, but I'll admit I'm using ME. The only thing left for you to try is a complete re-install of the OS. If you're not up for that, or if it doesn't work, guess you'll have to take the board back.

P.S. I assume you've tried swapping the slot the board is in, you've tried using the "clear configuration data on boot-up" property in the BIOS to make sure all old traces of the board are scrubbed from the CMOS, etc.?
March 30, 2001 7:37:24 PM

Re. your friend's problem with the "not enough disk space", I've seen this problem before with other software, sometimes when I had an incredible 20 or 30 gig available. I've concluded that some software must be using a 32-bit integer or something and maybe it's getting an integer overflow such that anything over 2 gig looks like a negative number or something. I've even seen this problem with microsoft products. The solution is a total hack, but if you have a smaller disk, or a disk with less space available, open a command window and set the TEMP (or TMP) environment variable to point at some directory on the smaller drive, then run the setup program from that command window. Another hack is to temporarily put a few gig of junk (just recopying/renaming a large file over and over will do it) until the drive space drops below 2G and you can complete the install, then you delete the junk. Yeah, it sux, but when you work with windows you get used to working around problems.

P.S. If you want I'll post a zip file with the drivers from my retail CD somewhere and you can try them -- they're known to work in at least one system (mine!).
March 30, 2001 9:33:43 PM

Well i do could that. But since i went there complaining about that the card wasn't good because i couldn't install the drivers and then.... ok let me explain.

Over here in Portugal i can sometimes get OEM versions of hardware, which means, most of them IS just the hardware (no CD or manual) at a very low price (heck most of the manuals and drivers are available thru the net).

This was the case with the card, it originally came with NO CD (but the store's fault) and i didn't think much of it. After d/l the drivers from Creative with no sucess on installing the card i assumed the problem was in the card.
So i went there complaining and then they returned the same card WITH the CD (which they apologised btw) saying that it worked with drivers on the CD. And so it did.

I'm AVOIDING going there again complaining about a faulty card that isn't faulty at all (the only thing faulty here are the neanderthals at Creative).

I have also an A7V133 and the reason i changed the AWE32 for the SBL 5.1 was the same (no ISA). Anyway the Windows 98SE is the same that i had with the P2/333 which be could causing this, but again i'm avoiding re-installing it because (first in my case there's allot of trouble involved) i'm waiting for my IBM 45Gb to that which should be soon.

RE-PS: Yes i've done that, anyway the card NOEW is in PCI SLOT #3, and if you see the manual (since you have an Asus A7V133 also) the INT-Line only shares the IRQs for that slot with the onboard sound card (which doesn't exists), so it's pretty much the best slot for a troublesome card.
March 30, 2001 9:37:36 PM

You might be right. But look at this.

My partition of Windows is only 2Gb in FAT16, and i tried installing LW3.0 with only 180Mb free. The Install program detected that i had 2Gb free?!?!??! WTH??? I think that's the problem the program doesn't correctly detect the available disk space (actually it's reporting the partition size as the free space) which kinnda answers the posts at the creative users group that most people say that to install LW most of them must have a FRESH installation of Windows (meaning almost the entire partition free).
March 31, 2001 4:19:55 PM

I would strongly recommend re-installing after switching the disk from a P2 to the AMD platform. Looks like we did almost the same thing, except I already had a 40G drive on my old P2/266 system. I just moved the drive to the new system and figured it would "find new hardware" and just work. Boy was I wrong, Linux crashed with a kernel panic (later traced to a missing instruction on the Athlon, but only after I reinstalled), W2K starts to boot but then BSOD. ME came up after complaining a lot, but my system was very unstable. This turned out to be due to too much (!) memory but I didn't know that so I reinstalled ME several times.

If I remember, I will try to extract the critical driver-related files from my retail CD and post them somewhere for you to download. I have the identical hardware (A7V133 and SB Live 5.1), so unless you have a bad board it should work.
March 31, 2001 5:54:05 PM

Ok i'll apreciate if you do that

They should be in \audio\english\win9xdrv or something like that

Don't believe blindly in what you hear! - Play safe! Play hard!
April 1, 2001 1:17:31 PM

First of all, thanks for your support dmcmahon, but i believe i've cracked the problem :) 

Yesterday i was looking at one of the two drivers the Creative GamePort Joystick devices uses... namely vjoy.vxd and i noticed that it's number was very odd (4.05.blabla) and i had DirectX8.1a installed so it should be more in the line of 4.08.blabla..

Could this be it? Hum... i reinstalled Directx8.1a and VOILÁ... instant solution.

It's funny sometimes what coes the problem is something that no one EVEN considers in terms of drivers in the Device Manager... all DirectX HAVE components have influence in the device drivers.

Anyways, it's either a faulty installation from Creative (which wouldn't come as a suprise), or transient technologie left over from my AWE32 (which i think was the case)... anyway 4.05.bla??? Isn't that DirectX5?? How the hell did that get here :) 

Don't believe blindly in what you hear! - Play safe! Play hard!
Anonymous
a b \ Driver
April 4, 2001 12:09:03 PM

Hi. Please someone help !!!
I have ASUS CUV4x mainboard - and exactly the same problem: I have that yellow mark on the "Joystic Gameport". I have Win98se and SB 5.1.

Here is what my manual shows:

___________________INT-A_______INT-B_____INT-C_____INT-D
PCI_slot1__________shared________-_________-_________-
pci_slot2___________-___________shared_____-_________-
pci_slot3___________-____________-________shared_____-
pci_slot4___________-____________-_________-_________shared
pci_slot5__________shared________-_________-_________-
AGP_pro slot_______shared________shared____-_________-
OnboardUSBcontroller_-___________-_________-_________shared
Onboard_audio/AMR____-___________shared____-_________-


-------------------------------------------------------
IRQ / PRIORITY / STANDARD FUNCTION
0 1 system timer
1 2 keyboard controller
2 N/A Programmable Interrupt
3 11 com2
4 12 com1
5 13 SOUND CARD (sometimes LPT2)
6 14 floppy disk controller
7 15 LPT1
8 3 System CMOS/Real Time Clock
9 4 ACPI Mode when used
10 5 IRQ holder for PCI steering
11 6 IRQ holder for PCI steering
12 7 Mouse Port
13 8 Numeric data processor
14 9 Primary IDE Channel
15 10 Secondary IDE channel

It also says:
If using PCI cards on shared slots, make sure that the drivers support "Share IRQ" or that the cards do not need IRQ assignments. Conflicts will arise between the two PCI groups that will make the system unstable or cards inoperable.


I hope this will help. Actually there is NOT an onboard audio card. I have tried reinstalling all the drivers... Nothing helped. I tried removing the "Gameport Joystic" drivers and reinstall them... nothing happened. I reinstalled Directx8 but nothing... again.
The Directx8a is different version from what I have? (I have Directx8).
Could someone give tell me what to do - step by step (what to do in BIOS, with drivers and IRQs etc).... please?
thanx

Blue Skies Bring Tears
April 4, 2001 11:35:38 PM

Look.. First of all... AVOID long posts (i have the same problem myself) people don't like to read much :) 

Could you give me the exact reason of the yellow mark?
In the device manager for the GamePort device it should say what is going wrong (in it's own cryptic way)... something like "Device Loader MMDEVLDRWHATEVER.VXD was unable to load the drivers (Code XXX.)"

And also gimme the Driver File Details in Driver tab... that's including filenames, manufacture and version...



Don't believe blindly in what you hear! - Play safe! Play hard!
Anonymous
a b \ Driver
April 5, 2001 5:04:39 AM

The MMDEVLDR.VXD device loaders could not load the device driver....
I've searched through Internet. Many people have this problem, on the joystick gameport...
I've tried everything. Changing OS PNP to "no", assigning IRQ 5 to SB LIVE , putting SB LIVE at the 3rd slot, changing the I/O settings, installing the latest VIA drivers for my motherboard, reinstaling drivers for SB LIVE, reinstalling Directx8....
(I have Asus CUV4x - win98se, sblive 5.1)

Creative MUST give us NEW drivers... Its time now...
the losers....
stark


Blue Skies Bring Tears
April 5, 2001 8:48:02 AM

The MMDEVLDR.VXD device loaders could not load the device driver....

after the "driver...." does it say a (Code 2.)?

My problem was with vjoy.vxd , it had a version of 4.05.00.01... when i installed DirectX8.1a it was updated to 4.08.00.01... the mmdevldr.vxd was the same and stayed the same, which leads me to believe that creative is shipping a version of vjoy.vxd that doesn't work on some systems.

Another questions, before the SBL 5.1 which soundcard did you have (if any)?

Look the problem shouldn't be at the PCI Slots, since the the GamePort Joystick doesn't take any IRQs, only 1 address.

About the PNP OS, yes you should set it to "no". In my system the SBL 5.1 is at IRQ9, an I reserved IRQ5 for the SB16 emulation because it can't share the same IRQ... so in practice you SBL 5.1 takes 2 IRQs... one for the card itself, and one for the SB16 emulation.

Don't believe blindly in what you hear! - Play safe! Play hard!
Anonymous
a b \ Driver
April 5, 2001 9:56:32 AM

First of all: There is NOT Directx8.1a!!! There is Directx8a. I'm saying this because I've done a lot of searching and wasted time to come to the above conclusion.

Yes it has "code2"

My "vjoy.vxd IS updated to ...4.08....

Before, I had SB Live! 1024 Player

I have heard tha setting the OS pnp to "NO" is not a good thing, and we ought to do this ONLY if we can't do anything else. (?)

Today (I hope) I'll download the latest VIA (Apollo 133 pro) motherboard drivers. I hope this might help me (I doubt it... I gave so many backs to buy the "precious" CUV4x and now what I've got is garbage... Damnt)

I'll try changing the IRQs (for the 1000th time) and ...
the I will throw my H'Y down from the balcony

thanx anyway
stark



Blue Skies Bring Tears
April 5, 2001 10:25:15 PM

Ok ok... my mistake... i mean't DirectX v8.0a (that's you get from talking from the top of your head :) ). Anyway if you still DirectX8.0 installed, upgrade to DirectX8.0a, that way at least your 98SE will be simillar in driver versions with my own.

Ok it's the same Code i got in my problemn, so the solution should be at vjoy.vxd.

Oh btw, I made a mistake on the codes, here are the correct values:

vjoy.vxd:
4.08.00.0400 (DirectX8.0a Virtual Joystic device driver)
mmdevldr.vxd
4.10.1998 (98SE bogged down standard device loader:)  )

Now...(i'm getting out of ideas here :) ), i assume you've tried everything imaginable? Like removing the device from the device manager and deleting the ctmisc.inf in both \windows\inf and \windows\inf\other PLUS deleting both *.bin in \windows\inf and then restarting the computer.

You should probably post this at the CL newsgroups (if haven't done yet) AND (pointlessly) sending an email to CL about this, because i'm fresh out of ideas.

But i can tell you this much:

-The OS PnP is a setting that says to the BIOS to configure or not, the IRQs and Addresses, of all NONBOOTABLE (ie: soundcards) devices. It's tottaly indiferent to Windooze if you set it to Yes or No,... i have No because my Linux won't properly detect my NIC since it says the BIOS has set it at IRQ0 (??!?).

-Changing IRQs won't most probably change anything since the GamePort doesn't use any, and what uses the IRQ is the SBLive driver itself and, in your case, is working perfectly.

-The same goes for change the slots, it shouldn't make any diference.


I just remembered something...have you tried to set the Address for the GamePort device manually in the device manager?
Anyway, if you have DirectX8.0a, please check the drivers version with your own... if they're the same... your in deep [-peep-] :) 
Anonymous
a b \ Driver
April 5, 2001 10:30:05 PM

CHECK MY NEW POST...
stark

Blue Skies Bring Tears
!