Sign in with
Sign up | Sign in
Your question
Solved

SSD Problems? Possibly?

Last response: in Systems
Share
February 18, 2012 11:21:27 AM

Where to start? I'm bad at this... Well, I guess I should start with my build:

OS: Win 7 Home Premium

MOBO: ASRock P67 EXTREME4

CPU: Intel Core i5-2500K Sandy Bridge 3.3GHz

SSD: OCZ Agility 3 120GB

GPU: HIS H685F1GD Radeon HD 6850

RAM: G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600

POWER: OCZ ModXStream Pro 500W

This was built last June and has been a great system for me, with minor problems. Every since building the system I have intermittently had Windows freeze and then the computer restart on its own (should have taken care of this a long time ago but I'm a procrastinator). After restarting and passing the initial load screen where you can choose to go into bios I will get a black screen that says insert boot device. If I restart after getting this screen I can go into windows with no problems.

I have checked the connections from my SSD to my mobo to be sure that no wires are loose, I have also checked wires for any damage and have even switched out wires. Again, this happens infrequently and was not on the top of my list of things to get done.

Now my pc is doing something new..... Sometimes it freezes and I have to restart but now I get a black screen with a flashing cursor. If I restart a couple of times I'm able to get into windows. I have also had the computer make a popping noise and restart and freeze at asrock logo. I have looked over the mobo for any busted capacitors and found nothing and neither have I smelled any smoke or seen any sparks when it happens. As best I can tell, the popping sound is coming from the power supply although I'm not 100% sure.

I don't really have any extra money laying around to throw at this thing but all parts are still under warranty. I would appreciate any input or at least a good course of action on where to start as far as doing a RMA.

More about : ssd problems possibly

Best solution

February 18, 2012 11:47:45 AM

try updating the firmware for the ssd, that sounds exactly like the problem i had with my first agility3, firmware update fixed it 100%.
Share
a b B Homebuilt system
February 18, 2012 1:15:24 PM

Locking up, temporary freezes where you could move the mouse but nothing works for like 1-5 minutes, random reboots, SSD not detected on first reboot, all these issues where corrected since I updated my SSD's firmware to the latest revision. Have not had a single issue since for months.
m
0
l
Related resources
February 19, 2012 6:44:36 PM

Thanks for the suggestions guys. I have tried to do a firmware update and it continuously fails. I have checked connections and traded out wires and still I get failure to update firmware every time I run the update (I did read instructions closely, I know that I cannot update on the drive that is currently running windows).

I was comparing a friends solid 3 with my agility 3 and I notice his has a green led lit up and mine has a green and red led lit up. I cant seem to find much about the leds but I assume that my drive has an error on it. The only viable reason I can think of, other than its defective is that when I installed windows 7 I did it in ide mode and went back at a later time and added the ahci drivers. I wonder if that would cause the red led to light up.....

At this point I'm trying an alternate method of updating firmware using linux, if that doesnt work do you think it would be worth the trouble of reinstalling windows in ahci mode? or should I just wipe it and rma it?
m
0
l
February 19, 2012 8:24:42 PM

Best answer selected by vickca86.
m
0
l
!