No display with Radeon HD 5670 Graphics card

Hello,
I recently purchased XFX Radeon HD 5670 graphics card and installed in PCI Express slot. But when trying to boot the system, I can hear the computer is booting with single beep sound but not getting any display. Monitor is not getting any signal.

My System config
AMD Phenom X2
MOBO-Gigabyte GA-M61PME-S2P
Power: 450 Watts with 19 AMPS at +12 volt line

Please help me to resolve the issue...

Thanks
Praveen
6 answers Last reply
More about display radeon 5670 graphics card
  1. Do you have a display connection built into the motherboard? What did you use before this 5670 card for video?
  2. HI,
    I used inbuilt display (Nvidia 6150SE nforce430) come with mobo.

    Thanks
  3. Does your PC work when using this built-in display? If it does, then check in your BIOS what the Default Display Adapter is set to. Should change it to PCI-E.
  4. Yes. Inbuilt display works. I also set to 'initiate graphics on PCI Express slot' in BIOS settings. But still no display...

    Thanks
  5. Card may be faulty... did you plug the power cable into the card? Maybe your PSU isn't strong enough to run this card... Make sure you have the monitor set to the right input... like digital(DVI) or analog(VGA)..
  6. As per card specifications, it won't require any external power supply (max power consumption 75W). I have HDMI cord and connected to monitor HDMI port but with no success :( :( :cry:
Ask a new question

Read More

Radeon Graphics Cards HD Graphics