Sign in with
Sign up | Sign in
Your question

HDMI Audio stops after TV turned off

Last response: in Graphics & Displays
Share
December 21, 2011 3:11:55 PM

Hi all.

I have resently purchased a MSI 2GB HD 6950 Twin Frozr III Power Edition/OC.
I am using this to connect my Windows 7 HTPC to my TV via a HDMI 1.4 cable.
I have set the ATI HDMI speakers as my Default Playback Device and also disabled all other audio devices.

I can watch any type of video and hear the audio fine, however when I switch off my TV the HDMI audio device disapears. When the TV is switched back on again there is no sound as the Playback Device isn't refreshed.

To get around this I have to open up the Playback Devices menu, give it a few seconds to see the ATI HDMI Speakers and it automatically selects them, click OK and I have audio again.

I would like to know if anyone else has this problem?

If I can get my system to automatically detect my TV being turned back on?

or if I can perminantly keep my ATI HDMI Speakers selected regardless of the state of my TV?

Thanks for reading,
January 1, 2012 1:19:24 AM

I'm having a similar problem, seems to have started occurring after I applied the latest update. Really annoying as the only way I've been able to fix this is to reboot the computer.
March 30, 2012 1:44:49 PM

Hi gitargr8.

Didn't see your post till now, sorry.

I don't seem to have this problem any more. Just started working as normal. May have been a driver update?
Are you still experiencing this or has yours too rectified itself?
Related resources
!