Sign in with
Sign up | Sign in
Your question

Video flicker on one of my monitors

Tags:
  • Radeon
  • Video
  • Monitors
  • Graphics
Last response: in Graphics & Displays
Share
December 24, 2011 1:30:46 AM

I've got a Win7 boot drive on my Mac Pro. I've been using it for years with no problems. Recently after some updates (both Windows and ATI), I get a flickering on the bottom half of one of my two screens. If I go into Catalyst settings and fiddle around, I can make it start happening on the other monitor. So I'm going to assume it's not a monitor or cable issue. Here's an example:

http://youtu.be/64JM9zCHYkk

More about : video flicker monitors

a b C Monitor
December 24, 2011 1:36:57 AM

I would recommend hitting the AMD driver archive and dropping back one or 2 revisions. Uninstall the old driver first.

http://support.amd.com/us/Pages/AMDSupportHub.aspx

Also, if it happens in lets say safe mode, then it may be a monitor or cable issue, but i doubt it is.

What resolution are you running?
m
0
l
December 24, 2011 2:00:47 AM

1920 x 1200, but I've tried lesser resolutions too. I'll have to try going back a revision or two when I boot back into Windows. Thanks for the quick response.
m
0
l
Related resources
a b C Monitor
December 24, 2011 2:13:05 AM

Look for the option called "Reduce DVI frequency on high-resolution displays" and "Alternative DVI operational mode". Try to mess with those

It is in CC under My Digital Flat Panels

You are at the MAX for a single link cable and this may just be the cause.

Fingers crossed.

That assumes you are on a DVI or HDMI screen.

But if the lesser resolutions did not help, this will most likely do nothing for you.
m
0
l
December 24, 2011 7:31:56 AM

Nope, I already had those checked in Catalyst. I'm wondering if it's interference from another program. As the system is still booting, It doesn't occur. But after everything is loaded, that's when it starts up.
m
0
l
a b C Monitor
December 24, 2011 2:55:34 PM

You can use msconfig to stop programs from starting with the system, but do not shut off anything essential.

It is a bit trial and error, but should cover most 3rd party apps by stopping them. With some testing you can find what is causing the problem. There may be a popup about some kind of fixit, that is not what i sent you for.

http://support.microsoft.com/kb/331796
m
0
l
December 24, 2011 5:57:29 PM

I hope you can fix it. Try setting the catalyst settings to default and see if that works. I had a prob with my old vid card that looked just like that in Oblivion before my pc would freeze. It ended up being bad ram and only happened when I stressed the card. If you can't find the prob in software then see if the card does anything weird in osx when you stress it.
m
0
l
December 24, 2011 6:34:43 PM

Well, it seems it was Catalyst causing the problem. I turned everything off in msconfig, and on reboot everything was fine. On a hunch I restarted Catalyst, and the problem came back. It's been off for a couple hours now, and now flicker (yet). Thanks Nukemaster.
m
0
l
a b C Monitor
December 24, 2011 6:39:49 PM

Any time(still a shame you are now without a control panel). I just installed the latest drivers for my ATI card thinking it may be that, So far its good, but i was like 5 or more driver revisions behind. Fingers crossed.

I would contact ATI to let them know so they can fix it in the next release.

http://support.amd.com/us/Pages/AMDSupportHub.aspx
m
0
l
!