Sign in with
Sign up | Sign in
Your question

Password-protected sharing won't be disabled

Last response: in Windows 7
Share
January 9, 2012 1:58:07 AM

Greetings Earthlings,
I can't disable "password protected sharing" in Win7 (home premium, came pre-installed on new laptop, less than a week old). I can disable the setting in advanced network settings and save, and it stays saved when i re-open settings, but no matter what I change, whenever I try to open the network share from an XP machine it challenges me for a login/password.
January 9, 2012 5:47:54 AM

did you try entering nothing and pressing whatever the login button is?
m
0
l
a c 232 $ Windows 7
January 9, 2012 11:28:15 AM

If it's an admin share like C$, then you need an account to access the share.
m
0
l
Related resources
January 9, 2012 9:43:27 PM

@Hawkeye22: I can't even open the shared computer without being challenged for a login/pass; at the moment all I have shared is an empty folder meant for network sharing / testing.

@alidan: if I enter a junk login/pass, it does let me in -- but the next time I restart that machine, I need to do so again. it will work, but it is beyond pestersome and it's annoying that I can't figure out how to make it go away.
m
0
l
a c 232 $ Windows 7
January 10, 2012 10:47:29 AM

Is the win 7 laptop part of a "homegroup"? It seems that homegroup sometimes has weird behavior in regards to the standard permissions. If it's in a homegroup, try temporarily removing it from the home group and see if it works.

Also, I had to do step 2 on this page to get admin shares working properly. Perhaps it works with normal shares too. You need to reboot after making the registry setting.

http://blog.hansmelis.be/2009/09/06/administrative-shar...
m
0
l
January 11, 2012 2:33:43 AM

Hawkeye22 said:
Is the win 7 laptop part of a "homegroup"? It seems that homegroup sometimes has weird behavior in regards to the standard permissions. If it's in a homegroup, try temporarily removing it from the home group and see if it works.

Also, I had to do step 2 on this page to get admin shares working properly. Perhaps it works with normal shares too. You need to reboot after making the registry setting.

http://blog.hansmelis.be/2009/09/06/administrative-shar...


It started off as part of a "homegroup" and later I disabled the homegroup thing, and it seemed to make no difference.

I'll try your link and see what happens, thanks.


Followup:
it didn't seem to change anything :-/
I am still challenged for a login/pass when first trying to open the share (the computer itself) from an XP machine. My wife's PC, on the other hand, also running win7, lets me in just fine.
m
0
l
a c 232 $ Windows 7
January 11, 2012 11:04:53 AM

I had no problems getting my xp computer to see my win7, but I had an identical account/password on both computers. I had also changed my networks settings to use the user accounts for sharing, not homegroup. I did it like this:

Open the Control Panel, select Network and Internet, then Network and Sharing Center. Once there, in the left-hand pane choose Change advanced sharing settings. There are two lines that are circled. Try changing both as shown.


http://download.windowssecrets.com/images/wsn/W20101014...
m
0
l
January 12, 2012 11:31:37 PM

Hawkeye22 said:
I had no problems getting my xp computer to see my win7, but I had an identical account/password on both computers. I had also changed my networks settings to use the user accounts for sharing, not homegroup. I did it like this:

Open the Control Panel, select Network and Internet, then Network and Sharing Center. Once there, in the left-hand pane choose Change advanced sharing settings. There are two lines that are circled. Try changing both as shown.


http://download.windowssecrets.com/images/wsn/W20101014...


I have both of those settings how you have them, though I also have the "password protected sharing" option set to "off". FWIW, i have no problem "seeing" my win7 share from the XP machine -- the issue I have is that I can't get the password challenge prompt to go away (no matter which settings I change, or how many times I restart).
I have even tried the two registry tweaks suggested at the bottom of this thread, with no change: http://social.technet.microsoft.com/Forums/en-US/w7itpr...
m
0
l
a c 232 $ Windows 7
January 13, 2012 10:58:16 AM

I understand that you can see the share, but are promted to authenticate. I had a similar problem but with admin shares. This is what I had to do to fix it. I don't know if it will work for you. On the win 7 machine do:

Open Regedit, navigate to HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System – create a new DWORD:

LocalAccountTokenFilterPolicy with the Value of 1

Now my admin shares work and I'm not prompted to authenticate. You will need to reboot in order for the change to take effect.
m
0
l
January 13, 2012 8:56:15 PM

Hawkeye22 said:
I understand that you can see the share, but are promted to authenticate. I had a similar problem but with admin shares. This is what I had to do to fix it. I don't know if it will work for you. On the win 7 machine do:

Open Regedit, navigate to HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System – create a new DWORD:

LocalAccountTokenFilterPolicy with the Value of 1

Now my admin shares work and I'm not prompted to authenticate. You will need to reboot in order for the change to take effect.


I tried this already (per your previous post, this appears in the link you gave), and it didn't seem to work. however, i'm not sure I did a proper restart afterward, and I will try that now, and let you know if there's any further luck.

Edited to add: still no luck after a full restart :( 
m
0
l
a c 232 $ Windows 7
January 16, 2012 11:07:42 AM

Doh! Yeah, sorry. I forgot I had already sent you that link. At this point, I'm out of options.
m
0
l
January 17, 2012 3:42:13 PM

Ah well, thanks for the help. If you come up with any further ideas, please let me know :) 
m
0
l
December 4, 2012 6:37:32 PM

drakar2007 said:
Greetings Earthlings,
I can't disable "password protected sharing" in Win7 (home premium, came pre-installed on new laptop, less than a week old). I can disable the setting in advanced network settings and save, and it stays saved when i re-open settings, but no matter what I change, whenever I try to open the network share from an XP machine it challenges me for a login/password.


Check that the Guest account has no password, even if its disabled. I had this show up on a friends account and just happend to enable the guest account to show that it was password protected. First enablethe guest account, then open a cmd as admin, type 'net user guest *' it will prompt you to change the guest password, just dont enter one and hit enter. close the user contrl panel and go back in and the guest account shouldn't have a password on it.


that helped me, hope that helps you and others.


Got some of the info here: http://social.technet.microsoft.com/Forums/en-US/w7itpr...

didn't read much, most sentances longer than 5 - 6 words get fuzzy and ADHD kicks in...
m
0
l
!