Sign in with
Sign up | Sign in
Your question

No display after GTX 550 TI install on Z68

Last response: in Graphics & Displays
Share
December 24, 2011 4:06:26 PM

Hi everyone. I have a few questions. First off, this is the hardware I have:

AsRock Pro3 Gen3 B3
Core i7 2600k
Corsair HX650
16GB G.Skill DDR3-1333 [F3-10666CL9D-8GBNT (X2)]
Crucial M4 64gb (OS)
WD Blue 500gb (Storage)

Trying to install PNY GTX 550 TI

I have windows 7 64 bit installed as of last night.

Basically when I try to install the PNY GTX 550 TI I get no display. Ive tried plugging into the graphics card withe the DVI cable and into the mobo outputs on both DVI and VGA. I changed the BIOS under Primary Graphics Adapter to PCI with no go and PCI-E got no display either. I think the computer is posting and going to Windows but I'm not entirely sure because I dont have a chassis speaker and the SSD doesn't make any noise (obviously). I don't know if I have to install Lucid Virtu to get the card to work. When installed, the fan on the card spins and the 6 pin connector is in firmly as is the card in the PCI E slot I don't have any other cards installed and only have one PCI-E slot. The display works fine without the card installed, just wont come on without.

I'm running the 1.1 BIOS version. there is and update but I don't know if that is the problem.

Memory has been run through Memtest86+

I have not tried to install the drivers for the card yet. Should that be done before or after the card is installed.

Thanks in advance!
December 24, 2011 4:24:39 PM

Just tried to install Lucid Virtu. Apparently you need to have the card installed to install Lucid.

Update: Switched The Primary Graphics Adapter to "Onboard" and Ive got display now. I'm going to install the drivers and see what happens. I just checked in the BIOS and its still set to Onboard although the card shows up in the device manager.

Update 2: Changed Primary Graphics Adapter (PGA) to PCI Express and I have display still. Device manager recognizes the video card as it should. I had the DVI cable plugged into the motherboards output and disabled the onboard graphics, everything went black. Switched the cable to the card and went back online. Before that I ran the WEI benchmark and had the same result (6.4 or something). With Intel HD disabled and the DVI plugged into the card its up to a 7.3. I'm going to install and run Furmark and see what that benches at. Then install Lucid Virtu, enable Intel HD and see if it benchmarks the same score.

Update 3: Ran Furmark. The GTX scored a 1444 and around 24 to 25 fps. The Intel graphics were around 200 something and around 4 fps. Big difference. Still trying to figure out Virtu and if I really need it.

Hopefully this can help someone that has the same problem.
m
0
l
!