Sign in with
Sign up | Sign in
Your question

Wake on lan problem

Last response: in Networking
Share
March 13, 2011 6:43:44 PM

Hi there Everyone!

I am having a very annoying problem, and it drives me mad, that I just can’t solve it. I am trying to set my computer to be able to wake it on lan (magic packet) with my android phone. Here is my hardware configuration and settings:
Power supply: Codegen 400 Watt, model: 300xx (atx 2.03)
Motherboard: ASRock 4CoreDual-SATA2
Bios settings:
Network card: VIA VT6102 Rhine II Fast Ethernet Adapter (driver version: 3.84.0.1)
Network card settings: in the settings of the network card (power management tab) the following checkboxes are ticked: allow the computer to turn off this device to save power, allow this device to wake up the computer. In the advanced tab I have set the Wake up type to Magick Packet.
Router type: D-Link DI-524
Router settings: I have set a virtual server for the wake on lan with the following settings: Private IP: my ip address; protocol type: both; private and public port: 9; schedule: always

I tried to wake my computer from my android phone and from the site http://www.dslreports.com/wakeup but unfortunately no luck at all.

My problems are the followings:
1. I do not have any LED on the motherboard to check if the network card is still awake after I shut down the computer.
2. When I send the magic package from the website or phone, nothing happens.

Is there any setting or option that I left out? Is there a way to check whether the magic packet arrives to my computer or not (a software or something to check while online with the computer or something)?

Thank you for your help in advance!

More about : wake lan problem

March 13, 2011 6:51:30 PM

For security reasons, most routers do not allow access to the broadcast IP (x.x.x.255) from the WAN side of the router (something WOL needs). Thus, WOL will never work remotely.

That said, you can configure a dd-wrt router w/ remote WOL using the instructions in the following threads (those are my comments to other ppl having similar troubles w/ dd-wrt -- it can be tricky for a first timer, but it does work w/ dd-wrt).

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=514681
http://www.dd-wrt.com/phpBB2/viewtopic.php?p=506550

HTH
March 13, 2011 7:23:31 PM

Hi Eibgrad!

This is my very first try... so my knowledge is close to nothing. So basically you are saying that I need to install dd-wrt on my router, and afterward I need to make some changes in the configuration?
Am I understanding it right?

Thank you in advance!
Related resources
March 13, 2011 7:36:14 PM

Correct. However, your particular router (DI-524) is not supported by dd-wrt. :( 
March 14, 2011 7:19:20 AM

I see, so in this case I need to buy a supported router model or I won't be able to wake my pc on lan?

Thank you for your help!
March 14, 2011 12:47:48 PM

It's either get a dd-wrt compatible router, or find a router w/ stock firmware that supports broadcasts from the WAN side (I'm not aware of any at the consumer level, but that doesn't mean they don't exist).

There are some other less than ideal solutions. For example, LogMeIn has a WOL feature, but that requires at least one other machine be connected to LogMeIn from the same network at the same time (that’s how LogMeIn gets around the same problem, they use that existing connection as an entry point to your network). As I said, not ideal if you assume the whole point (at least for a home user) is to leave ALL your machines off and only enable them as necessary. But I thought I’d mention it anyway.

I’ve also seen people use techniques other than WOL. For example, a hacked cellphone spliced into the PC power connection; you call it, the PC turns ON. Or you could consider a remote IP power switch (this has the advantage of not just starting your PC, but restarting it w/ a power recycle should it hang, or shutting it down completely).

But when it comes to a pure WOL solution, the only simple, reliable solution I’ve found was dd-wrt. In fact, dd-wrt in combination w/ a remote IP power switch makes a nice combination, covers all the bases.
!