Sign in with
Sign up | Sign in
Your question

Metro 2033 Lagging badly

Tags:
  • Nvidia
  • Graphics
  • Product
Last response: in Graphics & Displays
Share
December 25, 2011 9:14:50 PM

Hi there...

I have recently bought 2 MSI GTX560 Ti's Twin Frozr II that come with a nice OC of 58Mhz (880 vs 822) and i OC'ed them to 930Mhz, and i must say that i couldn't be more happy with them, they beat a GTX580 by 40% and the HD7970 by 10% in 3Dmark11 on the extreme preset and by a larger margin on performance which only makes this problem even more weird.
I bought them 2 days ago and i decided to start throwing heavy games at them, warhead, bf3 and metro 2033 all at 1920x1080 with everything set to the max and MSAA 4x, and metro 2033 is running at 60~70 fps but that is only until... i trip on a can... or fire a single shot... or thouch anything else... then the fps drops into a ridiculously low 1~2 per second, i believe this has something to do with physics engine, possibly drivers or a patch problem... Does anyone know anything about this?

And by the way... while testing these cards with bf3 i managed to get an average always between 70~90fps with everything maxed out but i need to disable motion blur otherwise the game drops to 15~20fps... i don't actually like that game so it doesn't bother me much but it does bother me the fact that i spent 400€ on these cards and i expected to see them handle any of these games with ease and that is simply not happening but with stupid things... Having everything maxed out on BF3 with a constant 70~90fps but then start lagging when we enable motion blur is nothing short of frustrating.... believe me...

Does anyone know anything about this?

Thanks

EDIT: Check my specs on my profile if needed...

More about : metro 2033 lagging badly

a b Î Nvidia
December 25, 2011 9:41:34 PM

surprise, 2 560's are NOT better than a 580 even though benchmarks will show more FPS. The architecture is completely different. You're going to have to futz with the game settings until you find out what's holding you back. i would first try going into the nvidia control panel and make physx run off the processor....... ( should have listed rest of your hardware ). then I would systematically lower or turn off certain settings until I found out what the problem is........ in the games control panel........ work on the tessellation settings and others. don't have the game loaded anymore so I can't give more suggestions.

and I have to say it......... video cards with 1gig of ram are becoming more and more useless at resolutions above 1600. 2 - 1gig cards in sli still only provide 1gig of video ram.
December 25, 2011 9:46:18 PM

First, check nVidia control panel - what device is selected for PhysX?

Second, what drivers are you running? I suggest the latest beta 290.53.

Your motion blur problem is weird... I have it enabled with just one 560 Ti and it really doesn't care, maybe drops 2-5 fps but that is all.
Related resources
a c 94 Î Nvidia
December 25, 2011 10:12:49 PM

I just finished playing Metro 2033 on twin 560's about a month ago .... They were Asus TOP models, running at 1020 Mhz (CPU at 4.8Ghz) on 1 20 Mhz minitor....that's Son No. 3's box ..... play throughout was smooth, I never stopped to measure fps but at max settings, I played end to end w/ narry a hitch......it was a result of that experience that I dropped the settings down to 4.6 GHz on the CPU and 980 on the twin 560's .... the box just didn't need it so I backed it off to run a bit cooler. Also played it for comparison's sake on Son No. 2's 580 (default settings for they 580, never looked to see that they were) ..... the 580 ran into a hiccup or two but was more than satisfactory 99.9 % of the time.
December 25, 2011 10:16:07 PM

Probably won't be an issue, but you could try to turn off/on vsync.
December 25, 2011 10:19:32 PM

rocknrollz said:
Probably won't be an issue, but you could try to turn off/on vsync.


That can be a difference between life and death, actually :)  V-Sync is known to kill framerates in certain games. I disable it wherever I can.
December 25, 2011 10:44:52 PM

Okay guys... thanks for all your help so far...

Turns out i found out the problem with both metro and bf3...

With metro the problems is as i suspected, physics, i disabled advanced physicX and it now runs smoothly, but that is still a problem to me, when i bought these two 560's ti i could have bought 2 6950 instead, two of those are bit more powerful than two 560's Ti's and as far as i know, but two 560 ti's already give me everything i need to run whatever i want on max at 1080p, or so i think, so i got them for the PhysicX and now running PhysicX is turning out to be a problem... I already tried to set PhysicX as automatic, gpu1, gpu 2 and even set the gpu 2 as a dedicated physicX card on Nvidia control panel and no luck so far...

My drivers are the latest beta version 290.53 (or at least i think they are a beta version)... I believe this must be a physicX drivers problem... I have PhysicX System Software 9.11.1107 instaled...

Now with BF3 the problem is with the ambient occlusion and not motion blur, while poking with the settings i disabled it at the same time i disabled motion blur and forgot it, so when i got it to run smoothly i though it was motion blur but now after enable it again with HBAO i started having low fps again... but i don't know if the problem is that setting being too demanding or if the problem is that setting making the game require more than 1GB of vram... or anything else...
a b Î Nvidia
December 25, 2011 10:47:27 PM

still didn't list the rest of your hardware. did you try making the physx run off the processor ? an inadequate PS can also cause you problems.
December 25, 2011 11:00:29 PM

Quote:
Do your fps match my GTX 480 at maximum settings in BF3?
38fps minimum /45average/ 60max v-synced

I am having trouble running it with HBAO enabled but with SSAO i am having an average around 60~70fps depending on the zone and the lowest i have seen it go was 46fps but i am not always looking at the fps so i believe than that is not the lowest value i got but i never have seen it lagging... So, i don't know how much demanding HBAO is but i believe these values will get lower...

swifty_morgan said:
still didn't list the rest of your hardware. did you try making the physicx run off the processor ? an inadequate PS can also cause you problems.

My hardware can be seen on my profile, just click on "more information" under my avatar and then click on "member configuration"...
Also... i already tried to set physicX to run on both gpus, i also tried to set it to automatic and even tried to set the second graphics card as a dedicated physicX card...
December 25, 2011 11:04:52 PM

Quote:
I use HBAO and 4xmsaa on ultra with the fps i posted.


Do you know if HBAO increases vram usage significantly ? Because i suspect i am running out of vram...
I am going to check the AA settings it is using...
December 25, 2011 11:15:49 PM

Quote:
I use upto 1500mb in Kharg island (large map)


Okay... so i enabled HBAO and it's running without problems now and i didn't do anything else, it just went away, maybe it was some background process, i simply don't have a clue... the AA is also set to MSAAx4
Anyway, i haven't had much time to come up with a precise fps average but comparing to the zone were i was before enabling HBAO i didn't noticed any considerable fps drop, but to make this comparison more precise i should warn you that i am only using BF3 to test these cards and i am not playing it, im am still on the first level were we get ambushed, and the 48fps i got as a minimum were when two guys on a balcony started firing rpg's at me exploding a lot of cars... But that can't be the most demanding part in the game...
December 25, 2011 11:25:11 PM

Quote:
My fps are taken from multiplayer in a 64man battle.
Singleplayer i get a minimum of around 45fps.


well.. i guess your 1.5GB of vram vs my 1GB is making a difference... but i certainly wasn't expecting such a small margin between one GTX480 and two GTX560 ti's...
December 25, 2011 11:38:46 PM

Quote:
My 480 does beat stock GTX 580's as it is overclocked very highly on custom air cooling.
Plus my PC is dedicated to gaming, so i run nothing in the background.


Wow... i imagine your temps and consumption must be very high, a 480 has almost the exact same performance of a 570 last time i checked but the 570 runs much cooler, has lower consumptions and it's much quieter and it needs a great OC to come near a 580, so i can only imagine what have you done with your 480... have you posted any benchs yet? I bet some guys would love to see that...
a b Î Nvidia
December 25, 2011 11:40:44 PM

I don't care if you put it on auto or picked what card.......... did you specifically select the processor ?
December 25, 2011 11:44:23 PM

swifty_morgan said:
I don't care if you put it on auto or picked what card.......... did you specifically select the processor ?


No, i did not selected the cpu (if that is what you mean by processor)... but i believe that with the cpu it will lag like hell but if you want it i can try it...
a b Î Nvidia
December 25, 2011 11:56:29 PM

WOW, look at that e-penis... LOL................ anyways, yes, I have in the past made the cpu run the physx and it has help depending on the other hardware and situations. I wouldn't have said it if I didn't want you to try it.

I will also say that I tried to get that game to run on a 560 to no avail. just ran like crap. whether it was a bad card or what i can't remember any more. I know i had to mess with the game settings a lot.

a b Î Nvidia
December 25, 2011 11:58:38 PM

LOL...................... also check your refresh rate. guess it should be 60 ?.... depends on monitor.
December 26, 2011 12:05:45 AM

swifty_morgan said:
WOW, look at that e-penis... LOL................ anyways, yes, I have in the past made the cpu run the physx and it has help depending on the other hardware and situations. I wouldn't have said it if I didn't want you to try it.

I will also say that I tried to get that game to run on a 560 to no avail. just ran like crap. whether it was a bad card or what i can't remember any more. I know i had to mess with the game settings a lot.


I am not having problems with any settings except physicX and if 2x384 cuda cores aren't enough for metro than i don't know what's enough... clearly something is wrong with my game, or my drivers... i am going to reinstall my OS tomorrow and try again...

swifty_morgan said:
LOL...................... also check your refresh rate. guess it should be 60 ?.... depends on monitor.


Yes.... my refresh rate is 60hz...
December 26, 2011 12:29:30 AM

Quote:
This was a benchmark of crysis at very high and 4xAA with my GTX 480 only at 800 core...
http://www.tomshardware.co.uk/forum/forum2.php?config=t...


Is your 480 a evga sc?
Anyway, in that video it's hard to make a decent comparison because the videos are not synced but it seems that the 580 manages to stay ahead by a significant margin, but with your actual OC and without the 580 OC i believe your 480 will definitely keep up with a 580, with a 1000w psu i would consider sli in you case, you would be set for years and i don't think that a 2500k at 4.5Ghz would bottleneck them... though i wouldn't keep the oc in case you decide to get another 480, or at least not that high... but i guess you would need to change that cooler since it's almost taking three slots...
a b Î Nvidia
December 26, 2011 12:29:40 AM

did you try each card individually and in each slot ?
December 26, 2011 12:33:50 AM

swifty_morgan said:
did you try each card individually and in each slot ?


Not yet... but i think that if it is a problem with any of the cards i would have had problem with other games and in Mafia2, Skyrim, Dragon Age 2 and Mass Effect 2 i haven't any problems...
a b Î Nvidia
December 26, 2011 12:35:20 AM

hope the OP doesn't forget to come back to HIS thread so we can find out if he discovered a solution.................
a c 173 Î Nvidia
December 26, 2011 12:42:29 AM

swifty_morgan said:
surprise, 2 560's are NOT better than a 580 even though benchmarks will show more FPS. The architecture is completely different. You're going to have to futz with the game settings until you find out what's holding you back. i would first try going into the nvidia control panel and make physx run off the processor....... ( should have listed rest of your hardware ). then I would systematically lower or turn off certain settings until I found out what the problem is........ in the games control panel........ work on the tessellation settings and others. don't have the game loaded anymore so I can't give more suggestions.

and I have to say it......... video cards with 1gig of ram are becoming more and more useless at resolutions above 1600. 2 - 1gig cards in sli still only provide 1gig of video ram.


Really? So they are not both Fermi's then?
a b Î Nvidia
December 26, 2011 12:46:49 AM

to me both GF110 and GF114 was configured in a different way but still both was still based on the same architecture.
December 26, 2011 12:47:43 AM

Quote:
No.
My next gpu is a 7970 in jan-feb time.
This 480 is going to my brother ;) 
And yes it is a EVGA SC (bios flashed).
Originally a Point of view TGT.


I also though about waiting for the HD7000 series but once i saw the first reviews i changed my mind, that card is mind blowing for a single card but lets not forget the price which is going to be be around 550~600$ if i am not mistaken... For that kind of money you can get more powerful solutions though they will all be SLI or CF configs with all their inherent problems but in my case i spent 400€ (less 100€ than a 7970) and the resulst can be seen here (just scroll down a bit and check the result i got on 3Dmark11)...
But if you really want a single card i would probably wait for the Kepler GPUs...

If that graph is correct i think AMD is in big trouble...
a c 173 Î Nvidia
December 26, 2011 12:49:20 AM

So have you sorted out your issue with Metro yet?
December 26, 2011 12:50:21 AM

swifty_morgan said:
hope the OP doesn't forget to come back to HIS thread so we can find out if he discovered a solution.................


Tomorow after reinstalling the OS i am going to test it again... I have recently upgraded almost my entire system (motherboard, cpu, ram and vga's) and haven't reinstalled the OS so i think there must be a lot of stuff here messing with registries and drivers...
December 26, 2011 12:52:13 AM

Mousemonkey said:
So have you sorted out your issue with Metro yet?


Not yet, the problem is when i turn on the advanced physics option but that shouldn't be a problem which makes it one... i think it's something with the drivers or the PhysicX software...
a c 173 Î Nvidia
December 26, 2011 12:56:20 AM

I run it with everything except DOF and it runs smooth as silk, enabling DOF makes it as choppy as hell though.
December 26, 2011 1:06:18 AM

Mousemonkey said:
I run it with everything except DOF and it runs smooth as silk, enabling DOF makes it as choppy as hell though.


I am going to disable it and see what i get but with my previous card which was a GTX 570 i didn't had any trouble with dof, but i was in DX10 mode without tessellation and some other stuff which i don't remember, but as far as i have seen in a lot of other games that use DOF it never seemed a demanding effect... but i believe that in metro, having all the settings maxed out (at 1920x1080 in my case) makes us exceed the 1GB of our 560's and that is the problem...
a c 173 Î Nvidia
December 26, 2011 1:10:46 AM

I'm also running @ 19 x 10 and in DX11 mode with tess and PhysX and having tested a GTX580 in the same rig I know the 560's are giving better framerates.
December 26, 2011 1:14:04 AM

Mousemonkey said:
I'm also running @ 19 x 10 and in DX11 mode with tess and PhysX and having tested a GTX580 in the same rig I know the 560's are giving better framerates.

Did you had DOF enabled with the 580?
a c 173 Î Nvidia
December 26, 2011 1:20:16 AM

CryptorX said:
Did you had DOF enabled with the 580?

I tried it with and without and it was definitely smoother without.
December 26, 2011 1:21:04 AM

Damm... i enabled the advanced physicX and disabled DOF and now i am getting an average of 70~80fps and the lowest i have seen it going was 38fps with fraps in that part on the beginning where we get surrounded by those mutants...
December 26, 2011 1:22:02 AM

I guess need to read a lot more about DOF...
a c 173 Î Nvidia
December 26, 2011 1:23:33 AM

CryptorX said:
Damm... i enabled the advanced physicX and disabled DOF and now i am getting an average of 70~80fps and the lowest i have seen it going was 38fps with fraps in that part on the beginning where we get surrounded by those mutants...

And is that better than you were getting before? :whistle: 
December 26, 2011 1:30:07 AM

Mousemonkey said:
And is that better than you were getting before? :whistle: 

Much better but i still think i am having vram limitations...
Before i was having an average of 70fps but when i fired a gun or did anything else that used the physics engine the game dropped to 2-3fps and then stayed that way for a few seconds even after all the particles had disappeared, now i don't have any physics problems with advanced DOF disabled... i guess it's really a vram issue since dof and physics have nothing in common apart from having data being stored on the vram (i think)
a c 173 Î Nvidia
December 26, 2011 1:35:29 AM

CryptorX said:
Much better but i still think i am having vram limitations...
Before i was having an average of 70fps but when i fired a gun or did anything else that used the physics engine the game dropped to 2-3fps and then stayed that way for a few seconds even after all the particles had disappeared, now i don't have any physics problems with advanced DOF disabled... i guess it's really a vram issue since dof and physics have nothing in common apart from having data being stored on the vram (i think)

Are you still running in SLi? Have you tried downclocking the the cards to 822mhz?
December 26, 2011 1:38:43 AM

Mousemonkey said:
Are you still running in SLi? Have you tried downclocking the the cards to 822mhz?


Yep... still running in sli... and no... i haven't tried downclocking the cards, why should i? Do you think this may be instability problems?
These cards already come with a factory OC of 58Mhz (880Mhz), i only raised it by 50Mhz...

btw... you just reached 32000 posts =)
a c 173 Î Nvidia
December 26, 2011 1:46:06 AM

CryptorX said:
Yep... still running in sli... and no... i haven't tried downclocking the cards, why should i? Do you think this may be instability problems?

Your cards were clocked @880mhz were they not? I have found that there seems to be times when my cards will not like running @900mhz but they run just fine and stable @825mhz. I've only tried a few DX10 and DX11 titles though due to time constraints.
December 26, 2011 1:56:34 AM

I am goint to run some tests tomorow but right now i am barely managing to keep my eyes open, it's 4am here and i have too much blood in the caffeine... Tomorrow i will reinstall the OS and run some tests and then i'll let you guys know the results...

Thanks for all the help so far...
December 26, 2011 3:16:30 AM

I just finished Metro2033 with settings on "High" / Advanced PhysX OFF at 1920x1200 res. "Very High" produced a framerate that was playable but just not as smooth as I like. I am running the following:

2x MSI GTX560Ti Hawk
Core i7 920 @ 2.8Ghz (133x21 multiplier..this is turbo mode)
6GB Corsair XMS3 DDR3 1600

I am also running it under DX11 and the factory-default clocks for my cards (950 Core / 1900 Shader / 2100 Memory) and I have yet to run into any problems with the game at all. It's by far the most stable game I've played in a long time, as well.

I haven't read every single post but if someone missed it, perhaps you should defrag. :p  And set up your OS environment to have as few services as required Win7 Config by Black Viper

I did note that with Adv PhysX and depth of field turned on, I had a nasty decrease in framerate, but with them off everything was like butter, and there really is no comparable difference in gameplay or visuals(at least to me).
!