Sign in with
Sign up | Sign in
Your question

ASUS P8Z68-V LX wont see Powercolor Radeon HD 6870

Last response: in Systems
Share
February 26, 2012 10:26:00 AM

Specs:
ASUS P8Z68-V LX MoBo
i7 2600k 3.4 GHz (no OC)
8GB G-Skill Ripjaws X 1600 MHz
Dual Powercolor Radeon HD 6870 1GB GDDR5 (my intention is to Crossfire)
Thermaltake Toughpower 750w PSU
Windows 7 Home 64-bit
Bog standard Hitachi 1TB SATA3 HDD
Dual 19" VGA monitors

Hey guys, I built the above specified system yesterday and I've been having endless trouble getting the MoBo to see the graphics cards.
The problems started when the PC wouldn't boot at all, because I'm not using a fresh HDD, I had to create a new Win7 partition and load the MoBo drivers onto that partition before it would boot. Everything is working fine now aside from the HD6870s. When I plug either of them into either PCI-E slot on my MoBo the fans spin on them and they appear to be working, but I get no output onto any screen plugged into them, and they don't show up in the device manager.
I tried an old card (GeForce 9800GT) in the PCI-E slots to make sure that the lanes themselves weren't faulty, and it worked fine, it automatically defaulted away from the integrated graphics (what I'm having to use to get any output onto a screen) and even automatically installed the drivers for it! But when I plug in either HD6870 nothing happens.
I've tried installing the drivers from the CD provided with the graphics cards it loads them, and appears to have completed successfully, I can even go to the folder that they installed to, and there are some files in there. But even after rebooting the MoBo just wont see either card. I tried downloading the drivers again from the AMD website and exactly the same thing happened. I then tried installing this hotfix: http://archive.msdn.microsoft.com/KB961894 as this article: http://support.amd.com/us/kbarticles/Pages/ATICCCInstal... on the AMD website recommended it, but after following the instructions nothing changed. I then installed Win7 Service Pack 1, and tried installing the drivers again - nothing.
I am plugging the 6-pin power connector from the PSU into the cards, so that isn't the issue. I tried changing the boot priority in the BIOS to boot from PCI-E rather than iGPU, but it made no difference because as far as the MoBo is concerned, there is nothing plugged into either PCI-E lane. I also tried disabling the onboard graphics in order to force the MoBo into recognizing the GFX, but it didn't work.
I'm getting pretty desperate now, so any assistance would be greatly appreciated! If I've missed any details please let me know and I'll fill you in, thanks!
a c 78 B Homebuilt system
February 26, 2012 11:43:34 PM

Try the cards in somebody else's PC. Preferably one at a time.
February 27, 2012 12:36:13 PM

Thank you for your reply but I'm afraid it was simply my own astounding stupidity that was preventing the cards from working! I was only plugging in one PCI-E power cable from the PSU instead of 2. Thanks for the reply though!
a c 78 B Homebuilt system
February 27, 2012 7:33:38 PM

It happens.
!