Sign in with
Sign up | Sign in
Your question

Dual Diamond HD 5970 Disabled Crossfire Flicker and BF3 Blue Screen

Last response: in Graphics & Displays
Share
December 27, 2011 8:16:22 AM

During Black Friday I purchased two Diamond HD 5970's on Neweggg.

Here is the Newegg link: http://www.newegg.com/Product/Product.aspx?Item=N82E16814103195&Tpk=HD%205970

I've been having a few issues with the cards. I'm wondering if maybe one of the cards is defective. I have 4 monitors, so I frequently switch between having Crossfire enabled and disabled. Most of my issues seem to crop up only when Crossfire is disabled.

1. After watching a video on Youtube (crossfire disabled), when I close the tab or navigate to another page, my screen will flicker black very quickly once.

2. If I run Battlefield 3 with Crossfire disabled, the game will load the entire map. Play for about 5 seconds and either freeze or BSOD 0x00000116 atikmpag.sys. If I run with Crossfire enabled I have absolutely no problems except for an occasional crash. Most likely BF3 is the culprit as there are no screen artifacts or signs pointing to a graphics problem. I've even tested the cards one by one by removing one card at a time and running BF3. When only one card is installed in the system BF3 will run with no problems.

3. When Magic The Gathering 2012 - Duels of the Planeswalkers launches and plays the introduction video, the video will rapidly flicker bright pink. (with or without crossfire enabled)

4. While crossfire is disabled Windows will randomly display a pop notification "Windows has detected your computer's performance is slow" and will disable Aero transparency effects on the taskbar.

Here are my system specs:

CPU: FX-8150 3.6 Ghz 8 Core Water cooled with a Corsair H100
MEMORY: 16 GB GSkill Sniper (4x4096mb) @ 1866 Mhz
MOTHERBOARD: ASUS Sabertooth 990FX @BIOS Beta Version 0810
GRAPHICS: DUAL DIAMOND A5970PE52G Radeon HD 5970 2GB @Driver Version 11.12 @Cap 3
POWER SUPPLY: RAIDMAX RX-1000AE 1000W ATX12V
HARD DRIVES: SAMSUNG 320 GB SATA 3.0 (OS Drive), 500 GB Seagate Sata 3.0 (Data Drive)
MONITORS: 3 ASUS VE247H 23.6 LED & 1 55 INCH Samsung HDTV
OS: Windows 7 64 Bit w/ all latest updates (fresh install)
CASE: Thermaltake Level 10 GT

Any idea on a fix? I'm still covered by the 60 day Iron Egg return policy. Should I return the cards? Should I contact Diamond?
December 30, 2011 5:22:45 AM

Company has not responded to any of my requests for customer support.

One of the cards is now crashing the computer after about 20 minutes of playing.

Going to return these cards. Never going to buy a Diamond product again. It's incredibly frustrating dealing with a company that doesn't even have a phone number to call.

Be advised when purchasing a Diamond product. Be sure to check out their BBB rating of an F
http://www.la.bbb.org/business-reviews/Miscellaneous-Pr...
December 30, 2011 5:39:33 AM

Best to return them asap, don't even bother trying to get the company to care.
If you can, return the cards and buy another brand!
December 31, 2011 10:07:48 AM

I have the same problem. When doing anything graphically taxing the video driver will die on me after a few minutes. I'm not sure why it does. I did run a few tests in FurMark though.

Speed: Auto Fan Control (47%)
Temp: 88C
Time To Lockup: 1:59

Speed: Manual 55%
Temp: 77C
Time To Lockup: 2:19

Speed: Manual 100%
Temp: 73C
Time To Lockup: Never actually did. I stopped the test at about 20 minutes.
!