CPU_LED on Sabertooth X58

Hello everybody. I have recently come a across a problem that I have been unable to solve. When I boot up my PC, the CPU and RAM LEDs come on, and I cannot POST. I have not been overclocking. I have a water-cooled i7 960 on a Asus Sabertooth X58. My PC worked perfectly yesterday, and I cannot understand why this happened. Did my CPU suddenly die? I have tried reseating memory and clearing my CMOS. Can anybody help me? BTW, I really don't want to RMA my CPU, but if I have to, can anybody tell me how exactly to RMA it. I bought this custom system from iBuyPower.
5 answers Last reply
More about cpu_led sabertooth
  1. If you have more than 1 RAM stick (I guess you have 3), try to install only 1 stick at a time & see if you can post or boot.
  2. I tried that. When I inspected my BIOS battery, it had two nicks on it. Could it be a corrupt BIOS?
  3. A failed CMOS battery would simply cause the PC to report a CMOS checksum failure during boot, reload default settings and wait for you to press a key to enter BIOS setup.
  4. bad psu maybe?
  5. That might be it. I recently got a hardware component failure POST. My optical drive and hard drive could not spin up. Bad PSU maybe?
Ask a new question

Read More

CPUs Sabertooth LED Monitor