Sign in with
Sign up | Sign in
Your question

Windows 7 , PPTP VPN error 807 and 800

Last response: in Networking
Share
March 21, 2011 1:48:48 PM

Dear Experts

Please don't steer the topic from PPTP to IPsec and other types of VPN which is more secure than PPTP,,,,etc

I have got this scenario windows 7 is acting as vpn client at home and windows XP is acting as vpn server at work.

At home (LAN address is 192.168.10.x/24)And I configured windows 7 as VPN client same as here :

http://www.hideipvpn.com/2009/09/howto-windows-7-pptp-vpn-setup-tutorial/


At work (LAN address is 192.168.1.x/24) I configured XP SP3 as VPN server same as here (except I could not enable PPTP Passthrough on my router because I could not find that option) :

http://www.home-network-help.com/pptp-vpn-server.html

Please be aware
On the vpn server, I have selected administrator as username to be allowed for vpn, subnet that vpn server is using, is : 192.168.1.70-73

On the vpn client I am using the correct username/password.

Security I tried below combinations with no joy:

Type of VPN : Automatic,,,,,,error 800
Data encryption: Optional encryption (connect even if no encryption)

Type of VPN: Point to Point Tunneling Protocol (PPTP),,,,,error 807
Data encryption: Optional encryption (connect even if no encryption)


Router that I am using at work (where XP is connected to it) is :

2wire router with below details :

IModel: 2701HGV-W Gateway
Hardware Version: 2701-100655-004
Software Version: 5.29.113.16

Port forwarding 1723 was enabled

Whenever I try to establish a vpn tunnel I am receiving either error 807 or 800

Note:
The VPN server (work deskto) was working when I had at home VPN client as an XP OS not windows 7, but when I upgraded from XP to windows 7 I lost my vpn connection.


Thanks
March 21, 2011 1:54:01 PM

Now I have got couple of question :

1- Do I need to enable GRE Protocol 47 (PPTP Pass Through or VPN Pass Through) as well, when I read couple of online threads they suggested to enable VPN Pass Through (GRE Protocol 47) with some nasty routers

http://www.chicagotech.net/vpnsetup.htm

2- I had not enabled GRE Protocol 47 (PPTP Pass Through or VPN Pass Through)when I had XP as client before upgrading to windows 7

3- If option 1 is not necessary what could cause this problem ?
m
0
l
March 21, 2011 2:13:09 PM

Yes, your router (and every other router in the chain) must support GRE 47. That's why so many ppl will "steer" you away from PPTP. Although relatively simple and ubiquitous, it suffers from compatibility issues w/ older routers, those that don't support GRE 47. That's why it's best to have a backup plan whenever possible.

In addition to port 1723, you need to have port 500 (udp) forwarded as well.

One last thing wrt MS VPN. I've had trouble using DHCP on the VPN server side. Many times (for reasons I don't understand) it would only work w/ static IP assignments.



m
0
l
Related resources
March 21, 2011 2:31:20 PM

Quote:
Yes, your router (and every other router in the chain) must support GRE 47

Are you saying my work router and home router should be configured for GRE 47 ?

Quote:
That's why so many ppl will "steer" you away from PPTP. Although relatively simple and ubiquitous, it suffers from compatibility issues w/ older routers, those that don't support GRE 47. That's why it's best to have a backup plan whenever possible.

Although I was about to try that but I could not find that option on my work's router !!! but confusing me why didn't I need to configure that to my work router when I used to have windows XP at home acting as vpn client before upgrading to windows 7 and VPN was working!!!


Quote:
In addition to port 1723, you need to have port 500 (udp) forwarded as well.

I will try that

Quote:
One last thing wrt MS VPN. I've had trouble using DHCP on the VPN server side. Many times (for reasons I don't understand) it would only work w/ static IP assignments.

Noted
m
0
l
March 21, 2011 3:46:55 PM

GRE 47 isn't something you enable/disable or configure, it's a protocol (not a port) that's either supported or not supported by the router. You can't do anything about it if it's not supported other than buy new equipment that does support it.

Of course, that’s only part of the battle. All the other routers involved need to support GRE 47 as well. So it can be problematic when dealing with routers you don’t even control.

Then there are the ISPs who block these ports (1723, 500), or only have a single VPN pass-through, yada yada.

Welcome to the world of VPNs. :) 

m
0
l
March 23, 2011 11:37:33 AM

Credits goes to other forum

udp port 500 is not necessary to be configured

The problem was with Norton 360 V5 firewall when I disabled it, VPN worked

As you have mentioned GRE 47 should be enabled on both routers home's router and work's router and I did the test below :

1- On home's router cable router (simple cisco provided by my ISP) 'PPTP pass through' is enabled,,,I guess not sure the work's router 2wire has 'PPTP pass through' or GRE 47 enabled by default, and firewall (Norton 360 V5) on the VPN server (Desktop computer at work) is disabled,,,,,,VPN worked

2- On home's router cable router (simple cisco provided by my ISP) 'PPTP pass through' is disabled,,,I guess not sure the work's router 2wire has 'PPTP pass through' or GRE 47 enabled by default, and firewall (Norton 360 V5) on the VPN server (Desktop computer at work) is disabled,,,,,,VPN didn't worked


Please see the snapshot below:

http://i54.tinypic.com/2s8nsrp.png

m
0
l
January 31, 2012 1:30:04 PM

I have faced the same problem of vpn error 800 while connecting VPN to my Windows 7.

1-Check out if you are using the correct server name as given by your subscribed VPN service provider.

2-Make sure that you internet connection is working properly, if not then reset the adapter or modem, as the case may be.

3-Another method would be to ping the server. For this, click “Run” after clicking the “Start” button on the windows screen. Type “Ping” followed by the name of your VPN server or IP address. Press enter. You will come instantly come to know if the server is working or not, in the resulting DOS screen.

4-Look out if the network firewall of your system is blocking the VPN connection. If it is so, then open Port 1723 and enable Port 47 in the configuration settings for the firewall. If you are using L2TP VPN then ensure port 1701 I not blocked.

5-If any of the antivirus installed at your system is causing the problems in VPN connection than remove it or alternatively, add the the IP of remote client in its configuration settings.

6-If you are able to connect to VPN from your desktop but not from your laptop, it could be probably due to security software such as Microsoft OneCare that is quite capable of blocking GRE, uninstall it and check out the results.

7-Uninstall and reinstall the VPN client at your end, enter the provided username and password provided by your VPN vendor during the setup. If you are having problem with installing the software, seek the customer care support of your service provider.

8-Contact your server administrator if more than expected clients are currently using the VPN connection. Though, such an occurrence is rare.

9-If the problem still exists, make a request for VPN server security certificate verification.

Hope this will help you.
m
0
l
!