Sign in with
Sign up | Sign in
Your question

PC crashing upon loading games.

Last response: in Graphics & Displays
Share
January 1, 2012 7:54:11 PM

Hi all, I know I recently made a post about having up to 3 displays on my 6870 card, but I made that thread as I was just interested because I was getting the card on that evening.

The card was a Powercolor 6870 1GB. I installed it into the PCI slot on the mobo (Gigabyte G880GM-UD2H), connected the PSU to the card and fired up my pc.

I installed all the drivers from the disc and opened up Skyrim. It played through the opening cinematic until I could walk around, as I was walking I seen that the mouse sensitivity was low, so I decided to hit escape and change it. I increased the mouse sensitivity and hit escape again, only to be greeted by a black screen. I could hear the game running in the background, there was just no video.

I powered off the pc by holding in the power button and connected it to my upstairs tv via VGA. (DVI to VGA adapter on the pc, then into VGA input on tv.) Once again, I opened up Skyrim, only to find that whenever I loaded it, I was met with the same black screen.

I thought that maybe it was the mouse, so I changed the mouse to a different one. Same problem.

I tried a different game, Minecraft. Surely that game didn't have much to run? But, the same black screen appeared.

I have checked the fans, plugged the mouse into different usb slots (just in case) and even tried booting it without the case's side panels on. But I still receive the same black screen.

Before installing the graphics card, games like Minecraft ran fine with the integrated graphics from the Motherboard.

I'm totally lost now. If anyone can help me out I would be most thankful. My specs are listed below.


MOBO: Gigabyte G880GM-UD2H
GPU: Powercolor AMD Radeon 6870 1GB
CPU: AMD Phenom II X4 955 Black Edition
CPU Cooler: Stock cooler
PSU: WinPower ATX 750w (ever heard of it? sounds like a no-name brand. is this causing my issues? i didn't have alot to spend and it had some good reviews on amazon so..)
OS: Windows 7 Ultimate 64 Bit

Once again, thanks in advance. Need urgent help! :cry: 

More about : crashing loading games

January 1, 2012 8:09:23 PM

CPU Temps while game running ?

GPU Temps while game running ?

Run OCCT 4.0 and monitored temps and voltages for 60minutes ?

Anything in Event Viewer ?

What was old card ?

Did you remove drivers, shut down machine, remove card, install new card, say "no" when windows wants to install crap and then finally install latest GFX driver ?

Plugged in both 6 pin PCI-E conenctors ?

http://www.amd.com/us/products/desktop/graphics/amd-rad...

500 Watt or greater power supply with two 75W 6-pin PCI Express® power connectors recommended (
January 1, 2012 8:34:56 PM

im running 2 6870's in crossfire .. that power supply should be good enough .. i have mine running fine with a corsair gold professional 750watt and i dont have any issues .. im going to say check your power cord connections to your video card also it wouldnt hurt to make sure its seated properly .. secondly when you start up skyrim double check your monitor resolutions.. i know theres a bug i noticed were with certain programs if you go from say an hd tv to a standard monitor the resolution for the game will stay with the hd set verses the monitor .. if you have changed your monitor settings recently i would consider that as your starting point
Related resources
January 1, 2012 8:35:59 PM

try starting it up with just one monitor and go from there..
January 1, 2012 8:37:51 PM

or revert to your last known working set up... are you running hybrid crossfire?
January 1, 2012 10:01:34 PM

JackNaylorPE said:
CPU Temps while game running ?

GPU Temps while game running ?

Run OCCT 4.0 and monitored temps and voltages for 60minutes ?

Anything in Event Viewer ?

What was old card ?

Did you remove drivers, shut down machine, remove card, install new card, say "no" when windows wants to install crap and then finally install latest GFX driver ?

Plugged in both 6 pin PCI-E conenctors ?

http://www.amd.com/us/products/desktop/graphics/amd-rad...

500 Watt or greater power supply with two 75W 6-pin PCI Express® power connectors recommended (


This is a brand new build, I was running with integrated mobo graphics up until installing the card.

I will measure the temps and get back to you tomorrow.

Could you reccomend the best way to completely remove the drivers from my system and try reinstalling them with the latest ones from the website?

Thanks for replying
January 1, 2012 10:03:15 PM

goodguy713 said:
im running 2 6870's in crossfire .. that power supply should be good enough .. i have mine running fine with a corsair gold professional 750watt and i dont have any issues .. im going to say check your power cord connections to your video card also it wouldnt hurt to make sure its seated properly .. secondly when you start up skyrim double check your monitor resolutions.. i know theres a bug i noticed were with certain programs if you go from say an hd tv to a standard monitor the resolution for the game will stay with the hd set verses the monitor .. if you have changed your monitor settings recently i would consider that as your starting point


This is a brand new build, I have double checked all power connections. Whenever I start Skyrim on a different display I always make sure to change the graphics to default.

I am not running crossfire, just a single card. This is my first build so I'm not looking to go for crossfire at this point.
January 1, 2012 11:32:35 PM

Okay, following some advice from a different forum, I upgraded to the very latest drivers and launched up Skyrim yet again. Everything seemed to be running smoothly, until I got to one part of the game where it needed to go to the loading screen. It black screened shortly after going to the loading screen.

I tried running HWMonitor to measure the temps during ingame by running Skyrim in a window, but when I switched tabs to view the HWMonitor window, the game crashed. I tried measuring the temps in Minecraft, but when I loaded that, the game crashed and my screen was full of grey stripes.

I will have a go with that OCCT now. I have never used this software before though.

Thanks for the help so far
January 2, 2012 3:45:07 PM

Ran occt but I got a verticle striped grey screen at 59m 50 seconds. I seen that my gpu maxed at 82 degrees c.

I have tried updating drivers and changing the ram to a different slot. Where should I go from here?
!