Sign in with
Sign up | Sign in
Your question
Closed

Possible Graphics Card Defect? Please help!

Last response: in Graphics & Displays
Share
January 1, 2012 10:15:01 PM

This is going to be long, please bear with me! :) 

I had a PC built by NCIX after choosing all of the parts. It was shipped this last week and arrived on the 30th of December. When it arrived, it seemed to work alright, although the Catalyst Control Centre kept popping up with an error message daying that my drivers were out of date. So I went to the AMD website to update my card's drivers, but I was still getting the same error message.

I also downloaded the game, SWTOR, and was getting an averge FPS of 5-10 (which aboslutely should not be happening with the specs I have). I thought that this maybe related to the driver issue that I was having earlier.

Then today, when I was just surfing the internet, the computer totally froze and I had to manually turn the power off. Then, after I had waited, I tried to turn the power back on and it's like the monitor isn't connected to the PC. It turns on with it's manunfacturer's logo, but then a message pops up saying DVI signal not found and it turns (and remains) black.

It seems as though the computer itself is working, but maybe the graphics card was bad? Or I'm doing something wrong? I double checked that everything was plugged in, but still it stays black. I'm getting really frustrated, and I have contacted NCIX, but waiting until they're open again to use my PC is too much for me, so I'm hoping someone here might be able to help! lol.

Any help, suggestions would be greatly appreciated!

My specs:
OS: Microsoft Windows 7 Home Premium Edition 64BIT SP1
CPU: Intel Core i5 2500K Quad Core Unlocked Processor LGA1155 3.3GHZ Sandy Bridge 6MB
MONITOR: ASUS VE247H 23.6IN Widescreen LED LCD Monitor 1920X1080 2MS 10M1DC HDMI DVI-D VGA Speakers
MOBO: ASRock Z68 EXTREME3 GEN3 ATX LGA1155 DDR3 2PCI-E16 2PCI-E SATA3 USB3.0 SLI CrossFireX Motherboard
HDD: Western Digital Caviar Blue 500GB 16MB Cache 7200RPM 3.5IN SATA Internal Hard Drive OEM
MEMORY: G.SKILL Ripjaws X F3-12800CL9D-8GBXL 8GB 2X4GB DDR3-1600 CL9-9-9-24 Memory
PSU: OCZ ZT Series 750W ATX12V 20/24PIN Modular 80+ Bronze TOWER: Coolermaster Haf 922 Mid Tower ATX Case Black 5X5.25 5X3.5INT Front Audio USB eSATA No PSU
GPU: MSI Radeon HD 6950 Twin Frozr II OC 810MHZ 2GB GDDR5 2XDVI 2x Mini DisplayPort HDMI PCI-E Video Card

More about : graphics card defect

January 1, 2012 10:35:54 PM

Are both cables plugged into your 6950?
Score
0
January 1, 2012 10:44:37 PM

amuffin said:
Are both cables plugged into your 6950?


I haven't moved the tower at all from the time it was working, up until now when it isn't. I did just go and double check though, and the cords are definitely all plugged in where they should be :( 
Score
0
Related resources
January 1, 2012 11:24:24 PM

Unfortunately you aren't listing other indications for good troubleshooting. Does the system respond at all when you hit the power button? Does it sound like it is starting up but just no video?
Score
0
January 1, 2012 11:46:57 PM

stubbies2003 said:
Unfortunately you aren't listing other indications for good troubleshooting. Does the system respond at all when you hit the power button? Does it sound like it is starting up but just no video?


I apologize: I can turn on the tower, and it sounds as though it's running fine and the fans are working. The monitor does come on with the Asus logo, and then a message pops up saying that there is "No DVI signal". I have tried changing the inputs (DVI, VGA, HDMI) and it just does the same thing. It was working before the computer froze and had to be restarted, but is definitely not working now.

Does it sound like it could possibly be a graphics card issue (when combined with the driver error messages I was receiving earlier, and the low FPS on games)?
Score
0

Best solution

January 1, 2012 11:57:32 PM

Ouch okay well even though this is a long shot you might want to take the 8 pin connectors off and plug in a different set of the 8 pin connectors from the PSU (at 750 watts I'm guessing that PSU has plugins and cables for 2 video cards. Swap the cables being used AND the port on the PSU for plugging them in). That being the long shot as video cards usually scream at you if they are missing the required power plugins. Double check the video cards connection to the mobo to verify it is seated all the way in/not at an angle where the PCI-e isn't making full connection. If all of that checks out and it still doesn't work I would see about finding a buddy with a computer you can slave the video card into. If it fails to work still then it would be the video card. If it works slaved in then try it one more time in yours. If it still doesn't work then my guess would be a bad PCI-e slot on the mobo. Also is your video card in the slot the mobo manual suggests for a single video card?
Share
January 2, 2012 12:06:37 AM

I really appreciate all the help and quick responses.

I guess my next course of action will be to wait until I have access to a second system where I can test and see if it's the video card or not.

It's frustrating though, considering the PC is a day old, and is already causing me massive headaches (which of course would have to happen over the long weekend, making me wait the longest possible time to be able to take it in to be fixed lol).
Score
0
January 2, 2012 12:07:02 AM

Best answer selected by Lola_Belle.
Score
0
!