Cant tell if Video card or motherboard or both dead

Hello all,

Well this is my first build and i cant seem to get it to work i have already checked the guides on troubleshooting and building and neither worked. Right now I am thinking the motherboard is dead but i cant tell if it really is dead or if its the graphics card.

Random info:
Cant get optical drive to open or close but flashes: don't know if its important
Everything turns on (or sounds like it) except the graphics card cycles fan speed to low and off
graphics card has a red light when it only has 2 6 pin, no red light with 6+2 and 6.
All the cords work (checked with different computers) and outlet works

System:
Radeon XFX HD 6970 2 GB Graphics Card

Cooler Master Silent Pro M850 Series Modular 850W

AMD FX 6100 6-Core Processor, 3.3 6 Socket AM3+

Crucial 64 GB m4 2.5-Inch Solid State Drive SATA 6Gb/s

GIGABYTE GA-990FXA-UD3 AM3+ AMD 990FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard

Corsair Vengeance 8 GB

P.S. Sorry for bad English
4 answers Last reply
More about cant video card motherboard dead
  1. Hi re: "...Right now I am thinking the motherboard is dead but i cant tell if it really is dead or if its the graphics card. ... "

    This is easy to check. Pull the video card. Turn on the PC. Does the PC post and give beep codes indicating no video ? Yes then the MB seems OK and video is suspect (although it could be the power supply). No, pull some more parts until the MB posts.

    Standard debugging is to pull parts until you have just the MB, CPU and Power supply. If that POSTs with beep codes indicating no memory then you are ready to find the problem. If that doesn't POST then CPU, MB or Power Supply is bad. You swap those until you find which one. There's no easy way I know to tell. Except it's always the power supply.

    This debugging guide, especially breadboarding will help. http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
  2. hello thanks for quick response would the CPU not being installed correctly cause the motherboard not to post or show image sence as i was removing my cooler the cpu came up with it.
    Edit: nvm it beeped loudly when i reset the cpu ill post back if it works
  3. installing windows 7 now thanks Tsnor :D
  4. Outstanding! Glad you fixed it.
Ask a new question

Read More

Systems