Sign in with
Sign up | Sign in
Your question
Solved

Temp folder writing permission by itself

Last response: in Windows 8
Share
January 21, 2013 2:26:26 PM

Hello,

I have just recently clean - re-installed my system - it's Windows 8 Pro x64. I have one dedicated SSD hard drive to be used by the OS and most of the applications which means Disk C is the system drive where I keep all installed programs and it's about 250 gigs in size. All the other HDs are used to keep all my documents, games, backups and other stuff. Now, from time to time when I try to run WinZip or an installer of some sort I get different kinds of error message which always come to this: the app has no access to temp folder. I went to the Temp folder located at C:\Users\<Username>\AppData\Local\Temp and noticed that the Security Tab of that folder only contains the following users:

Everyone with low permissions (read and write)
Administrators with Full control.

I've checked in two other different computers in my home with the same OS installed and those computers has three users instead of two listed in the security Tab (SYSTEM, Administrators and the machine user with full access to that folder).

I then changed the security permissions of that folder to match the other computers meaning that I removed the Everyone and added the SYSTEM and the machine user (myself).

Now the funny part - everything works perfectly after that change but couple hours again all of the sudden the issue returns and guess what? it changes the permission by itself back to what were before (Everyone and Administrators).

I ran the Kaspersky which is my AV and other malware programs such as Spybot and Malwarebytes and they couldn't find anything in my computer.

I'm at a loss here. I consider myself to be fairly experienced computer user, but that kind of behavior is beyond my comprehension. Does anyone have any clue what I might be doing wrong? Maybe some policy in the registry or GPedit?

As a tip - nothing new was installed in my computer that was not installed in my previous version which was Windows 7 Ultimate x64.

Here is a quick log for the paths I have in my system

Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.

C:\Users\Gabriel>set
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\Gabriel\AppData\Roaming
CLASSPATH=.;C:\Program Files (x86)\QuickTime\QTSystem\QTJava.zip
CommonProgramFiles=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=R2-D2
ComSpec=C:\Windows\system32\cmd.exe
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Users\Gabriel
LOCALAPPDATA=C:\Users\Gabriel\AppData\Local
LOGONSERVER=\\R2-D2
NUMBER_OF_PROCESSORS=8
OS=Windows_NT
Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32
\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-St
atic;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Media Too
ls\MKVToolNix;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Fil
es (x86)\Intel\OpenCL SDK\2.0\bin\x64
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=AMD64
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 42 Stepping 7, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=2a07
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PROMPT=$P$G
PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
PUBLIC=C:\Users\Public
QTJAVA=C:\Program Files (x86)\QuickTime\QTSystem\QTJava.zip
SAN_DIR=C:\Program Files\Hardware and Drive Tools\SiSoftware Sandra Business 201
3
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\Windows
TEMP=C:\Users\Gabriel\AppData\Local\Temp
TMP=C:\Users\Gabriel\AppData\Local\Temp
USERDOMAIN=R2-D2
USERDOMAIN_ROAMINGPROFILE=R2-D2
USERNAME=Gabriel
USERPROFILE=C:\Users\Gabriel
windir=C:\Windows

C:\Users\Gabriel>


Thanks in Advance,

J
January 21, 2013 2:35:53 PM

Try booting with full admin rights and redoing the procedure you've already done (adding your user account in permissions).

1) Control Panel > User accounts > Change UAC settings - drop the slider to the bottom
2) Type 'Local Security Policy' in start screen/menu search and press enter
3) Go to Local Policies > Security Options, scroll to the bottom and set 'User Account Control: Run all administrators in Admin Approval Mode' to Disabled
4) Restart PC when prompted
5) Re-add your user account to Temp permissions and re-enable the option from step 3, else you won't be able to use Modern apps
January 21, 2013 10:08:56 PM

Thanks Soda,

Just before read your message I had done the procedure to add my my user account permissions AGAIN so i will rather wait for the issue to happen again which will happen between today and tomorrow and then I will do your suggestion. That way I can be sure that your suggestion worked. :-)
Related resources
January 21, 2013 11:15:25 PM

One thought might be if the temp directory was deleted it might cause the permission issue when and how the folder is created. You could look at the creation date and time.
January 22, 2013 12:37:04 AM

Was not deleted at anytime. Checked already and the creation dates from when I installed the OS. Wish I can see when the permissions were modified.

When the issue happened this morning the only thing I did different was to unchecked the special permission under the Everyone user. When I did that the user Everyone just disappeared so I added my user and SYSTEM again and so far the issue didn't happened again.
January 22, 2013 1:11:49 AM

Have a look at the local security policy.
January 22, 2013 7:20:48 PM


Hello everyone :-)

It's really weird but the issue didn't happen again so far. As I mentioned before what I was doing during the last 20 days which is the time I'm having this problem I was removing the Everyone user and adding SYSTEM and my User account into the security Tab of the folder properties.

What I did different yesterday just before create this topic was to instead of removing the Everyone user I unchecked the special permission which automatically deleted the Everyone user and then I added the SYSTEM and my user account as I usually was doing.

The issue could be related to the "special permissions" been checked? What program did that? That question remains unanswered....

Regardless I'm still monitoring every hour to see if the issue returns and will let everyone knows before close the topic.

Thanks so far to all of you :-)
January 23, 2013 5:08:23 PM

Just happened again so I did what Soda-88 suggested.







Let's see what it goes and if this will fix this problem once and for all
January 28, 2013 1:56:37 AM

Well...

Soda-88 suggestion last three days and the problem returned. Really annoying :-(
February 6, 2013 9:54:35 PM

I have the same problem. But I noticed that the permissions go back automatically on the first boot up of every day. So if I change permissions and reboot, everything is fine. But when I turn the computer on the next morning, the permissions revert back to the exact way it is on your computer. I discovered that if I disabled my Norton antivirus before turning off the computer at night, the permissions do not self-revert the next morning. So I think what is happening is that the antivirus might be reducing the permissions of the temp folder because viruses tend to run from that location. Since you said you have computers that don't have this problem, do they have the same antivirus program?
February 7, 2013 2:18:37 AM

yes, they do have the same anti-virus. One thing I just realized is that the issue seems to appear after I use WinZip or WinRAR. Anyways, what I did today was to give both programs administrator rights. I navigate into their instillation folders and right click on the executable. From there, compatibility tab and I've checked run as administrator.

Let's see if the issue returns.
February 10, 2013 9:02:33 AM

Hi,
Any news on this issue? I'm suspecting a virus, rather than an anti-virus problem. I hope I'm wrong.
Google "google drive python dll" to see another thread about the same issue.
February 10, 2013 2:58:17 PM

No news :-(

Actually my last attempt which was give WinZip administrator rights didn't work. The issue came back last night.

What you mean by virus? I've google it for python.dll and couldn't find anything relevant related to this issue. Also I don't use Google drive.

Just to be sure I ran KIS in my entire computer and it couldn't find anything :-( however the behavior seems to be a virus.
a b * Windows 8
February 10, 2013 3:25:51 PM

make a batch file that writes a few bytes to a file in the temp directory one time a minute then loops until it fails to write then have it pop up a error when it fails. Maybe you can find what is triggering the change right when it happens

- maybe look to see if you have a task in the scheduler that is making the change

February 10, 2013 3:43:29 PM

Will try the batch option cause there is nothing unusual in the Task Scheduler or Startup
a b * Windows 8
February 10, 2013 4:00:26 PM

I would just echo the time to a file in the batch file, then use waitfor command to wait
then loop until I get a error making a file, then maybe change the screen colors so I notice the failure.

time /T >foo.txt (path to your temp file)
waitfor noevent /t 30
February 10, 2013 4:27:45 PM

Same error here. Very annoying and it keeps reverting by itself. One thing I notice is you may not add/set the accounts for temp folder directly. Instead it inherits from the user/<username> permissions level. Not sure if it's relevant, since the problem still returns itself after I set the inheritance. Haven't tried disabling UAC before setting it though.
February 10, 2013 4:30:19 PM

Petithomme said:
Hi,
Any news on this issue? I'm suspecting a virus, rather than an anti-virus problem. I hope I'm wrong.
Google "google drive python dll" to see another thread about the same issue.


The python dll issue has to do with Google Drive. This permissions issue prevents Google Drive from starting because that python file needs to be created in the Temp folder but can't. I have since switched to Microsoft SkyDrive because it doesn't use the Temp folder at all. But I would still like to get to the bottom of this.
February 10, 2013 9:07:24 PM

I have UAC completely disabled as well SmartScreen. It reverts by itself every two days or so or something is triggering the change and I couldn't figure what it is :-(
a b * Windows 8
February 10, 2013 10:45:02 PM

you can dump the ACL of the files in %temp% to a file when everything is working, then dump it to another file when you get the failures. Then do a diff between the two files and see what actual ACL has changed.

something like
cd %temp%
icals.exe *.* > goodlist.txt
then do it again to a different output file when you hit the problem. and Diff the files

February 11, 2013 1:02:34 PM

I am the smartest man alive!! I kid of course, but I did find the culprit. Adobe Acrobat. Every time I open a PDF, the security settings on my temp folder are changed a few seconds later. I reset the folder permissions and tried again 4 times. It happened every time. I am using Adobe Acrobat Pro XI. So I'm gonna mess with the settings to see if I can figure out if I can stop it.
February 11, 2013 3:06:23 PM

LOL....

Great finding because I'm also using Acrobat Pro XI. I will try to find something in the settings too.
February 11, 2013 3:12:38 PM

Just tested and it's indeed Adobe Acrobat XI. I not even opened a PDF, just opened Acrobat itself. Unfortunately looking into the Acrobat preferences (settings) I couldn't find anything that explains this behavior.
February 11, 2013 8:57:46 PM

I confirm that the problem is reproduced too. Windows 7 x64, Adobe Acrobat 11.0.1. The PDF needs to stay open for a while for this to happen - wouldn't work if just open and immediately close it.
February 11, 2013 9:46:05 PM

And I believe this is only a problem on the 64bit version of windows, which is funny because Acrobat is in the x86 folder. That means the same version of Acrobat is used for both the 32bit and 64bit OS's, right?
February 12, 2013 11:05:38 AM

I think so...it's actually changes the NTFS permissions. There should be a way to limit or prevent Adobe Acrobat to do that
February 17, 2013 11:22:51 PM

Couldn't find any workaround for this :-(

Best solution

February 20, 2013 12:37:05 PM
Share

CONFIRMED SOLUTION:

Had my head spinning over the same issue ... and after a long and thorough investigation I CAN CONFIRM that I now have gotten to the bottom of the issue.

The issue ONLY happens when Acorbat XI has been activated using the dll method. (check it out for yourself if you have the time: ... after a clean install leave it unactivated and you'll notice the Temp folder permissions are never edited. The moment you activate it using the dll method, and open the user interface ... only a few seconds then voila! Temp folder permissions changed!

This is therefore NOT an Acrobat XI bug, no wonder Adobe has been completely silent on the issue.

The solution is to activate Acrobat XI via the internet, or using the offline method :) . When Acrobat XI is properly activated in either of those two ways the issue does not occur. Things go wrong when you use a patch or dll.
February 23, 2013 12:23:23 PM

it worked :-)

Thanks
March 31, 2013 12:56:27 PM

I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit
April 1, 2013 6:45:51 AM

ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit


Day 2 no Temp error message, everything works fine. :) 

After a few days the error windows started popping again at login

April 1, 2013 11:37:52 AM

will check as well and let you know.
April 19, 2013 2:59:09 AM

eliot22 said:
I am the smartest man alive!! I kid of course, but I did find the culprit. Adobe Acrobat. Every time I open a PDF, the security settings on my temp folder are changed a few seconds later. I reset the folder permissions and tried again 4 times. It happened every time. I am using Adobe Acrobat Pro XI. So I'm gonna mess with the settings to see if I can figure out if I can stop it.

ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.
It worked so far for me under Win 8 64bit


THANKS A TON ! Both ralf89 and eliot22 for identifying the culprit & providing the solution.

I had installed Acrobat and had been unable to Print from any app after that. Spent two days troubleshooting and reinstalling printers before stumbling upon this. Doing it fixed my problems.
May 27, 2013 6:26:01 AM

ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit


I tried to follow your solution but I'm lost. The Acrobat.exe part I did it without problem. But the part of the Temp folder I don't understand your instructions very well. I open the Properties of the folder, go to Security tab, click on Advance, a new window opens with several tabs and then, what?

I am using Windows 7 64bit so maybe the steps are a little different from here.
May 27, 2013 9:36:24 PM

^ On the window that opens when you click on 'Advanced', look to the left bottom and there will be a Button or Check Box called "Enable Inheritance" OR "Disable Inheritance".

You have to click it so that it says "Enable Inheritance".

Then select the check box below it called "Replace all child object permissions with this......"
June 10, 2013 2:46:11 PM

i Had the same problem when activating adobe with amtlib.dll
it's been weeks & i'm digging in the Internet for solution
i want to thank you all .. this topic was very useful ^^
June 10, 2013 3:18:18 PM

ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit


IT WORKED FOR NOW .. I WILL CHECK IF THAT IS NOT GOING BACK
THANK YOU ^^


June 20, 2013 12:09:52 AM

Soda-88 said:
Try booting with full admin rights and redoing the procedure you've already done (adding your user account in permissions).

1) Control Panel > User accounts > Change UAC settings - drop the slider to the bottom
2) Type 'Local Security Policy' in start screen/menu search and press enter
3) Go to Local Policies > Security Options, scroll to the bottom and set 'User Account Control: Run all administrators in Admin Approval Mode' to Disabled
4) Restart PC when prompted
5) Re-add your user account to Temp permissions and re-enable the option from step 3, else you won't be able to use Modern apps


June 20, 2013 12:12:24 AM

Hello, I checked in my PC , through follow given steps, found that , by default set 'User Account Control: Run all administrators in Admin Approval Mode' to Disabled.
Please guide me...!
October 10, 2013 3:02:52 PM

The fixes provided here worked for me to. (For Windows 64-bit Home Premium)
I thank all of you who helped in finding this fix!
Just to make it clear for some people who might doubt if this is what they are looking for (because I did at first), for me it fixed:
-The python dll problem with Google drive,
-The shockwave flash plugin problem in google chrome,
-The winrar extracting problem,
-A problem where my logitech gaming software couldn't find my g700s mouse
-And will possibly many more problems that are related to the Temp folder.

But still I have one more problem with my logitech mouse software, the mouse is being detected and works fine now, but I still get this annoying popup. Any thoughts on how to fix this? I've added a link to a screenshot of the problem.
Thanks in advance!
(ps. The text is in dutch, but it basically says that It can't get access to the file because I don't have the needed permission.)
https://docs.google.com/file/d/0BxCDifPT5-GNdlJ5aW9zUjJ...
October 27, 2013 2:17:18 AM

I don't have an answer but I can confirm the problem is not just confined to windows x64 it also occurs on my x86 (32 bit windows 8). I suspected Adobe acrobat had something to do with it, however this thing about activating acrobat XI using a fixed dll only can not be right as I did not use this method.
December 7, 2013 9:08:17 PM

ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit


I can confirm your solution works in Win 7 x64. Thanks man

December 27, 2013 1:29:56 PM

Soda-88 said:
Try booting with full admin rights and redoing the procedure you've already done (adding your user account in permissions).

1) Control Panel > User accounts > Change UAC settings - drop the slider to the bottom
2) Type 'Local Security Policy' in start screen/menu search and press enter
3) Go to Local Policies > Security Options, scroll to the bottom and set 'User Account Control: Run all administrators in Admin Approval Mode' to Disabled
4) Restart PC when prompted
5) Re-add your user account to Temp permissions and re-enable the option from step 3, else you won't be able to use Modern apps


How do I boot with full admin rights?
February 13, 2014 5:49:46 AM

Soda-88 said:
Try booting with full admin rights and redoing the procedure you've already done (adding your user account in permissions).

1) Control Panel > User accounts > Change UAC settings - drop the slider to the bottom
2) Type 'Local Security Policy' in start screen/menu search and press enter
3) Go to Local Policies > Security Options, scroll to the bottom and set 'User Account Control: Run all administrators in Admin Approval Mode' to Disabled
4) Restart PC when prompted
5) Re-add your user account to Temp permissions and re-enable the option from step 3, else you won't be able to use Modern apps


After this procedure, do I need to move the UAC slider back to where it was?
March 17, 2014 5:55:25 PM

ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit


I tried this and it didn't work. Is it possible that you forgot a step? My problem continued after I made all these changes. I went back into the properties for Acrobat.exe and noticed that the owner of the file was still "System." I changed it to Administrators. I'll restart it soon and see if your fix along with changing the owner worked.

EDIT: Yeah that did it! Make sure you remember to change the owner of Acrobat.exe as well. Boca2605, yes, you will want to restore your UAC permissions back to where they were or else your system will be extremely vulnerable to outside threats.

EDIT 2: Four days later, it happened again. I got the Python DLL error for Google Drive. I'm tried the more thorough instructions on changing Temp folder permissions here: https://productforums.google.com/d/msg/drive/zbazK_MeKR.... However this is a temporary fix as well since once Acrobat is opened, the Temp directory permissions are altered once again. The only solution seems to be to remove the faulty amtlib.dll activation version of Acrobat.

EDIT 3: The alternate non-DLL activated version of Acrobat Pro XI did it. I use the software for hours a day and my Temp folder permissions have remained exactly the same as before I installed it. Unfortunately there is no getting around the DLL activation changing your Temp permissions. Just get rid of it. Thanks to all the people who are much smarter than me for the guidance!
April 4, 2014 1:41:26 PM

Malickfan86 said:
ralf89 said:
I might have found a solution. Go to Acrobat.exe Properties, Security and Edit System permissions by clicking under Deny Full Control and will mark all the entries under, once saved go click Properties on the user temp folder in C:\Users\[user]\AppData\Local\, Security, Advance, Enable inheritance and tick Replace all child object permissions entries etc... apply Ok and it should be done. Reboot and no message.

It worked so far for me under Win 8 64bit


I tried this and it didn't work. Is it possible that you forgot a step? My problem continued after I made all these changes. I went back into the properties for Acrobat.exe and noticed that the owner of the file was still "System." I changed it to Administrators. I'll restart it soon and see if your fix along with changing the owner worked.

EDIT: Yeah that did it! Make sure you remember to change the owner of Acrobat.exe as well. Boca2605, yes, you will want to restore your UAC permissions back to where they were or else your system will be extremely vulnerable to outside threats.

EDIT 2: Four days later, it happened again. I got the Python DLL error for Google Drive. I'm tried the more thorough instructions on changing Temp folder permissions here: https://productforums.google.com/d/msg/drive/zbazK_MeKR.... However this is a temporary fix as well since once Acrobat is opened, the Temp directory permissions are altered once again. The only solution seems to be to remove the faulty amtlib.dll activation version of Acrobat.

EDIT 3: The alternate non-DLL activated version of Acrobat Pro XI did it. I use the software for hours a day and my Temp folder permissions have remained exactly the same as before I installed it. Unfortunately there is no getting around the DLL activation changing your Temp permissions. Just get rid of it. Thanks to all the people who are much smarter than me for the guidance!


I have been having all of the same problems as everyone here, and I did a bit of searching; I am no computer programmer but decided the best solution was to write a batch file which starts on Windows startup using the icacls command reseting the folder permissions each time on startup granting "Everyone" full control. I then delayed the startup of programs using the Temp folder e.g. Google Drive and Box.net etc and since then no problems. here is the batch file code:-

@echo off
cls
title Temp File Permissions
icacls %c%:\Users\%user%l\AppData\Local\Temp /grant Everyone: (OI)(CI)F

I am sure there are much neater ways of using icacls i.e. getting folders to inherit the properties etc and making it more secure, but this works. So, create a .txt file, drop this code into it (changing the drive and user name accordingly), save as a .bat file somewhere on your computer (i put in root of c drive), create a shortcut and drop that into your startup folder, delay any programs which have problems with accessing the Temp folder and hey presto.

Cheers.



April 15, 2014 1:53:29 PM

I'm using Windows 7 OS 64Bit and i am having problems with the Dropbox permissions each time i tried to start it.
I followed the guide dropbox give you and tried to change the permissions at %user%\AppData\Local\Temp etc etc with no luck the error continued to appear.
But then i added my user account giving full control to my user account at C:\Windows\Temp and it works now!
Not sure for how long but it works, will report if the error happens again.

KP
!