Brand New ATI Radeon HD 6950: strange screen flickering/artifacts

Hey all, I just purchased this graphics card on black Friday and installed it on Christmas. It seemed to be working fine for the first few days, but now I am encountering a pretty strange issue. Whenever I watch any sort of video, there are black and white horizontal lines flickering all over the place. Here is an example:

http://i40.tinypic.com/9r6n4p.png


Also, I have been trying to play Psychonauts which is a game from 2005 that I should really not have an issue playing, but found that there was insane flickering and texture problems all over the place. I played this game on my girlfriend's system just days ago, which is significantly weaker than mine, and had absolutely no problems.

http://i44.tinypic.com/312ajrb.png

EDIT: I just booted up Skyrim:
http://i40.tinypic.com/2ivz3q1.jpg
http://i43.tinypic.com/noy4pd.jpg

Keep in mind that this stuff is flickering EVERYWHERE at a very rapid pace.


The drivers are fully updated. What do you guys think? Is there any fix to this or is the card faulty?

My current specs:

Summary
Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
Intel Core 2 Quad Q6600 @ 2.40GHz 34 °C
Kentsfield 65nm Technology
RAM
4.00 GB Dual-Channel DDR2 @ 400MHz (5-5-5-18)
Motherboard
EVGA NFORCE 680i LT SLI (Socket 775) 32 °C
Graphics
W1952 (1440x900@60Hz)
AMD Radeon HD 6900 Series (ATI) 34 °C
Hard Drives
977GB Hitachi Hitachi HDS721010CLA SCSI Disk Device (ATA)
Optical Drives
TSSTcorp CDDVDW SH-S203B SCSI CdRom Device
Audio
Realtek High Definition Audio

PSU is an Ultra XPRO 600w. http://www.silentpcreview.com/article708-page1.html
4 answers Last reply
More about brand radeon 6950 strange screen flickering artifacts
  1. The issue seems like it may be getting worse, here's what happened when I just booted up Skyrim: http://i40.tinypic.com/2ivz3q1.jpg
    http://i43.tinypic.com/noy4pd.jpg

    Keep in mind that this stuff is flickering EVERYWHERE at a very rapid pace.
  2. Did you try and re-seat the video card? If you did and it's still doing this, I would send it back. Pronto!
  3. Kridian said:
    Did you try and re-seat the video card? If you did and it's still doing this, I would send it back. Pronto!


    I just opened up my case and reseated the card. This seems to have helped for now, but I'm afraid it's only a temporary fix :(
  4. tl29 said:
    Kridian said:
    Did you try and re-seat the video card? If you did and it's still doing this, I would send it back. Pronto!


    I just opened up my case and reseated the card. This seems to have helped for now, but I'm afraid it's only a temporary fix :(


    Any updates on this? I'm curious.
Ask a new question

Read More

Radeon Graphics