Sign in with
Sign up | Sign in
Your question

How to disable hardware acceleration for only videos

Last response: in Graphics & Displays
Share
January 4, 2012 7:36:16 PM

Video played normally through various players, including KMPlayer and MPC-HC, gets played in video hardware mode (or something like that), and I wish it to not be so, instead to be played in software mode for quality reasons.

To work around this issue I start a playback of a video, pause it, and start the video I want to play in "software mode".

In my old GeForce 7300 GT and all previous Nvidia cards, I would just start a single video and it would "grab" the hardware acceleration and keep it, even if minimized or on resolution changes.
Starting with Ati 4670 HD, the video to "grab" the hardware acceleration needs to be opened at all times, and also be the foreground video to "get" the acceleration on any resolution change.

On Ati 5670 HD I see that each screen output gets it's own hardware acceleration "thread" for video, so I need to start 2 such videos to pause, one on each screen, if I want to play back on secondary display via software mode. (can get it with only one video on pause if it's the main display, but for some reason I need to start and pause a video on each display when I want to play in software mode on the secondary display).
Also on 5670, hardware mode is really bad, not just bad colours but video playback is jerky, so default playback is not an option.

What I would like to do is to completely disable hardware acceleration for video playback, without having to start 2 little videos that will get to stay on pause, (and also without having to minimize the main video on each resolution change so the paused video gets the "hardware acceleration" again)

Messed with the settings on the ati driver and the directx diagnostic tool, without success, unless I disable DirectDraw Acceleration, but that reduces performance on windowed 3D applications. So far the most successful way to keep 3D performance and just disable hardware acceleration for video playback is to start those small videos and keep them on pause.

Operating system is Windows XP, video drivers and directx are the latest. The issue is also on the clean OS of the dual boot, but as I said, the issue is ancient, just becoming more of a problem as new tech gets in.

I searched in google a bit on the issue, but maybe I am not using the proper keywords, I only find unrelated threads.
a b U Graphics card
January 4, 2012 10:17:09 PM

In MPC, go to view>options>Internal filters

Deselect any transform filters with (DXVA in it).
a b U Graphics card
January 5, 2012 6:07:57 AM

You could try (MPC-HC) view->options->output and try "overlay mixer" or "old renderer". You could also try VMR7/9 (renderless) with different surfaces (but not 3D).
I really don't know what "quality reasons" you have, but for me overlay was always better, especially when the movie had a lower resolution than monitor and stretching had to be done in full-screen.
Related resources
January 5, 2012 8:17:55 AM

Thank you. Will try those as soon as I get home.

The quality reason are 2 in fact:
1) is contrast/gamma enhanced for the displays via driver settings, and the video version of such enhancements do not match in quality as the standard desktop enhancements.
2) one external filter for both KMP and MPC, one that came from Cyberlink Power DVD, and that I use quite often, this filter breaks synchronization between audio and video if used in hardware accelerated mode.
January 5, 2012 5:11:04 PM

Feedback on the results of the tests:
KMP was set on old renderer. Changed it to VMR9 and works great, both windowed and renderless. No page tearing. Framerate is good even with heavy filter usage and CPU usage is the same as when I grab the overlay via other videos.
MPC was on overlay mixer. Changed it again to VMR9 and works great as well.

I tested the other modes since getting my hands to these options. VMR7 shows the same glitches as overlay and old renderer. Direct Draw on overlay surface, for KMP, is again similar or the same with overlay mixer. Direct draw on RGB surface brings a very pixelated result image.

Thank you again Mathew.
May 23, 2012 10:38:31 AM

Pyree said:
In MPC, go to view>options>Internal filters

Deselect any transform filters with (DXVA in it).


Installed new K-Lite Codecs Pack.
Tried the methods that worked last time in fixing the problem: they did not work this time.
As soon as I hit the filters I want, glitches and page tears appear.

Then tried what you suggested, which did not change anything last time, but this time fixed the problem.

Thank you Pyree
!