Sign in with
Sign up | Sign in
Your question

Can't detect my USB

Last response: in Windows 7
Share
January 11, 2012 2:46:12 AM

my computer can't detect any of my usb. I follow the instruction by erasing the USB devices and it turn out that even my mouse can't detect by the computer,,now i'm using my keyboard to search the net because even if i use other mouse it can't be detected..please help me,,really need your help tnx. I'm using a WINDOW 7 64bit.

More about : detect usb

a b \ Driver
a b $ Windows 7
January 11, 2012 2:58:54 AM

You can hit start then type "mousekeys" without the "". This will let you use the mouse pointer with your keyboard. This is optional and just makes it easier to select things on the next steps.

Now goto the device manager(start and type "device manager" without the "") and check if the usb drivers have reinstalled.

If they have(no ! or ?'s under Universal Serial Bus controllers) and your mouse is still not working, try to roll back the driver(in the driver tab for the usb devices. anything that has no roll back is using windows default drivers and should not require it.).

I remember and older Intel update breaking USB devices on an older motherboard(975X chipset i think).

Normally the uninstall the USB drivers just leaves the mouse un-usable for a short time(while they reinstall), but you seem to be in a different issue.

Hope this helps
m
0
l
January 11, 2012 3:59:41 AM

did you have a virus recently? Because working in a computer shop, we get a good amount of clients that get viruses, some of which attack either the registry and/or driver services rendering the mouse and sometimes keyboard useless.

For the mouse:

open regedit.exe (start, run). Navigate to the following:

HKEY_LOCAL_MACHINE -->SYSTEM -->CurrentControlSet -->Control -->Class -->
{4D36E96F-E325-11CE-BFC1-08002BE10318}. You'll see an entry for UpperFilters. If it says anything other than "mouclass", modify the value so that its "mouclass" without quotes.

If that doesn't work:
2nd fix: Note this is most likely not the issue though since if the virus disabled this service, both your mouse and keyboard would be disabled. Almost forgot how to do this without my special boot disk software from work, but this should work:



Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt]. The "start" entry should be set to 1. If it isn't, then set it to Decimal 1.

Reboot.

If that doesn't work, post back.
m
0
l
!