Sign in with
Sign up | Sign in
Your question
Closed

Display driver AMD has stopped responding and has recovered

Last response: in Graphics & Displays
Share
January 5, 2012 9:28:55 PM

Ok this is going to be a good one for you all to try and solve as I have tried just about EVERYTHING there is.
Here are my specs:
Operating System
MS Windows 7 Home Premium 64-bit
CPU
AMD Phenom II X6 1100T 38 °C
Thuban 45nm Technology
RAM
8.00 GB Dual-Channel DDR3 @ 669MHz (9-9-9-24)
Motherboard
ASUSTeK Computer INC. M4A88T-V EVO/USB3 (AM3) 46 °C
Graphics
ZORAN MATRIX (1440x900@60Hz)
ASUS EAH6850 Series (ASUStek Computer Inc) 48 °C
Hard Drives
977GB Seagate ST31000524AS ATA Device (SATA) 30 °C
Optical Drives
TSSTcorp CDDVDW SH-222AB ATA Device
Audio
AMD High Definition Audio Device
PSU
630W
"Display driver AMD has stopped responding and has recovered" has been popping up basically since i got the computer almost 6 months ago.
Here is what I have tried: (no specific order and I have definitely tried many more solutions than this)
1. Replaced video card
2. Underclocked
3. used older driver
4. wiped hard drive and installed windows/drivers cleanly
5. installed updated drivers cleanly with Driver sweeper every time
6. made sure no other graphics programs are interfering
7. tried different slot on the mobo
8. installed driver that came with box
9. overclocked
10. boosted the idle memory/core clock speed
11. tried to get help from ASUS tech support (which was near useless)
12. flashed bios
13. ETC ETC ETC ETC

Details: The error happens at random times when im gaming (SWTOR, Skyrim, LoL), but occasionally can occur when im doing nothing. The error seems to have a mind of its own and seems to have happened less when im doing nothing since i decided to increase the idle clock speeds.

Anything you people can think of would be appreciated. I guarantee ill give it a shot. I have been told it could be the mobo itself, but im trying to avoid replacing a 200$ mobo since i am in college and dont have that kind of money. It is and will be a challenge so keep the suggestions coming.
plz and thank you,

PS. I can not play skyrim because of this error since when i try to play if the error happens then it boots me to desktop.
January 5, 2012 9:47:56 PM

Try a different Powersupply, I think its the only thing not listed in the things you tried. If this don't fix the issue i'd put my money on the board having a faulty compassitor or something.
January 5, 2012 9:56:58 PM

This is exactly what I am getting at the moment. In fact my new GPU (A sapphire 6850) arrived today and I keep getting this message along with some visual artifacts (whitish boxes appearing all over the screen and blurring it all over).

I have been trying to fix this for at least 6 hours now and am near to giving up so please any help would be very appreciated.
Related resources
January 5, 2012 9:58:50 PM

Oh yeah and I forgot to mention the driver stops responding when I open AMD catalyst control centre. When I don't allow it to make changed (click no when the message comes up as soon as Windows boots) it works but the artifacts still show up :( 
January 7, 2012 8:34:37 AM

Hmm i sent in the mobo for RMA so hopefully that helps. I have a hard believing its the PSU tho dorman but it is an interesting thought
January 7, 2012 3:25:32 PM

I have a 6850 to, and it does the same error message when I turn WOW from fullscreen to windowed mode. Wow works fine in fullscreen though, but I want windowed mode sometimes. :fou: 
February 8, 2012 3:28:30 PM

I am having exact same issue. It appears at odd times with no pattern.

Windows 7 (64-bit)
Version 6.1.7601
i5 quad core 2.8GHz
AMI BIOS v2.6

ATI Radeon HD 5900
Catalyst 12.1

The PS is new and with plenty of power so that shouldnt be it.
February 18, 2012 3:43:39 AM

try disabling aero on windows see if it helps.
February 18, 2012 6:01:45 PM

Boot in safe mode and Use driver sweeper to ensure all amd drivers are out.I had the same artifacts and issues with a HD6990.Also possibly use manual fan speed in ccc crank it up to make sure high temps are not an issue.Use gpu-z to monitor temps if need be.
February 25, 2012 5:34:43 AM

Quote:
Boot in safe mode and Use driver sweeper to ensure all amd drivers are out.I had the same artifacts and issues with a HD6990.Also possibly use manual fan speed in ccc crank it up to make sure high temps are not an issue.Use gpu-z to monitor temps if need be.


did that a long time ago

Quote:
try disabling aero on windows see if it helps.


will give a try, but unlikely this is the error.
February 29, 2012 10:40:18 PM

I had the same problem for the longest time on my hp dv6. I tried everything, but nothing seemed to work. Finally I tried disabling powerplay in the catalyst pro control center and the problem has not happened since. Don't know if this will work for you but it's worth a try. To disable powerplay go to the power tab in the catalyst control center and uncheck the box that says enable powerplay. Hope this helps you
March 1, 2012 1:32:59 AM

will try. Btw the disabling aero didnt help
March 1, 2012 4:53:49 PM

there is no option to mess with anything called powerplay
March 1, 2012 6:06:37 PM

have not been able to test a different PSU and I had the original video card replaced by newegg. I know this does not answer your problem but I think it does rule out the certainty of a faulty card. The computer does not regularly shut off so I am not sure if its the PSU but then again troubleshooting this side of the issue would not be my strong suit. I do wonder sometimes however if I should use the power extensions that came with the card or just use the chords that come directly from the PSU.
March 2, 2012 6:09:10 AM

Cool so do i just press the ON button or do i need to tick anything else haha
March 2, 2012 5:26:16 PM

Quote:
You could try using a tool like OCCT (http://www.ocbase.com/perestroika_en/index.php?Download) and doing the PSU stress test (will run your CPU & GPU @ 100%) and seeing if it causes issues.

Ok then results of the test are thus. "Stopped. Error Detected." During the PSU test. I assume this means that it is either my memory or core?
March 3, 2012 2:44:53 AM

I have yet to find a way to get memtest on a cd haha but ill let you know when i do. As for the CPU it is not overclocked.
March 4, 2012 4:22:24 AM

UPDATE: Ran the CPU OCCT no errors and then CPU Linpack and bam error in about the same amount of time as the PSU test. So must be the memory then?
March 4, 2012 2:59:32 PM

Ive never even attempted to OC the CPU. I tried burning the ISO to a disk 3 times and it did not work properly any of the times. Tech issues are so much fun!
March 4, 2012 5:05:14 PM

OK really everything you have tried, FORGET IT. ALL OF IT. I'm helping as much people with this problem cause i have had it too :( .
Ok forget everything you have already tried, and follow these steps exactly. I tried for litterally 40+ on this thing, and i KNOW this will work. PLEASE REPLY if it doesnt work and tell me what is wrong!

First off, i overcame this but i have slightly different spec than you. I have a radeon HD 5700 and windows vista, but they are almost identical, so it wont matter. I am not copying and pasting this fix, i made it up, so sorry if im not good with words. I know you said you installed the latest drivers and such but try this just to be sure.

this exact thing happened to me, i looked everywhere spent hours coming across things, but this is my own remedy. ok, so completely UNINSTALL your AMD/ATI drivers.-----> http://www.youtube.com/watch?v=ihVEGWrk5E4&list=UUqMGPT...

When the guy says "uninstall all ati folders" - this also includes any AMD folders also.

After uninstalling everything and rebooting like the guy says to, do this: go to your search bar in the lower left, and type "assembly" without the quotes. Next, go into it and click on public key token (this sorts them bye the public key token)
Next, delete everything with the Token “90ba9c70f846762e” (ATI’s key). You’ll obviously need Administrator privileges.

next, INSTALL your newest drivers ----->http://www.youtube.com/watch?v=qq_t45e1lJg&list=UUqMGPT...

after this is done, go to CCC (Catalyst Control Center). This might take 1-2 minutes to appear if you havent went into it for a wihle.

once you're in there go to performance (second tab from the bottom), then click on AMD overdrive.

Click on the check box saying "enable graphics overdrive" (so that it has a checkmark in it)

under that there should be a thing called "High performance GPU clock settings" put that at 825 MHz

under that there should be a thing called "high performance memory clock settings" put that at 1200 MHz

Under that there should be a check box saying "enable manual fan control" click it (so it has a check mark in it) now turn it up to 60. you might think this is very cold and your graphics card can get too cold to work, and while that is true its something like -30 degrees, so you have nothing to worry about

once you have done all this close CCC and restart your comp one last time. Run a game for a whille to make sure its working.

Ok, so i hope this helped, really! If it didnt work, or you have a problem (like ccc wont open) tell me! and if this did work, tell me! If i didnt clarify something, tell me! Ok best wishes - mattroxlol

IF YOU DIDNT READ ANY OF THIS READ THIS: believe me, this is the only way. Unfortunantly you will need to do this every time amd has a new update. Annoying!!! :bounce: 
March 4, 2012 10:40:15 PM

memtest decides it does not want to be recognized as a CD. Just runs the CD like a USB which is def not what i told it to do
March 5, 2012 3:52:28 PM

Memtest Results are thus:
TST Pass Failing Address Good Bad Err-Bits Count
7 2 001cdf8e3a0- 7391.5MB 243f616e 643f616e 40000000 1
6 4 0007ddd6c34- 2013.8MB ffffff7f 7fffff7f 80000000 2

I ran it once already and got the first error and then switched which slots the RAM were in and got the two errors you see here. I am going to run the test again and start taking out the RAM modules one at a time and see if the errors stop or not.
:pt1cable: 
Anonymous
March 5, 2012 5:44:53 PM

Hi,
i have this problem for one week too!
At the moment about every 20 seconds my computer is unable to respond for about 2 seconds, than the screen gets black (1~2 seconds) and normal again with the message "der anzeigetreiber wurde nach einem fehler wiederhergestellt der anzeigetreiber "amd driver" reagiert nicht mehr und wurde wiederhergestellt" on english: "the display driver stopped responding and has recovered. display driver "amd driver" stopped responding and has recovered"
But this afternoon my computer ran for an hour without the error!

550W PSU
MSI HD5850
Intel Q9950 @4x2,83Ghz
Asus P5QL-E motherboard
4gb ddr2 800 ram
Windows 7 32bit
March 6, 2012 4:39:45 PM

Alright then. Ran memtest through 10 tests on each card. Together and individually.

Together i got the errors you see above. When i ran them individually one got errors after about 10 tests while the other card had 0 errors after 16 tests. I think this can be chalked up as a memory issue? either way im gonna send in the RAM to Corsair and run my computer on one stick for awhile and see if the error happens again
March 6, 2012 5:23:29 PM

Still sound like a PSU problems to me...

Please convince me, for any of you people who had this kind of error message, that your PSU is capable enough, or just tell us what exactly that you use.

Honestly, I was having this same troublesome notice on my servers PC of my cybercafe, but after a quick maintenance, I suppose Thermaltake 500watt just don't have what it takes. So, I change it to Xigmantec at the same wattage. And it's been wonders ever since.
March 6, 2012 6:12:53 PM

No, I mean OP never really stated what exactly the PSU he used. The said damage to the RAM most likely will happen again on the future, or may not be just RAM. Perhaps something else. I have a really bad memory for such occasion. Changing stuff, mixing components here and there, and I still fry some other component with the PSU being the main culprit. And I thought I was using a powerful PSU, it boasts 750watt, but after I change it to a Xigmantec 500watt it never complains ever again.

I know there should be a way to test the PSU to re-assuring for it not the main culprit, if it did so, the result later on could be as fatal as I experienced...I just hate to see people experienced the same fate as I did...
March 11, 2012 12:49:08 AM

Its the RAM. took it out and now no issues in like 5 days. BAM
March 17, 2012 5:39:27 AM

mattroxlol said:
OK really everything you have tried, FORGET IT. ALL OF IT. I'm helping as much people with this problem cause i have had it too :( .
Ok forget everything you have already tried, and follow these steps exactly. I tried for litterally 40+ on this thing, and i KNOW this will work. PLEASE REPLY if it doesnt work and tell me what is wrong!

First off, i overcame this but i have slightly different spec than you. I have a radeon HD 5700 and windows vista, but they are almost identical, so it wont matter. I am not copying and pasting this fix, i made it up, so sorry if im not good with words. I know you said you installed the latest drivers and such but try this just to be sure.

this exact thing happened to me, i looked everywhere spent hours coming across things, but this is my own remedy. ok, so completely UNINSTALL your AMD/ATI drivers.-----> http://www.youtube.com/watch?v=ihVEGWrk5E4&list=UUqMGPT...

When the guy says "uninstall all ati folders" - this also includes any AMD folders also.

After uninstalling everything and rebooting like the guy says to, do this: go to your search bar in the lower left, and type "assembly" without the quotes. Next, go into it and click on public key token (this sorts them bye the public key token)
Next, delete everything with the Token “90ba9c70f846762e” (ATI’s key). You’ll obviously need Administrator privileges.

next, INSTALL your newest drivers ----->http://www.youtube.com/watch?v=qq_t45e1lJg&list=UUqMGPT...

after this is done, go to CCC (Catalyst Control Center). This might take 1-2 minutes to appear if you havent went into it for a wihle.

once you're in there go to performance (second tab from the bottom), then click on AMD overdrive.

Click on the check box saying "enable graphics overdrive" (so that it has a checkmark in it)

under that there should be a thing called "High performance GPU clock settings" put that at 825 MHz

under that there should be a thing called "high performance memory clock settings" put that at 1200 MHz

Under that there should be a check box saying "enable manual fan control" click it (so it has a check mark in it) now turn it up to 60. you might think this is very cold and your graphics card can get too cold to work, and while that is true its something like -30 degrees, so you have nothing to worry about

once you have done all this close CCC and restart your comp one last time. Run a game for a whille to make sure its working.

Ok, so i hope this helped, really! If it didnt work, or you have a problem (like ccc wont open) tell me! and if this did work, tell me! If i didnt clarify something, tell me! Ok best wishes - mattroxlol

IF YOU DIDNT READ ANY OF THIS READ THIS: believe me, this is the only way. Unfortunantly you will need to do this every time amd has a new update. Annoying!!! :bounce: 


Just tried all that and it crashed within 5 minutes. Black screen for the video card. I am running at Radeon HD 6870 with Windows 7 (32 bit).
March 18, 2012 2:59:47 AM

Best answer selected by mkadvil.
April 17, 2012 5:16:08 PM

just followed the instructions line for line and it didnt work.

im running
windows 7 64bit
amd radeon HD 6500M / 5600 / 5700 series
8.00 gb ram
intel core i7 cpu / q740 @ 1.73 ghz

three things that it might have been... [?]
[1] i couldnt find "assembly" to delete that bit and it wasnt in the youtube video.
[2] after i uninstalled the drivers and the reinstallation finished there was no backlight on the display. not sure what that was.
[3] the CCC control panel looked completely different than described. i couldnt find "performance" tabs or the other things


i still got the "Display Driver has stopped responding and has recovered"

and then about a minute later it just crashed.

thanks!


mattroxlol said:
OK really everything you have tried, FORGET IT. ALL OF IT. I'm helping as much people with this problem cause i have had it too :( .
Ok forget everything you have already tried, and follow these steps exactly. I tried for litterally 40+ on this thing, and i KNOW this will work. PLEASE REPLY if it doesnt work and tell me what is wrong!

First off, i overcame this but i have slightly different spec than you. I have a radeon HD 5700 and windows vista, but they are almost identical, so it wont matter. I am not copying and pasting this fix, i made it up, so sorry if im not good with words. I know you said you installed the latest drivers and such but try this just to be sure.

this exact thing happened to me, i looked everywhere spent hours coming across things, but this is my own remedy. ok, so completely UNINSTALL your AMD/ATI drivers.-----> http://www.youtube.com/watch?v=ihVEGWrk5E4&list=UUqMGPT...

When the guy says "uninstall all ati folders" - this also includes any AMD folders also.

After uninstalling everything and rebooting like the guy says to, do this: go to your search bar in the lower left, and type "assembly" without the quotes. Next, go into it and click on public key token (this sorts them bye the public key token)
Next, delete everything with the Token “90ba9c70f846762e” (ATI’s key). You’ll obviously need Administrator privileges.

next, INSTALL your newest drivers ----->http://www.youtube.com/watch?v=qq_t45e1lJg&list=UUqMGPT...

after this is done, go to CCC (Catalyst Control Center). This might take 1-2 minutes to appear if you havent went into it for a wihle.

once you're in there go to performance (second tab from the bottom), then click on AMD overdrive.

Click on the check box saying "enable graphics overdrive" (so that it has a checkmark in it)

under that there should be a thing called "High performance GPU clock settings" put that at 825 MHz

under that there should be a thing called "high performance memory clock settings" put that at 1200 MHz

Under that there should be a check box saying "enable manual fan control" click it (so it has a check mark in it) now turn it up to 60. you might think this is very cold and your graphics card can get too cold to work, and while that is true its something like -30 degrees, so you have nothing to worry about

once you have done all this close CCC and restart your comp one last time. Run a game for a whille to make sure its working.

Ok, so i hope this helped, really! If it didnt work, or you have a problem (like ccc wont open) tell me! and if this did work, tell me! If i didnt clarify something, tell me! Ok best wishes - mattroxlol

IF YOU DIDNT READ ANY OF THIS READ THIS: believe me, this is the only way. Unfortunantly you will need to do this every time amd has a new update. Annoying!!! :bounce: 

April 17, 2012 6:10:31 PM

This topic has been closed by Mousemonkey
!