Sign in with
Sign up | Sign in
Your question

DisplayPort errors from Catalyst for a S23A750D, but appears fine?

Last response: in Graphics & Displays
Share
January 5, 2012 10:24:37 PM

So I have a Samsung S23A750D connected to my RADEON 5770 using a DisplayPort. There are two issues that sometimes occur:

1. Sometimes when I boot up, Windows is running fine and dandy. After a short period, the monitor will go black as if it's not receiving signal, only showing the DisplayPort signal bouncing around. If I turn off the monitor and turn it back on, all is well and functional.

2. The second problem occurred today. It didn't lose signal this time, but Catalyst threw the following errors:

Quote:
The system has detected a problem with the connection between your computer and the DisplayPort display that will prevent you from using the highest resolutions and/or refresh rates. For more information, click on "Help".


After pressing Okay, I got this:

Quote:
The system has detected a problem with the connection between your computer and the DisplayPort display that will prevent you from using the highest resolutions and/or refresh rates.


I pressed Okay.

But as you can see:



Both the refresh rate and resolution appear to be fine.

The monitor is a week old. Googling around hasn't helped me too much. A couple suggested that this could be a power issue. How would one solve such an issue, if it's an issue at all? If anyone can give me insight on this it would be helpful.

More about : displayport errors catalyst s23a750d appears fine

a c 94 U Graphics card
January 5, 2012 11:14:08 PM

check cable between the graphic card and monitor for a good connection also try another monitor on the 5770 with the same cable,monitor loosing signal from card
m
0
l
January 6, 2012 12:17:10 AM

I mean the cables are firmly connected in. Unfortunately I don't have another DisplayPort monitor to test. Any other ideas?

Like I said everything appears to be working, so I'm assuming the Catalyst errors are on AMD's part?
m
0
l
a c 94 U Graphics card
January 7, 2012 12:11:20 AM

could you connect to your tv from the computer and does your motherboard have a onboard video
m
0
l
April 1, 2012 11:16:17 PM

I have the same monitor and had the same issues for couple months now. It would black out couple times a day giving me the " not recommended resolution" and hear the sound of usbing disconnecting or w/e but i lived with resetting with the power button. The thing is the monitor and graphics were all to my liking , high quality and 120fps actually showing now but the my fraps (game recording software) would record at low 30fps and struggle to run smoothly even with my ati radeon 5850. I thought that was normal because I know fraps supposedly makes the comp work harder... as you cantell i dunno much about computers. Anyway I ended up downloading Steam last night and it downloaded the CCC Catalsyt control center and from what I can tell it stopped the monitor from blacking out. The video card runs a LOT smoother , which is apparently how itw as always supposed to run because I can alt-tab out of World of Warcraft instantly in fullscreen non-windowed mode as if were windowed mode and my fraps is now recording at max 60 fps mark, how its setup to do which is kick ass. Anyway I know you already have the CCC but I just wanted you know my story because I've been searching for a way through this problem on google and there aren't many forums giving solutions. Seeing as this post is old I'm hoping you got some updated driver that solved your problem ;)  anyway it's a sweet monitor even with the problem heh
m
0
l
!