Sign in with
Sign up | Sign in
Your question

[Solved] GTX 560 TI no signal

Last response: in Graphics & Displays
Share
January 6, 2012 9:32:13 AM

Hi guys my GTX 560 TI finally arrived today, replacing my crappy GT 240 but then when i replace the card the screen goes blank and comes up with no signal! Then i replace it again with the GT 240 it works. So... I dont really know whats wrong..It might be because i have a crappy 500w power supply without the 2-6 pin PCI E wire. but i did connect the 2-6 pin power connecter adapter to my molex connecter, so i think its the power supply i think i have to buy a new one.. So yeah GT 240 still works but GTX 560 TI comes up with no signal.

My spec:

Asus m4n68t-m v2 mobo
AMD X4 955 black edition 3.2ghz CPU
4gb ram

Do any of you guys know why its doing this? Is it cause of the graphics card or power supply?

Edit: forgot to say that the fan is working on the GTX 560 TI card tho...

More about : solved gtx 560 signal

a c 175 U Graphics card
a b ) Power supply
January 6, 2012 9:51:57 AM

Change the PSU, it's not enough.

EDIT: Try to put it on an other system first anyway.
m
0
l
a b U Graphics card
a c 144 ) Power supply
January 6, 2012 10:06:46 AM

I would first try the card in another computer to make sure that the card is OK.
m
0
l
Related resources
January 6, 2012 10:13:35 AM

Thanks for the reply's guys, anyway I dont have any computer to try it on :/  and all my mates have PS3 and Xbox -.-

I decided to buy a new power supply since the one i have now is crap anyway. I just ordered a 760w power supply with 2x 6 pin connecter so...Hope it works!
m
0
l
a c 175 U Graphics card
a b ) Power supply
January 6, 2012 10:16:33 AM

What is it? You should get a decent brand OK?
m
0
l
a b U Graphics card
January 6, 2012 10:55:15 AM

Never heard of HPS, I think you bought a crappy one.
m
0
l
January 6, 2012 11:06:36 AM

Yeah looks crappy but i dont have much money and it was cheap so...:p 
m
0
l
a b U Graphics card
January 6, 2012 11:44:30 AM

Bad mistake. It might damage your components. A 600w ModXStream would be able to run the 560 Ti or this Fatal1ty 550w that I have. I got my Fatal1ty for $35 on sale.
m
0
l
January 6, 2012 12:00:34 PM

Damn..wish i knew those earlier, well i can always save up for those ones price aren't too bad. btw can you explain how it could damage my components?
m
0
l
a c 175 U Graphics card
a b ) Power supply
January 6, 2012 12:16:10 PM

Well most cheap or no name brand PSU don't have the good components in it, which is not going to be nice for the hardware.
m
0
l
a c 225 U Graphics card
a c 134 ) Power supply
January 6, 2012 12:24:48 PM

Before buying any PSU you should check out the reviews over at jonnyguru.com or another reputable source. The fact that reviews are hard to find on the HPS is a scary thing.

For one GTX 560 Ti, I'd recommend a 650 watter simply because if you go smaller, you don't save any significant money. If your MoBo is SLI Capable, you can get by w/ a 750 watter, but if you are over clocking the cards and the CPU, I'd get a 850 watter

650w $65 http://www.newegg.com/Product/Product.aspx?Item=N82E168...
850w $90 http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Both get 9.5 performance ratings from jonnyguru.com
m
0
l
a c 175 U Graphics card
a b ) Power supply
January 6, 2012 12:55:35 PM

Agree with that, get an XFX PSU.
m
0
l
January 6, 2012 11:49:25 PM

Thanks for the reply's btw when i put the GTX 560 TI my computers go wild i mean the sound gets really loud! Im still not 100% sure if its the power supply...

So..If i buy a new power supply and it doesnt work what would be the issue? the graphics card?
m
0
l
a b U Graphics card
January 10, 2012 11:40:35 AM

Find the source of the noise.
m
0
l
January 13, 2012 2:05:16 AM

My new power supply came today and now the card is working great! :D 
m
0
l
a c 175 U Graphics card
a b ) Power supply
January 13, 2012 2:17:34 AM

good good :lol: 
m
0
l
!