Sign in with
Sign up | Sign in
Your question

Won't recognize dedicated GPU?

Last response: in Graphics & Displays
Share
January 6, 2012 7:29:43 PM

When I tried to launch Skyrim, I went to the setting to maximize them. But, when I looked over to the Graphics Adapter, it showed Intel HD 3000, which my Processor has! Why won't they recognize the Dual GTX 570, that I have?
January 6, 2012 7:39:14 PM

Odd, try disabling one of the GTX 570s from SLI to see, or go to the BIOS and disable the Intel graphics adapter and see if that changes anything...
January 6, 2012 7:43:23 PM

digitalzom-b said:
Odd, try disabling one of the GTX 570s from SLI to see, or go to the BIOS and disable the Intel graphics adapter and see if that changes anything...


Can you please tell step-by-step how to do that with the BIOS?
Related resources
January 6, 2012 7:44:32 PM

digitalzom-b said:
Odd, try disabling one of the GTX 570s from SLI to see, or go to the BIOS and disable the Intel graphics adapter and see if that changes anything...


It still won't detect any of the gtx 570's
January 6, 2012 7:50:54 PM

Well, navigating you through the BIOS depends on which motherboard you have. Can you provide us with that information?
Generally once you get into the bios, you can look into onboard items and you might find graphics adapter or intel chipset, which you can disable.

I wouldn't do anything until you're sure of it though, try checking your motherboard manual (if you have it), most of the time you can also find it online on the company's website.
January 6, 2012 7:57:47 PM

More importantly, does it let you run the game on those high settings? If so, I wouldn't worry about it.

The i5 has that adapter built into it, so maybe it's just picking that up for some reason. In fact, I'm almost 100 percent positive that's why it's showing up like that. I think mine did the same thing for Skyrim, but it never caused me any issues.
January 6, 2012 7:58:38 PM

digitalzom-b said:
Well, navigating you through the BIOS depends on which motherboard you have. Can you provide us with that information?
Generally once you get into the bios, you can look into onboard items and you might find graphics adapter or intel chipset, which you can disable.

I wouldn't do anything until you're sure of it though, try checking your motherboard manual (if you have it), most of the time you can also find it online on the company's website.



I have a ASRock Z68 Extreme3 Gen3
Okay, so If I want to go to the bios settings, I should:
Restart my computer and while booting up hold F10?
January 6, 2012 8:25:57 PM

It is most likely picking it up because of the Virtu software if you installed that. Do not worry about it, it will route the heavy load to your good GPUs. If you are running the game on high settings then it is obvious that it is going through the correct cards as the HD3000 would not be able to do that.

Bios on the board is F2 or F10 (cant remember exactly and I am not on that computer at the moment). When I get home I can do an exact walk-though as I have that same board.
January 6, 2012 9:28:45 PM

CaedenV said:
It is most likely picking it up because of the Virtu software if you installed that. Do not worry about it, it will route the heavy load to your good GPUs. If you are running the game on high settings then it is obvious that it is going through the correct cards as the HD3000 would not be able to do that.

Bios on the board is F2 or F10 (cant remember exactly and I am not on that computer at the moment). When I get home I can do an exact walk-though as I have that same board.

That would be splendid!
January 6, 2012 11:15:20 PM

OK, finally made it home!
Del or F2 to enter UEFI (Bios is a thing of the past, but UEFI is basically the same thing)
Go to advanced settings, north-bridge, and then under the graphics setting make sure you have it set to PCI Express (not intigrated or PCI). Also, while you are in there take the opportunity to mess with your fan settings and such. I have all 3 of my 120mm fans set to level 1 and it works very nicely and very quiet. I also set the CPU fan to the lowest level until it heats up past 55*c, at which point the mobo takes over (even when doing video rendering I have never heard the fan kick up in speed, using a zalman cnp cooler). Do not forget to save settings on your way out.
If that it set up then you are good to go no matter what the software says. There is no way to really disable the onboard graphics completely, but so long as you have that selected and you are plugged into the nvidia card instead of the mobo, then it should be working fine.

Hope that helps!
January 7, 2012 7:26:08 AM

CaedenV said:
OK, finally made it home!
Del or F2 to enter UEFI (Bios is a thing of the past, but UEFI is basically the same thing)
Go to advanced settings, north-bridge, and then under the graphics setting make sure you have it set to PCI Express (not intigrated or PCI). Also, while you are in there take the opportunity to mess with your fan settings and such. I have all 3 of my 120mm fans set to level 1 and it works very nicely and very quiet. I also set the CPU fan to the lowest level until it heats up past 55*c, at which point the mobo takes over (even when doing video rendering I have never heard the fan kick up in speed, using a zalman cnp cooler). Do not forget to save settings on your way out.
If that it set up then you are good to go no matter what the software says. There is no way to really disable the onboard graphics completely, but so long as you have that selected and you are plugged into the nvidia card instead of the mobo, then it should be working fine.

Hope that helps!


So, when I'm done with this, as I recall, the integrated graphics will be used with playing videos?
a b Î Nvidia
January 7, 2012 7:34:58 AM

Are you sure you plugged the monitor cable to the primary card of your SLI configuration and install your drivers properly?
January 7, 2012 7:49:54 AM

refillable said:
Are you sure you plugged the monitor cable to the primary card of your SLI configuration and install your drivers properly?


No, my monitor is connected to the motherboard! With this type of plug: http://media.wiley.com/Lux/27/80327.image0.jpg
I don't have the connector, which can convert the regular to the gpu one
a b Î Nvidia
January 7, 2012 7:57:27 AM

That's where the problem! Because when you plug the cable to the motherboard, The Computer will BOOT FROM THE IGP :D !

Get yourself an adapter. I know it's such a waste that you have GTX 570 SLI and only can play with HD 3000 :( . But you don't have to worry because you can buy an adapter, good luck :) .

January 7, 2012 8:20:25 AM

refillable said:
That's where the problem! Because when you plug the cable to the motherboard, The Computer will BOOT FROM THE IGP :D !

Get yourself an adapter. I know it's such a waste that you have GTX 570 SLI and only can play with HD 3000 :( . But you don't have to worry because you can buy an adapter, good luck :) .


Can you please show an example of what adapter?
January 7, 2012 8:36:55 AM

Creav said:
No, my monitor is connected to the motherboard! With this type of plug: http://media.wiley.com/Lux/27/80327.image0.jpg
I don't have the connector, which can convert the regular to the gpu one


/facepalm. :o 

VGA to DVI/HDMI should do it.
!