Sign in with
Sign up | Sign in
Your question

Asus 6950 hd DirectCU II low fps

Last response: in Graphics & Displays
Share
January 8, 2012 12:01:12 AM

Hello,
Basically My games lag I get low fps it just drops below 30fps and I cant do anything. but not on all games, It happens when theres loads of buildings in a area or when im close up to something I get really fps. On Batman Arkhem city I will have around 45fps then it will go down to 12fps then when I go to a roof it will go to 35fps but it will never keep at a certain fps. On AMD Vision Engine Control center Im running 11.12 but when I change something on the 3D application lets say im getting 60fps on fifa 12 but when I go back to bf3 i get a crapy 35-40fps. My drivers are up to date. On the 3D setting I really dont no what to have on or off. I hope this has made sense Thanks

My PC specs
AMD Phenom X6 1090T
Asus 6950 DirectCU II 2GB
Asus m4a87td evo Extreme Motherboard
16GB DRR3 RIPJAWS G.SKILL
1.5TB Harddrive
Corsair 850watt Power Supply

Battlefield 3- 45-80fps
Fifa 12- 60fps
APB Reloaded-60fps
World of tanks- 60fps
Just cause 2-60-80fps

Batman 1 and 2- 5-45fps This game I cant play very well.
Need for speed the run- 35-40fps but when i drive it will suddenly go down to 15fps or 25fps
Plus other games
Star wars old republic 25fps or lower.

Please help
a b U Graphics card
January 8, 2012 12:13:14 AM

Generally unless a game is missing its own options (like SW:TOR with AA), I set CCC to "Use application settings".

Are you forcing on heavy AA and/or AF through the driver? Are you running at higher than 1920x1080?
January 8, 2012 12:19:43 AM

file:///C:/Users/Curtis/Downloads/Pc.png
file:///C:/Users/Curtis/Downloads/pc2.png
Related resources
a c 253 U Graphics card
January 8, 2012 12:52:58 AM

Maybe you should adjust the settings a little lower and see what you get.
a b U Graphics card
January 8, 2012 1:06:31 AM

Make sure in games that support it to use the DX11 mode.

But without going through each one of your game's individual settings why don't you try running a benchmark like 3dMark11? That will tell you if similar systems to yours are performing similarly. Don't expect the visuals on the benches to look smooth - just pay attention to your scores and compare them to similar systems.
January 8, 2012 2:46:42 AM

inzone said:
Maybe you should adjust the settings a little lower and see what you get.

Doesnt make any difference.
a c 253 U Graphics card
January 8, 2012 1:12:22 PM

Can you give us a little history about what is going on. Did you just add the video card to your system? Has this situation been happening since you installed the card? Did this just start doing it and you have had the card for some time? Has there been any hardware or software changes to your computer recently?
Basicly trying to find a connection to the lower fps and something in your computer.
January 8, 2012 3:55:31 PM

Ok my first build was the same as I have but I changed the Ram I did have the Patriot G series (2X 2GB) Running at 1600Mhz, Also at that time I had a XFX HD 5950 1GB. Same motherboard same Processor. So it went like this, It was a Motherboard bundle I got it from Dabs.com so all parts should work nicely.

AMD Phenom X6 1090T Black Edition
Asus M4A87TD EVO
Patriot G series DDR3 4GB 2x2GB Black Edition
That was the motherboard bundle
XFX HD 5950 1GB
Hatichi 500GB Hardrive
600watt Power supply

Now that was about A year ago I think, Ive just starting playing on PC. P.s I played on Xbox 360 badtimes.

At the time I dont remember if I had low fps because I didnt no about it at the time. Now that I have been on computers Im starting to see how things work ect. Cant Remember sorry.

Now about 1month ago my processor broke so got a new one same one as before, Dont see any problems with new one, Also same with the RAM it broke so got a new one. Then bought the Samsung 1 TB Harddrive no problems. on the 9 Aug, 2011 I bought my new Graphics card. I starting playing games okay Like they should. But Games dont really play smoothly like they should. But I play bf3 fine I can get 75fps or 80fps but when I go on a different Game like Batman or Assasins creed it just Doesnt run smoothly, Well Because of low FPS.

I did have 8GB ram but then got another 8GB ram this is the Ripjaws.

Oh I was running Everything with the 600w power supply but later on when I got a new Case the Corsair 600t In white, I bought my self a Corsair 80plus gold 850w power supply. My dad helped me move everything in my new case So nothing got damaged.

This is maybe hard to understand that I am sorry but all the information you need to no is here. Hope this helps. Thanks


a c 253 U Graphics card
January 8, 2012 5:17:53 PM

I'm not sure how you keep having broke parts , first the cpu then the ram , it doesn't sound good that the parts keep breaking.Makes me think something is wrong with the motherboard or if there was something wrong with the old psu that may have damaged the motherboard before you switched to the new psu. Maybe the video card is defective.
January 8, 2012 10:01:57 PM

inzone said:
I'm not sure how you keep having broke parts , first the cpu then the ram , it doesn't sound good that the parts keep breaking.Makes me think something is wrong with the motherboard or if there was something wrong with the old psu that may have damaged the motherboard before you switched to the new psu. Maybe the video card is defective.


No umm My mate broke my old cpu long story but he did and my Ram burnt out on another motherboard long story . Basically I have a CrossHair V Formula but cant get it to work because I keep getting blue Screen. But thats another story. Everything I buy seems not to work.
!