Sign in with
Sign up | Sign in
Your question

Usb device damage due to faulty usb

Last response: in CPUs
Share
June 26, 2012 4:05:10 PM

i just bought a new mouse because my older ones got scrolling problems.so after few days the same problem in the new mouse so i replaced it and after a week same problem in the new mouse.i think my usb ports are damaging it i tried all the usb ports as i used different usb ports for all three.how do i solve this and what is causing that? and it is only affecting mouse not keyboard or other usb devices.
June 26, 2012 4:43:05 PM

Did you test those bad mice on another computer? If they work fine on another PC, then you might want to try updating the chipset drivers for your (USB controller) motherboard. And you can always install the official drivers for your mouse from the manufacturer.
a c 176 à CPUs
June 26, 2012 4:43:13 PM

junkin said:
i just bought a new mouse because my older ones got scrolling problems.so after few days the same problem in the new mouse so i replaced it and after a week same problem in the new mouse.i think my usb ports are damaging it i tried all the usb ports as i used different usb ports for all three.how do i solve this and what is causing that? and it is only affecting mouse not keyboard or other usb devices.

have you tried the new mice on another pc or laptop to see if there dead??
most time it could be older drivers that are still loaded in windows. did you uninstall the older drivers or use safe mode and a drive sweeper??
Related resources
June 26, 2012 4:47:50 PM

i tested on other pc and they are damaged permanatly.
June 26, 2012 4:48:45 PM

i tested on other pc and they are damaged permanatly.
June 26, 2012 5:02:40 PM

already tried that and also formatted the pc..but i m not getting what is damaging my mouse.and the problem is always in the scroll,when i scroll up sometimes it scrolls up and sometimes it scrolls down,irrational fucnctionality of scrolling.
a c 176 à CPUs
June 26, 2012 5:20:10 PM

are they the same brand mice or are the more then one brand.
http://www.beyondlogic.org/usbnutshell/usb2.shtml
as you can see there only one pin that should be around 5v. if it a lot higher then there an issue with your mb.
if there the same mice i would contact the vendor and see if they can swap out one of the dead mice for another modle..could be a defect in the mice.
!