Sign in with
Sign up | Sign in
Your question

Remote desktop kills my workgroup connection

Last response: in Networking
Share
March 29, 2011 12:54:11 PM

I have a home network with one desktop (xp pro) connected to a router (motorola netopia 2247-62) via ethernet and two laptops (vista home premium, and 7 starter) connected via wireless. they are all on the same workgroup, all sharing and printer (connected to the desktop) work fine. However, I have just set up Remote Desktop connection to the desktop, and when i set up the router to allow remote access and then port forward to the desktop, the desktop dissappears from the workgroup and therefore so does the printer and mapped drives. My current solution is to only enable remote access while i am not at home, but this still leaves the other laptop out of the network and also, what happens when I forget to set the router before leaving?

Is there a solution to keep the workgroup fully active while allowing remote desktop, or do i need to set up a domain or a vpn or server?
please help.
thanks
Kev

March 29, 2011 1:54:50 PM

To be honest, I've never heard of this problem before w/ RDP. Then again, I rarely use RDP for a host (no pun intended) of reasons. It is possible you’re logging on as a different user when running RDP? I’m just wondering if maybe your printer/folders are being shared under one account, then you log onto RDP w/ another, and then those resources become unavailable under the RDP user’s session (total speculation).
m
0
l
March 29, 2011 5:02:20 PM

So RDP and WORKGROUP home networks are not mutually exclusive. Have you had this arrangement yourself, or do you use domains?
I don't think it's a problem with RDP itself anyway, more to do with the router settings and firewalls perhaps creating a conflict of interests. But to rule it out, I was logging in to the Desktop via RDP from outside the router using my own user account details which is the primary admin account on the desktop. This is the same account that I use for Workgroup authorisation.
The problem arises when I set port forwarding to the desktop, it dissappears of the workgroup list. Perhaps I should be looking for some setting either on the router or on my desktop that will counteract this loss.

m
0
l
!