Sign in with
Sign up | Sign in
Your question

New Built PC - Can not connect to internet

Last response: in Systems
Share
March 14, 2012 10:09:14 PM

Hi,

I've just Built a new PC and everything works except I can not connect to the internet even with my Ethernet Cable connected and thats connected to the Router which use to work on my old PC. It comes up with:

"Windows could not find a driver for your network adapter" when I troubleshoot it.

Is this to do with a cable I wired wrong or is it just a simple software issue? Please help.

Thank you.

More about : built connect internet

a b B Homebuilt system
March 14, 2012 10:21:03 PM

You need to install the driver for the ethernet controller. If the RJ-45 jack is on your motherboard, go to the motherboard manufacturer's Support website for your model motherboard, download and install the driver for your operating system
March 14, 2012 10:35:53 PM

Do I need the internet to download a driver off their website though? Or do i use the disk I got with my motherboard? Either way I will have to do it tomorrow now. Thank you for the advice.
Related resources
a c 82 B Homebuilt system
March 14, 2012 10:37:47 PM

Did you install the drivers that came on a CD that should have been in the box with the motherboard?

Install those first then get the newest drivers from the manufacturers website.
a c 118 B Homebuilt system
March 14, 2012 10:38:11 PM

mayron4077 said:
Do I need the internet to download a driver off their website though? Or do i use the disk I got with my motherboard? Either way I will have to do it tomorrow now. Thank you for the advice.



The disk that came with the mobo may or may not have it. Its always a better idea to get it off their website to ensure you have the most recent version available. You can download it from a computer that does have internet, put it on a flashdrive, burn it to a cd, what have you.

I know its a pain, my Asus Sabertooth I just put in, didn't come with internet working right out of the box either. Fortunately, I was aware of this from reading reviews on Newegg, and had the drivers ready to go before the UPS man brought it to my door.
March 14, 2012 10:49:05 PM

Okay great thank you. I didn't think installing it from the disk would be the solution. I've never done this before so I had not got a clue. I knew it must of been something simple but unfortunately I have had to turn it off and leave it for tomorrow in a hurry so didn't have more time to experiment. But thank you! If for any reason it does not work, I will post a reply.
a c 82 B Homebuilt system
March 14, 2012 10:50:12 PM

No computer ever had the internet working "right out of the box" unless it was a prebuilt. Must be your first computer.
a c 82 B Homebuilt system
March 14, 2012 10:52:24 PM

mayron4077 said:
Okay great thank you. I didn't think installing it from the disk would be the solution. I've never done this before so I had not got a clue. I knew it must of been something simple but unfortunately I have had to turn it off and leave it for tomorrow in a hurry so didn't have more time to experiment. But thank you! If for any reason it does not work, I will post a reply.



All of the drivers on that disk are necessary. The bundled software I'm sure was included is not. Make sure you install all the drivers though.
a c 118 B Homebuilt system
March 14, 2012 11:00:34 PM

anort3 said:
No computer ever had the internet working "right out of the box" unless it was a prebuilt. Must be your first computer.



My first build yes. Must have been a fluke then that I saw so many people in the reviews complain about the internet not working as-installed. I put this mobo in because my original died, but I used the disk that came with it right away. So it had internet.
!