Sign in with
Sign up | Sign in
Your question

Cant overclock 3570k on Gigabyte GA-Z68A-D3H-B3?

Last response: in CPUs
Share
June 30, 2012 10:33:50 PM

I was recently able to acquire a 3570k to replace my old 2500. It's not like I expect to see any noticeable improvement in my gaming, but hey it's a newer processor and I figured I might as well use it.

But before I get into my problem/question, I'll list my rig specs.

Corsair 400d Case
Antec 750w psu.
EVGA gtx 560 Ti.
GA-Z68A-D3H-B3 revision 1.3 motherboard with f13 bios
500gb Hitachi 7200rpm drive
120gb Mushkin ssd
8gb 1600 g.skill ram
CM Hyper 212+ cpu cooler
i5 3570k

OK I think that's it. So yesterday I flashed to the newer bios and replaced the old i5-2500 with the i5-3570k, and all was well (except for a minor derp moment where I didn't push one of the ram sticks all the way down which caused boot loops). After a few hours of Prime 95 I decided to go for the overclock. I went into the bios and the bios does indeed recognize the chip as a 3570k, however when I go to the CPU clock ratio it limits me to a cap of 3.8 GHz. Why is this? Is there something I need to do inside of windows (maybe driver related), which will help the mobo to realize that my processor is unlocked? Here are some pictures I took of the bios screens, thank you for looking/helping!









a b à CPUs
June 30, 2012 10:42:03 PM

Go into "Advanced CPU Core features" (2nd pic menu)
June 30, 2012 10:59:28 PM

Hold on one moment... (trying it)
Related resources
June 30, 2012 11:02:48 PM

i had to disable turbo mode to be able to overclock it. asus maximmus gene z. z68 with 3570k running at 4ghz.
June 30, 2012 11:06:37 PM

Alright I still get the same limit when in the "Advanced CPU Core features" (took a picture but I feel that you hearing this is proof enough, right?), so let me try your suggestion boabs and disable turbo.
June 30, 2012 11:12:33 PM

Alright I disable turbo boost, however it is STILL giving me the 3.8GHz cap. More than that, but when I open CPU-z it is registering me at 1.6GHz... with turbo boost disabled??? I set the core to 3.8GHZ in the bios and, aside from turbo not actually being disabled, when stressed it is still going to 3.4GHz. What the hell is going on here lol? Any suggestions?
a b à CPUs
July 1, 2012 12:06:11 AM

Upgrade bios to U1a
July 1, 2012 12:20:18 AM

I actually tried doing that, but when in Q-Flash it wasn't able to properly identify the bios file. My flash drive is formatted to fat32, anything else I should do to help it to work? Or should I just try again?
a b à CPUs
July 1, 2012 12:45:37 AM

Says on the bios download section at your motherboard page -
"UEFI BIOS
(When updating from legacy to UEFI, use only the utility attached to your BIOS file)"
July 1, 2012 12:48:25 AM

Just downloaded the U1a and, as their website says, "When updating from legacy to UEFI, use only the utility attached to your BIOS file". When I extracted the file I was given three files: FLACHEFI (application), the U1a bios file, and autoexec (windows batch file). Assuming (correctly?) that the autoexec is the utility, I double clicked and a command prompt popped up, however than a message saying that the file was not compatible with my 64 bit version of windows. ???. I tried running as an admin and it crashed as soon as it popped up. Just for shiggles I fried to use the file in Q-Flash in the bios, but it was hacing troubles identifying the file and wouldn't work. Do I just have to wait for Gigabyte to release a bios that is compatible with a 64 bit friendly new bios?
a b à CPUs
July 1, 2012 12:54:48 AM

Right click on autoexec, go to the compatibility tab, check "Run this program in compatibility mode for:" and on the combo box select "Windows XP (Service Pack 3)".

If this doesn't help, then you'll have to run it on a 32bit environment, which sux. But anyway it's no biggie cuz I don't think the bios is the problem (although having the latest version never hurts). You should verify that you indeed have the 3570k and not the 3550 or smth like that, and if you do, I suggest you contact Gigabyte support with your problem (through their website).
July 1, 2012 1:17:58 AM

Box, Processor itself, CPU-z and Mobo all say 3570k. Running in the Windows XP setting still gives the same message; the program is unfriendly with 64 bit environments. I actually sent a message to Gigabyte yesterday, but they have yet to get back to me. As a hopeful fix, how would I go about running it in a 32bit enviornment? P.S. thanks a ton for helping, this site rocks!
a b à CPUs
July 1, 2012 1:30:53 AM

Plz post the "Advanced CPU Core Features" submenu, I would like to get a look. Thanks
July 1, 2012 1:58:05 AM

Here we go:



July 3, 2012 5:44:06 PM

Ok so I found out that I had to boot from the USB drive which had the three files on it. It's all good now, I have the UEFI bios, and I'm steadily working up my overclock (probably stop around 4.6GHz). Thank you all for the help!
!