Sign in with
Sign up | Sign in
Your question

PC TV hdmi display sound on/off situation

Last response: in CPUs
Share
July 1, 2012 4:50:07 AM

Hi, I am running into an issue when sometime I turn on my computer or restart it, the sound would switch to another audio device. I can fix it by either restarting my PC again or just take the hdmi cable out from my graphics card and just replug it in again and I get sound coming from my hdmi to my TV. I even went into bios and set my graphics card as first boot. I am running an intel i5 3570k cpu with gigabyte z77x-ud5h mobo. The sound happens unexpectedly but I would like to have this issue fix so everytime I can get sound out from my TV via hdmi. I even uninstall realtek audio drive since I am using nvidia audio driver. I thought that would fix it but apparently it didn't anyone have any ideas on how I can fix this issue, would be very helpful. let me know, thanks
a b à CPUs
July 1, 2012 7:03:51 AM

go into control panel/sound and then disable all of the devices except the one you are using....this should prevent windows from switching it on you....and for future reference this is how you can switch back to hdmi sound oh and btw the cpu section is not prolly the right section for this thread
m
0
l
July 1, 2012 10:56:38 PM

drums101 said:
go into control panel/sound and then disable all of the devices except the one you are using....this should prevent windows from switching it on you....and for future reference this is how you can switch back to hdmi sound oh and btw the cpu section is not prolly the right section for this thread



Hey, I disable all the other devices but sometime my tv sound icon is not listed until i take out the hdmi cable and replug it back in my graphics card. I don't know why it keeps disconnecting from my TV even though my hdmi is connected to my gpu.
m
0
l
Related resources
a b à CPUs
July 2, 2012 1:01:04 PM

do you have the hdmi tv sound icon set as default? also what gpu do you have installed in the system? You should try to uninstall and reinstall your nvidia drivers
m
0
l
July 2, 2012 9:10:04 PM

drums101 said:
do you have the hdmi tv sound icon set as default? also what gpu do you have installed in the system? You should try to uninstall and reinstall your nvidia drivers



Yes the hdmi tv icon is set to default automatically, but somehow I cannot press the set to default icon, is grey out but it is connected to my tv via hdmi for sound. But at times the tv icon will not show up and i will have to disconnect the hdmi from my GTX 670. That is the only way i can fix it. I haven't try reinstalling my nvidia drivers, I will give that a try.
m
0
l
July 2, 2012 10:59:59 PM

Have you tried setting it through the nvidia settings or just control panel?
m
0
l
July 3, 2012 4:15:25 AM

mac_mac_attack said:
Have you tried setting it through the nvidia settings or just control panel?



yes I try that too. Nothing seem to work.
m
0
l
a b à CPUs
July 4, 2012 5:46:59 AM

Try removing your NVIDIA drivers and resintalling them. The not being able to click the default icon is kinda weird makes me think there is sometbing weird going on in the software side of things
m
0
l
!