Sign in with
Sign up | Sign in
Your question

How to update the ROM of my Asmedia 1061 Sata 6G Controller

Last response: in Components
Share
July 2, 2012 4:34:30 PM

Hi there guys, I just wanted to update the firmware of my Asmedia sata3 controller. I have all that I need except knowledge on this. There are 2 executables that cant run on windows expect from bios. Which commands sgould I give? I provide a link with the files of the update. Thanks guys!
http://www.station-drivers.com/telechargement/asmedia/a...(www.station-drivers.com).zip
July 2, 2012 5:54:37 PM

Is this for a stand-alone card or for a controller integrated onto your motherboard? If for a motherbord controller, what make/model of motherboard are you using?

July 6, 2012 6:36:34 PM

2573669,1,1088942 said:
Hi there guys, I just wanted to update the firmware of my Asmedia sata3 controller. I have all that I need except knowledge on this. There are 2 executables that cant run on windows expect from bios. Which commands sgould I give? I provide a link with the files of the update. Thanks guys!
http://www.station-drivers.com/telechargement/asmedia/a...(www.station-drivers.com).zip[/quotemsM

1 Make a bootable usb with dos and copy all the files (extracted asmedia 106x firmware).
2. boot pc with usb
3.when the dos boot,run the command 106spi -u ahci95A1.rom
August 17, 2012 5:48:35 PM

hi there! what about flashing a new bios 0951? i find it on station-drivers with only one BIN FILE/ I TRY TO REPLASE IT IN PREVIOS firmware utility-but it is not working/ i made usb dos startup flash- copy there all files from 095 version but it also not working/ any ideas??? thanx
August 17, 2012 5:51:41 PM

necrogeddon said:
Hi there guys, I just wanted to update the firmware of my Asmedia sata3 controller. I have all that I need except knowledge on this. There are 2 executables that cant run on windows expect from bios. Which commands sgould I give? I provide a link with the files of the update. Thanks guys!
http://www.station-drivers.com/telechargement/asmedia/a...(www.station-drivers.com).zip


hi! are u update u bios succesfully? what about new august version of bios?
August 28, 2012 12:15:26 PM

I've updated the bios to 095 making a bootable usb and throwing everything inside, then I booted from the usb and flash bios through the program thats inside. This method does not apply to the new firmware thats missing a .ROM file
August 28, 2012 7:45:15 PM

hey guys, you may just need to rename the bios file from .bin to .rom

it may work. most times, .bin files are just renamed .rom files. if not, there may be programs to change the file from one to the other. maybe NIBITOR bios editor? should work.

also, before you try to flash the .rom, see under device manager under properties if the card has a flash firmware section. that usually comes in handy. i am not too sure if the asmedia chipset has one though. i am referring to my sil3114 driver properties. i use that to flash the card bios. maybe its the same?

ah well, good luck!
October 30, 2012 1:13:16 PM

necrogeddon said:
I've updated the bios to 095 making a bootable usb and throwing everything inside, then I booted from the usb and flash bios through the program thats inside. This method does not apply to the new firmware thats missing a .ROM file


Well, this is a noob question, but... how exaclty did you do that? I made my flash drive bootable following these steps (http://www.wikihow.com/Make-a-USB-Bootable), then placed the files from the archive (0.95) onto the usb drive, rebooted, selected in turns USB-FDD, USB-ZIP, USB-CDROM as first boot devices, but it failed to run.

What am I doing wrong?

I want to try and fix the PCI-E 1.0 mode it's running into right now, on a PCI-e 16x 2.0 slot (DFI Lanparty DK-P45-T2RS Turbo).


Thanks in advance!
!