Sign in with
Sign up | Sign in
Your question

Sapphire 6950 2GB crashes with black/blue screen

Last response: in Graphics & Displays
Share
January 14, 2012 8:24:33 PM

My new Sapphire 6950 2GB frequently crashes with either a blue screen with vertical lines, or a black screen. The rest of the computer seems to run fine in the background, but the display won't come back without a restart. I upgraded it from a 4870, removed old drivers, installed latest drivers (I've tried some older drivers too), and have recently replaced the PSU to a Corsair CX600 V2 80+ which should be plenty?? I've seen lots of other very similar issues with 6950's around but no solutions. Any ideas?
My system is:
Gigabyte GA-780G-UD3H
AMD Phenom 7950 Quad 2.4
4GB DDR2 800 RAM
Corsair CX600 V2 80+ PSU
and a couple of seagate 1tb hdd's

Thanks!
January 18, 2012 9:00:22 PM

I have a Sapphire 6950 2gb myself and evidently the card isnt too good with overclocking. So have you oc'd your card? if yes then try going back to default values or oc the card using Trixx while increasing the voltage to make it sable.
m
0
l
a b \ Driver
January 18, 2012 9:20:16 PM

Did this happen before or after you replaced the psu or did you replace the psu to see if it would make the crashes stop.
m
0
l
January 18, 2012 10:58:39 PM

I replaced the PSU when I had my 4870, and it worked fine. Crashes only started when I upgraded to the 6950. I noticed the PSU was only supplying 2.8V on the 3.3V rail, so I returned it and swapped it for a Cooler Master GX650, which has fixed the problem. I will not go near the Corsair CX series again. Thanks!
m
0
l
!