Closed Solved

Catalyst control center 11.12'-dont open

I just reinstall my windows because there was a virus on my computer that i could not remove so when i went to install my drives again the CCC only shows in the task bar and it will not open up to where i can see the whole thing i liked tried everything from looking around. I have a ATI Radeon HD 3870 card. AMD CPU and windows vista.
6 answers Last reply Best Answer
More about catalyst control center dont open
  1. Best answer
    Yes, AMD CCC does that sometimes to me, to open it, right click the CCC taskbar icon, and click on "AMD Catalyst Control Center", it works for me.
    If the problems persist, just update your driver, and don't download beta ones.

    Hope it helps! :)
  2. So the one i downloaded was a beta? if so which one isnt the beta.
  3. I don't think 11.12 is a beta but I was telling you to not download a newer driver that is a beta.
  4. And also, it may be a CCC service issue, you can just re-install the drivers.
  5. Best answer selected by Icee.
  6. Im glad that I could help. :)
    If you still find that annoying, I think in the newer drivers they fixed that somehow.
Ask a new question

Read More

Radeon Catalyst Graphics