Sign in with
Sign up | Sign in
Your question

Moniter shuts off ramdomly

Last response: in Graphics & Displays
Share
January 17, 2012 9:47:36 PM

Hello, i am running a hp pavillion with an integrated nvidia 3600 vid card. i recently installed a radeon 3650 1g vid card. after running for a week i noticed that the card was shutting off and repairing it self(?). last night the monitor stopped receiving signals. ( samsung sync master 920nw). it has a blue power button that blinks like it is in sleep mode. i bought a 520w power supply and installed it.
after about 10 min the moniter will come on

any ideas as to how i can resolve this problem

More about : moniter shuts ramdomly

January 17, 2012 10:43:04 PM

I would uninstall the card and try the onboard if that fixes the issue there is something wrong with the card. Then if under warranty RMA.
January 18, 2012 12:17:23 AM

Is the Monitor new? If it is, it may be also the Monitor that is somewhat broken, if you are sure that it is your new AMD Radeon card, return it if it is under warranty.
It may be an driver issue. Did you install official Display Drivers from directly AMD? Don't ever install display drivers from Windows Update.

Also you could buy an HD 6570, which is faster and cheaper than an 3650.

Hope it helps! :) 
Related resources
January 18, 2012 12:33:45 AM

thank you for your replies.
the monitor does turn on after about 5 min or so. works fine until i try to play a real game (not that facebook stuff.)
then it seems to goto sleep for a while.

i did buy that radeon 6570 last night but i get the same problem after i install it.
January 18, 2012 12:45:10 AM

Are you sure that both of the cards doesn't work and does the same problems? What is your motherboard? Some older motherboards may not be compatible with newer graphic cards...

Also, what is your Power Supply (PSU)?
January 18, 2012 1:00:07 PM

bloc97 said:
Are you sure that both of the cards doesn't work and does the same problems? What is your motherboard? Some older motherboards may not be compatible with newer graphic cards...

Also, what is your Power Supply (PSU)?


just installed a dynex 520 watt atx psu
January 21, 2012 12:25:24 PM

fixed thank you all
!