Sign in with
Sign up | Sign in
Your question

Problem with HD6870 to single Display in new build.

Last response: in Graphics & Displays
Share
January 20, 2012 1:38:42 PM

okay, i recently put a whole new build together after years of my old one, finally moving up to current ish tech.


Asus Sabertooth 990FX
16GB corsair vengeance
AMD 8120 (the 8 core 3.1GHz) did originally have this clocked to 3.8, but turned that off after i got problems on the very first boot up.
XFX HD6870 1gb GDDR5 (i have a second of these, but didn't want to fuss around with crossfire till i'd got the one working properly drivers and all. second is still completely sealed and boxed up.)
Corsair 60GB SSD
2x WD 1TB 7200RPM Storage Drives


okay, now first thing i did was just let it run idle in the asus bios level system monitor, just to check i had all the cooling and everything plugged in right, and that power was stable. everything was fine. proceeded to do my overclock, then did another hour stability check in bios, temp went up by 9C in idle. used a little utility in ASUS bios to run the processor at max load for 2 minutes, temp was stable at less than 60c 40 seconds in, didn't move after that.
i then proceeded to setup my hard drives, installed windows 7 64-bit and everything went fine, then started installing programs, first time glitch occured was when installing realtek audio drivers for the front panel on my Level 10 GT snow case. screen went black, then striped grey, then it reappeared, and looked like it had moved 300~ pixels to the left, and those pixels where now displayed on the right, system was still fully responsive, temperatures fine, so i turned it off, checked for any cables or anything touching anything. all good, i had spent a while doing cable management. i then installed a game, battlefield 2, (i still play a few mods with friends and create content in my spare time for the project reality mod).
install went fine, installed all the latest patches, checked all my drivers, checked directX, used compatability, all fine. start up the game, and bam, same problem as before, 300 pixels moved left, and placed on the right side of the screen. now interestingly, whilst playing the game, the arrangement kept jumping around, and sometimes repeated along the top, sometimes bottom, sometimes both x and y axis.

since, i've tested every program i can think of, bf3, crysis, bf2, windows media player/centre, shogun total war 2, all set off the same error.

the display is a single 40inch samsung LED TV (older model, not the new 3d ones) connected straight up by a brand new, solid gold connectors hdmi lead, have also tried DVI to DVI (yes i'm aware only one is capable of both digital and analog, i tried both, same error each time), all my drivers for everything are the latest straight from manufacturers, everything is seated properly in the case, and i have a 900W PSU.


any Ideas? if it'll help, i can cause the error and take some pictures with my phone. screenshots turn out fine when saved and opened in paint.
a b U Graphics card
January 20, 2012 2:00:36 PM

Interesting situation. Is the display displaced in the bios view? Does this happen only during games or is the display corrupted for the windows desk top and in other programs like email, web browser, Office or whatever non game applications you have? Do you have a monitor not a TV that you can attach to see if it make a difference? I doubt the sound drivers are involved but you can use Driver Sweeper (http://phyxion.net/item/driver-sweeper.html) to completely remove them to test that out. I assume you have installed catalyst control center . Under "My Digital Flat Panels" un-check everything especially the image scaling option; Scaling Options tab set to 0% and unchecked also and do not use LCD Over Drive. These are the latest video drivers (http://support.amd.com/us/kbarticles/Pages/Catalyst121a...), install them. You can test your video card by swapping it for the new one you already have. I suspect that there is a mismatch between the video card and it's divers with the TV. Check to see that the resolution matches the TV's default.
January 20, 2012 2:09:28 PM

the resolution and frequency both match, and no, i have no access to a monitor, i'm up at my uni flat, not my home. one of the things i find odd is that whilst the new drivers (which i had done a driver sweeper clean install of a few hours ago) do now allow me to pick a 75Hz refresh rate, at 75Hz, they don't allow selection of the 1920x1080 or higher resolutions, which this screen does support. i didn't have any of those options in my digital flat panels on, and scaling option was at 0%.


EDIT: and as for it only happening whilst gaming, no, its happened once whilst i was sorting out files through windows explorer, and now whilst i was watching a video through flash.
Related resources
a b U Graphics card
January 20, 2012 2:14:19 PM

Try un-installing the AMD drivers. Is the problem still there using the windows native drivers? This does sound like an over/under scanning or scaling issue.
January 20, 2012 2:19:44 PM

indeed, when i was using the native windows drivers, not a single problem, i have done 2 complete clean installs of the latest driver/CCC package. i've actually tried a whole new install of just the Display and OCL drivers, and that had no glitches whatsoever, but obviously, crossfire becomes harder to manage without access to CCC. i'm sure it must just be a setting somewhere in CCC, but i can't see anything i have turned on.
January 20, 2012 3:12:34 PM

okay, installed the other card, everything runs perfectly now, guess i'll just RMA the broken one and get a replacement.
thanks for the help anyway guys, was hoping to avoid this, but i guess thats just life.
a b U Graphics card
January 20, 2012 9:38:34 PM

If I was a help please select as best answer. Thanks and good luck
!