Sign in with
Sign up | Sign in
Your question
Solved

New build won't POST

Last response: in Systems
Share
March 28, 2012 3:38:34 AM

Hey guys. Just put together my new build, and I'm having a bit of an issue with it. I plug it in, fans come on, lights come on, a ray of light comes down from the clouds and angelic choirs start singing, but it refuses to POST. I looked over everything, and I have a solid red light indicator on DRAM. So I don't know if this is a motherboard issue or a RAM issue. Any help would be awesome, before I see how far this thing can fly off my balcony. Thanks.

ASUS Sabertooth X79
Intel Core i7-3820
EVGA GeForce GTX 570
G.SKILL Ripjaws X Series 16GB
Western Digital Caviar Black

More about : build post

Best solution

March 28, 2012 6:05:03 AM

The first thing to do is work through our standard troubleshooting checklist that was created to troubleshoot this exact type of problem. There's a link to the checklist in my signature. Let us know how it goes after you've performed all the steps in the checklist.
Share
March 29, 2012 1:38:22 AM

Ok. Sorry it took me so long to post back. I had to stop dancing around the house after a successful POST. So I took the day off and ran through the troubleshooting list, tried everything and then some, with no luck. ASUS didn't have a solution, and neither did G.Skil. (I had narrowed it down to one of the two, motherboard of memory.) So I googled my problem and found a solution from a expert who is my personal Jesus.

QUOTE:

"Hi guys, I had the same problem that you all report and I have just solved it (at least for me). So I wanted to quickly write to you all and share what I found out.
With the Sabertooth x79 motherboard it doesn't recognize the Corsair ram or most of the other normal brands of ram out of the box.
What you need to do is to go to asus homepage and download the latest Bios. Get it here: http://www.asus.com/Motherboards/Int..._X79/#download
Now you download the newest version and put it on a USB stick in the root directory with nothing else on that USB stick.
Note: RENAME the file to "SABERX79.ROM".
Now put insert the USB stick in the back of your motherboard where it has a BIOS button. It has a white box circling the USB to insert it in.
All you need to have is the motherboard and the powersupply, nothing else is required (but its ok if you have it all hooked up).
Don't try to start the computer, just have the power cord hooked up. The green light on the motherboard lights up to show you have power.

Now all you do is press the BIOS button and hold it for 3 seconds or so. It will start to flash. Now you leave it to its business for some minutes until the blue flashy light on the BIOS button turns off.
Now you can take out the USB stick and turn on your computer. It will now recognize your Corsair ram and any other brand you may use.
Good luck guys! I hope it works for you too!"

All credit for this goes to dyrby76 in the Corsair forums. And thank you shortstuff for the troubleshooting guide.
m
0
l
March 29, 2012 1:38:42 AM

Best answer selected by Hel Styrkr.
m
0
l
!