New build: No beeps/POST/video

CPU: INTEL|CORE I3 550 3.20G
Board: Intel BOXDH55PJ LGA 1156 Intel H55 Micro ATX Intel Motherboard
PSU: Thermaltake TR2 W0070RUC 430W ATX12V V2.2
Case: Antec 300
RAM: Two 4 GB Crucial DDR3 DIMMS

The CPU fan, rear and top case fans all spin. The green LED light is on the motherboard. The blue LED power light is on the front of the case. I get no POST and no video. I get the usual beeps if no RAM is installed.

I've done the following troubleshooting steps...

1. Checked all power cables are securely plugged into the board (unplugged/replugged all) including the 4-pin CPU power
2. Swapped the two RAM sticks, tried booting with only one DIMM, booting with no memory and got a beep code
3. Reseated the CPU and heatsink/fan
4. Tried VGA and DVI ports with two different monitors. Also put in PCIe video card with HDMI and could not get video on my HDTV.

I have not had a chance to try different RAM. Since I get a beep code with no memory in does that point to it being a memory issue?
2 answers Last reply
More about build beeps post video
  1. cjt20one said:
    CPU: INTEL|CORE I3 550 3.20G
    Board: Intel BOXDH55PJ LGA 1156 Intel H55 Micro ATX Intel Motherboard
    PSU: Thermaltake TR2 W0070RUC 430W ATX12V V2.2
    Case: Antec 300
    RAM: Two 4 GB Crucial DDR3 DIMMS

    The CPU fan, rear and top case fans all spin. The green LED light is on the motherboard. The blue LED power light is on the front of the case. I get no POST and no video. I get the usual beeps if no RAM is installed.

    I've done the following troubleshooting steps...

    1. Checked all power cables are securely plugged into the board (unplugged/replugged all) including the 4-pin CPU power
    2. Swapped the two RAM sticks, tried booting with only one DIMM, booting with no memory and got a beep code
    3. Reseated the CPU and heatsink/fan
    4. Tried VGA and DVI ports with two different monitors. Also put in PCIe video card with HDMI and could not get video on my HDTV.

    I have not had a chance to try different RAM. Since I get a beep code with no memory in does that point to it being a memory issue?

    Make sure the monitor/tv inputs are selected properly.
  2. Ah yes, forgot to include that to the list - I had checked that.

    Also, on my keyboard I get the all three lights flashing quickly just after powering the machine on. I tried a USB and PS2 keyboard.
Ask a new question

Read More

New Build Intel CPUs Systems