Sign in with
Sign up | Sign in
Your question

Upgrading Dell dimension 8400 video card with an HD4770

Last response: in Graphics & Displays
Share
January 22, 2012 7:51:19 AM

Hello,
I have a Dell dimension 8400 P4 3.2GHz, 3Gb RAM and Geforce 6800 GPU. I wanted to upgrade the GPU to an HD4770. When I tried the HD4770 and switched the pc on all the fans came on and a gpu fault was indicated on the leds at the back. I have since tested the hd4770 in another pc and it works fine, just not in my pc. I have also tried it with a coolermaster 650w psu but the outcome is the same. I removed the old drivers before I tried the HD4770. Is there something that I am not doing that is preventing the pc from powering up without thinking it has a faulty GPU? Any advice would be very helpful
January 22, 2012 8:05:04 AM

Check that your MoBo's bios version supports the 4770.
February 3, 2012 5:59:46 PM

I have updated the BIOS to the latest version but there is no improvement the system still shows a GPU fault. How do you check whether the BIOS version supports the card?

Related resources
February 4, 2012 5:39:57 PM

The latest bios version has to support the card, so the problem has to be something else. Did you connected the 6-pin power cable to the card?
February 11, 2012 4:23:19 PM

FunSurfer said:
The latest bios version has to support the card, so the problem has to be something else. Did you connected the 6-pin power cable to the card?



Hi Fun Surfer. I am running BIOS A05. I thought my friend had upgraded to the latest BIOS version (A09 I think) but he says it is a beta version so he didn't install it incase it caused problems. He also checked out all the hardware and M/board connections and said they were fine. I did connect the 6-pin power cable to the card so that wasn't the problem. Do you know what the latest 'proper' BIOS version is and what is the best way to install it? Many thanks for your help and any suggetions.
!