NotePad - file types

Archived from groups: microsoft.public.windowsxp.customize (More info?)

When I use NotePad, I usually need to open *.DAT files. So each time, I
need to change the file type from *.TXT to all files (*.*). Is it possible
to change default file type to *.DAT;*.TXT when I open a file in Notepad?

TIA
Mike
10 answers Last reply
More about notepad file types
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Folder Options/File Types... .DAT/Change/Select program from a
    list/Notepad.exe
    Michael
    "Mike" <hhey2@lycos.com> wrote in message
    news:xZtdd.291471$3l3.35078@attbi_s03...
    > When I use NotePad, I usually need to open *.DAT files. So each time, I
    > need to change the file type from *.TXT to all files (*.*). Is it
    > possible
    > to change default file type to *.DAT;*.TXT when I open a file in Notepad?
    >
    > TIA
    > Mike
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    I have *.DAT files opening with Notepad ok, BUT they have a *Nero Showtome*
    Icon.
    If I go to Folder Options/File Types... .DAT/ it asks if I want to restore
    the association to *Nero Showtome* which is obviously incottect...
    How can I rectify this please?


    > list/Notepad.exe

    "Michael" <afn18721@afn.org> wrote in message
    news:uWKLGtrtEHA.2116@TK2MSFTNGP14.phx.gbl...
    > Folder Options/File Types... .DAT/Change/Select program from a
    > list/Notepad.exe
    > Michael
    > "Mike" <hhey2@lycos.com> wrote in message
    > news:xZtdd.291471$3l3.35078@attbi_s03...
    >> When I use NotePad, I usually need to open *.DAT files. So each time, I
    >> need to change the file type from *.TXT to all files (*.*). Is it
    >> possible
    >> to change default file type to *.DAT;*.TXT when I open a file in Notepad?
    >>
    >> TIA
    >> Mike
    >>
    >>
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    You can check the registry for HKEY_CLASSES_ROOT\.dat and see if Nero is
    there - but have a reagistry backup or export the key that you want to
    delete. There are some registry utilities that can do the job if Nero is no
    longer on your system.
    Safe and best is to use a tool such as TweakUI for XP to restore file
    associations. Or Google for 'xp repair file association'
    Michael

    "zulu" <nothere@ntlworld.com> wrote in message
    news:73ydd.358$K2.127@newsfe3-gui.ntli.net...
    >I have *.DAT files opening with Notepad ok, BUT they have a *Nero Showtome*
    >Icon.
    > If I go to Folder Options/File Types... .DAT/ it asks if I want to restore
    > the association to *Nero Showtome* which is obviously incottect...
    > How can I rectify this please?
    >
    >
    >> list/Notepad.exe
    >
    > "Michael" <afn18721@afn.org> wrote in message
    > news:uWKLGtrtEHA.2116@TK2MSFTNGP14.phx.gbl...
    >> Folder Options/File Types... .DAT/Change/Select program from a
    >> list/Notepad.exe
    >> Michael
    >> "Mike" <hhey2@lycos.com> wrote in message
    >> news:xZtdd.291471$3l3.35078@attbi_s03...
    >>> When I use NotePad, I usually need to open *.DAT files. So each time, I
    >>> need to change the file type from *.TXT to all files (*.*). Is it
    >>> possible
    >>> to change default file type to *.DAT;*.TXT when I open a file in
    >>> Notepad?
    >>>
    >>> TIA
    >>> Mike
    >>>
    >>>
    >>
    >>
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Yes, I have associated DAT file type to open with NotePad. But if you open
    Notepad, then File, Open... Is there a way to change the "files of type"
    combobox in the Open dialog box to *.dat;*.txt?


    "Michael" <afn18721@afn.org> wrote in message
    news:uWKLGtrtEHA.2116@TK2MSFTNGP14.phx.gbl...
    > Folder Options/File Types... .DAT/Change/Select program from a
    > list/Notepad.exe
    > Michael
    > "Mike" <hhey2@lycos.com> wrote in message
    > news:xZtdd.291471$3l3.35078@attbi_s03...
    >> When I use NotePad, I usually need to open *.DAT files. So each time, I
    >> need to change the file type from *.TXT to all files (*.*). Is it
    >> possible
    >> to change default file type to *.DAT;*.TXT when I open a file in Notepad?
    >>
    >> TIA
    >> Mike
    >>
    >>
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    "zulu" <nothere@ntlworld.com> wrote
    | I have *.DAT files opening with Notepad ok, BUT they have a *Nero Showtome*
    | Icon.
    | If I go to Folder Options/File Types... .DAT/ it asks if I want to restore
    | the association to *Nero Showtome* which is obviously incottect...
    | How can I rectify this please?

    Does *Nero Showtome* use *.DAT files?

    Have you uninstalled *Nero Showtome* ?

    Exactly what "asks if (you) want to restore the association
    to *Nero Showtome*"?
    Did you click [Restore] ?

    Exactly what "is obviously inco(rr)ect" ?
  6. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Let me start over here...
    All *.DAT files have a NeroShowtime icon instead of a Notepad icon, and
    tried to opem WITH NeroShowtime - the *obviously incorrect* bit....[1]
    I have changed this to *Always open this type of file with Notepad*, and
    indeed they DO open with Notepad.
    HOWEVER, they STILL have NeroShowtime icons.
    If I follow the route you gave me: (I had already tried that BTW)
    Explorer
    Tools
    Folder Options
    File Types
    DAT <<<<<<<<
    Advanced
    Change Icon

    As soon as I click DAT (as above) *Advanced* is replaced by *Restore* and it
    wants to re associate with NeroShowtime.
    BTW, what is the Notepad icon called, *Notepad.ico*?
    IF so, it doesn't exist on my puter...!

    [1] Please excuse typos as I am partially sighted and this is bl@@dy hard
    work for me!:-(

    --
    ¦ zulu ¦


    "a nonymous" <anonymous@discussions.microsoft.com> wrote in message
    news:OafER9utEHA.3788@TK2MSFTNGP09.phx.gbl...
    >
    > "zulu" <nothere@ntlworld.com> wrote
    > | I have *.DAT files opening with Notepad ok, BUT they have a *Nero
    > Showtome*
    > | Icon.
    > | If I go to Folder Options/File Types... .DAT/ it asks if I want to
    > restore
    > | the association to *Nero Showtome* which is obviously incottect...
    > | How can I rectify this please?
    >
    > Does *Nero Showtome* use *.DAT files?
    >
    > Have you uninstalled *Nero Showtome* ?
    >
    > Exactly what "asks if (you) want to restore the association
    > to *Nero Showtome*"?
    > Did you click [Restore] ?
    >
    > Exactly what "is obviously inco(rr)ect" ?
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Guess you have to code your own notepad for that - i.e. change
    saveFileDialog="txt files (*.txt)|*.txt|All files (*.*)|*.*" and ad .dat.
    More here:
    http://www.visual-basic-data-mining.net/forum/ShowPost.aspx?PostID=768
    Michael

    "Squid" <noaddress@here.com> wrote in message
    news:NaDdd.505978$8_6.335980@attbi_s04...
    > Yes, I have associated DAT file type to open with NotePad. But if you
    > open Notepad, then File, Open... Is there a way to change the "files of
    > type" combobox in the Open dialog box to *.dat;*.txt?
    >
    >
    > "Michael" <afn18721@afn.org> wrote in message
    > news:uWKLGtrtEHA.2116@TK2MSFTNGP14.phx.gbl...
    >> Folder Options/File Types... .DAT/Change/Select program from a
    >> list/Notepad.exe
    >> Michael
    >> "Mike" <hhey2@lycos.com> wrote in message
    >> news:xZtdd.291471$3l3.35078@attbi_s03...
    >>> When I use NotePad, I usually need to open *.DAT files. So each time, I
    >>> need to change the file type from *.TXT to all files (*.*). Is it
    >>> possible
    >>> to change default file type to *.DAT;*.TXT when I open a file in
    >>> Notepad?
    >>>
    >>> TIA
    >>> Mike
    >>>
    >>>
    >>
    >>
    >
    >
  8. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    "zulu" <nothere@ntlworld.com> wrote
    | Let me start over here...
    | All *.DAT files have a NeroShowtime icon instead of a Notepad icon, and
    | tried to opem WITH NeroShowtime - the *obviously incorrect* bit....[1]

    Probably because NeroShowtime uses *.DAT files.


    | I have changed this to *Always open this type of file with Notepad*, and
    | indeed they DO open with Notepad.
    | HOWEVER, they STILL have NeroShowtime icons.
    | If I follow the route you gave me: (I had already tried that BTW)
    | Explorer
    | Tools
    | Folder Options
    | File Types
    | DAT <<<<<<<<
    | Advanced
    | Change Icon
    |
    | As soon as I click DAT (as above) *Advanced* is replaced by *Restore* and it
    | wants to re associate with NeroShowtime.

    Click Restore.


    | BTW, what is the Notepad icon called, *Notepad.ico*?
    | IF so, it doesn't exist on my puter...!

    The icon is inside Notepad.exe itself. To use that icon...

    Explorer
    Tools
    Folder Options
    File Types
    DAT
    Advanced
    Change Icon
    Browse (to c:\WINDOWS\notepad.exe)


    | [1] Please excuse typos as I am partially sighted and this is bl@@dy hard
    | work for me!:-(

    No problem.

    Have you adjusted the sizes of every item in "Display Properties" ?

    Control Panel
    Display
    Appearance
    Advanced
    Item:

    Also, have you tried the "On-Screen Keyboard" (OSK) ?

    Start
    (All) Programs
    Accessories
    Accessibility
    On-Screen Keyboard

    I copied the shortcut to OSK to my Statup folder.
    I use OSK in "hover mode" but you can click on the keys for faster typing.
    The "keys" are large and you can choose, among other things, ...

    On-Screen Keyboard
    Settings
    Font (face, style and size)


    P.S.: Ignore my reply to you in the other sub-thread - there is more detail
    in this sub-thread.
  9. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    "a nonymous" <anonymous@discussions.microsoft.com> wrote in message
    news:Od74En7tEHA.3088@tk2msftngp13.phx.gbl...
    >
    > "zulu" <nothere@ntlworld.com> wrote
    > | Let me start over here...
    > | All *.DAT files have a NeroShowtime icon instead of a Notepad icon, and
    > | tried to opem WITH NeroShowtime - the *obviously incorrect* bit....[1]
    >
    > Probably because NeroShowtime uses *.DAT files.
    >
    >
    > | I have changed this to *Always open this type of file with Notepad*, and
    > | indeed they DO open with Notepad.
    > | HOWEVER, they STILL have NeroShowtime icons.
    > | If I follow the route you gave me: (I had already tried that BTW)
    > | Explorer
    > | Tools
    > | Folder Options
    > | File Types
    > | DAT <<<<<<<<
    > | Advanced
    > | Change Icon
    > |
    > | As soon as I click DAT (as above) *Advanced* is replaced by *Restore*
    > and it
    > | wants to re associate with NeroShowtime.
    >
    > Click Restore.

    AArrghhhh
    As I just said, that doing THAT re associates it with NeroShowtime...
    and *Advanced* ain't there no more................

    >
    > | BTW, what is the Notepad icon called, *Notepad.ico*?
    > | IF so, it doesn't exist on my puter...!
    >
    > The icon is inside Notepad.exe itself. To use that icon...
    >
    > Explorer
    > Tools
    > Folder Options
    > File Types
    > DAT
    > Advanced
    > Change Icon
    > Browse (to c:\WINDOWS\notepad.exe)

    OL, I understand that, but it doesn't fix it :-(
    >
    >
    > | [1] Please excuse typos as I am partially sighted and this is bl@@dy
    > hard
    > | work for me!:-(
    >
    > No problem.
    >
    > Have you adjusted the sizes of every item in "Display Properties" ?
    >
    > Control Panel
    > Display
    > Appearance
    > Advanced
    > Item:

    Oh yes, I've played with that more than I have with her downstairs! <G>
    I've also increased dpi to 150%...

    >
    > Also, have you tried the "On-Screen Keyboard" (OSK) ?
    >
    > Start
    > (All) Programs
    > Accessories
    > Accessibility
    > On-Screen Keyboard
    >
    > I copied the shortcut to OSK to my Statup folder.
    > I use OSK in "hover mode" but you can click on the keys for faster typing.
    > The "keys" are large and you can choose, among other things, ...
    >
    > On-Screen Keyboard
    > Settings
    > Font (face, style and size)

    Thanks, I'll investigate that again.
    (I didn't like it the only (brief) time I tried it.)
    However....

    >
    > P.S.: Ignore my reply to you in the other sub-thread - there is more
    > detail
    > in this sub-thread.

    Ok :-))
    I'll delete the other thread...

    Thanks for all your efforts.
    This is getting VERY frustrating tho...
  10. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    "zulu" <nothere@ntlworld.com> wrote
    |
    | "a nonymous" wrote
    | >
    | > "zulu" <nothere@ntlworld.com> wrote
    | > | I have changed this to *Always open this type of file with Notepad*, and
    | > | indeed they DO open with Notepad.
    | > | HOWEVER, they STILL have NeroShowtime icons.
    | > | If I follow the route you gave me: (I had already tried that BTW)
    | > | Explorer
    | > | Tools
    | > | Folder Options
    | > | File Types
    | > | DAT <<<<<<<<
    | > | Advanced
    | > | Change Icon
    | > |
    | > | As soon as I click DAT (as above) *Advanced* is replaced by *Restore*
    | > and it wants to re associate with NeroShowtime.
    | >
    | > Click Restore.
    |
    | AArrghhhh
    | As I just said, that doing THAT re associates it with NeroShowtime...
    | and *Advanced* ain't there no more.


    On a working system, when you click [Restore] it should change back
    to [Advanced].

    Because NeroShowtime now owns *.DAT files,
    you need to MANUALLY set the *.DAT file association to Notepad.

    Explorer
    Tools
    Folder Options
    File Types
    DAT
    ( Click Restore to give you the Advanced button. )
    Advanced
    Change Icon
    Browse (to c:\WINDOWS\notepad.exe)
    OK

    In the "Action:" box, click "Open", then click [Edit]

    In "Application used to perform action:"
    "c:\WINDOWS\notepad.exe" "%1"

    If there is a tick in "Use DDE",
    then in the "Application:" box below that, enter

    notepad

    OK
    OK
    OK
Ask a new question

Read More

Configuration Notepad Microsoft Customization File Type Windows XP