Limited speed on Asus M4A89TD PRO/USB3

I've got a 75/75Mbit Fibre (FTTH) connection, but my speed seems limited with my new motherboard.

I always had the following speed on my old DDR2 motherboard (Asus M3A32 MVP):


I've recently bought an Asus M4A89TD PRO/USB3 and for some reason my connection is limited to about 40Mbit down and 10Mbit up.

The motherboard has an Realtek PCIe GBE Family Controller and all drivers are up to date and i'm running the latest BIOS version.

I've already tried plugging in another desktop PC and a MacBook on the same LAN cable, and they both get the full 75Mbit up/down.

Any ideas what might cause this?

Tnx
4 answers Last reply
More about limited speed asus m4a89td usb3

  1. Have a look in the network adapter's Properties>Advanced tab and check that Flow Control and Speed and Duplex are both set to Auto. There may be an advantage in changing the latter to 100Mb Half if it's already set to Auto.
  2. I've now set Speed & Duplex from Auto to 1.0Gbps Full Duplex and it looks like it's running fine now.

    Tnx for pointing me in the right direction! :)
  3. Hmm, it only worked for about a day and now with the mode set to Full Duplex 1.0 Gbps i'm again getting a limited speed of about 30/10Mbit and i'm still getting 75/75Mbit with every other PC I hook up to the same LAN cable.

    Anyone other suggestions?
  4. turn off QoS and see if that helps.

    also what OS are you using.. sometimes windows will throttle your bandwidth if you are playing media under certain circumstances this can cause issues.

    I remember before it was patched playing winamp slowed my file server tranfers to a crawl.
Ask a new question

Read More

Asus Motherboards Networking