Sign-in / Sign-up
Your question

Change default file type in Open dialogbox

Tags:
  • Configuration
  • Default
  • Notepad
  • Customization
  • File Type
  • Windows XP
Last response: in Windows XP
October 20, 2004 10:43:06 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

When I use NotePad, I usually need to open *.DAT files. So each time, I need
to change the file type from *.TXT to all files (*.*). Is it possible to
change default file type to *.DAT;*.TXT when I open a file in Notepad?

TIA
Mike

More about : change default file type open dialogbox

October 20, 2004 6:15:35 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

My DAT files open with Notepad ok (is this as it shoulf be...?) just by
double clicking them.

However, they have the *Nero Showtime* icon.
How do I fix this please?

"Squid" <Squid@discussions.microsoft.com> wrote in message
news:8A39DFB3-E1AB-4F93-8CDA-C892F28A77E9@microsoft.com...
> When I use NotePad, I usually need to open *.DAT files. So each time, I
> need
> to change the file type from *.TXT to all files (*.*). Is it possible to
> change default file type to *.DAT;*.TXT when I open a file in Notepad?
>
> TIA
> Mike
Anonymous
October 21, 2004 10:16:19 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"zulu" <nothere@ntlworld.com> wrote
| My DAT files open with Notepad ok (is this as it shoulf be...?) just by
| double clicking them.
|
| However, they have the *Nero Showtime* icon.
| How do I fix this please?

Explorer
Tools
Folder Options
File Types
DAT
Advanced
Change Icon
Related resources
Anonymous
October 21, 2004 11:32:58 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"Squid" <Squid@discussions.microsoft.com> wrote
| When I use NotePad, I usually need to open *.DAT files. So each time, I need
| to change the file type from *.TXT to all files (*.*). Is it possible to
| change default file type to *.DAT;*.TXT when I open a file in Notepad?
|
| TIA
| Mike

Not possible via "Resource Hacker".

However a hex-editor can be used to change "*.txt" to "*.DAT".

1. Copy c:\WINDOWS\NOTEPAD.EXE to c:\<folder-of-choice>\NOTEPAD-dat.EXE

2. In a hex-editor, open NOTEPAD-dat.EXE

3. Scroll to offset 0x7C0

4. Edit "t.x.t." to "d.a.t."

5. Create a shortcut to c:\<folder-of-choice>\NOTEPAD-dat.EXE, and use that one
to open "*.DAT" files.

-or-

Get a free text editor such as at http://www.editpadpro.com/editpadlite.html
October 21, 2004 11:47:48 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

I can't do that, that's the problem....
The only choce I have is to restore the association and that makes it try to
open with NeroShowtime...
Once I do that, the Notepad Icon isn't ther to choose anyway
AArrghhhhhhhhhhh

"a nonymous" <anonymous@discussions.microsoft.com> wrote in message
news:ekpLwGutEHA.3152@TK2MSFTNGP14.phx.gbl...
>
> "zulu" <nothere@ntlworld.com> wrote
> | My DAT files open with Notepad ok (is this as it shoulf be...?) just by
> | double clicking them.
> |
> | However, they have the *Nero Showtime* icon.
> | How do I fix this please?
>
> Explorer
> Tools
> Folder Options
> File Types
> DAT
> Advanced
> Change Icon
>
>
Anonymous
October 22, 2004 10:09:48 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"zulu" <nothere@ntlworld.com> wrote
| I can't do that, that's the problem....
| The only choce I have is to restore the association and that makes it try to
| open with NeroShowtime...
| Once I do that, the Notepad Icon isn't ther to choose anyway
| AArrghhhhhhhhhhh
|
| "a nonymous" <anonymous@discussions.microsoft.com> wrote in message
| news:ekpLwGutEHA.3152@TK2MSFTNGP14.phx.gbl...
| >
| > "zulu" <nothere@ntlworld.com> wrote
| > | My DAT files open with Notepad ok (is this as it shoulf be...?) just by
| > | double clicking them.
| > |
| > | However, they have the *Nero Showtime* icon.
| > | How do I fix this please?

Explorer
Tools
Folder Options
File Types
DAT
Advanced
Change Icon
Browse (to c:\WINDOWS\notepad.exe)