Sign in with
Sign up | Sign in
Your question

Can't change GPU fan speed of HD 6950

Last response: in Graphics & Displays
Share
January 23, 2012 4:25:19 PM

Dear Tomshardware community,

A couple of days ago I was playing a game and I noticed some screen tearing so I decided to bump up the memory clock settings a bit and see what happened. At the time I was using CCC to overclock the card and didn't raise the fan speed because it sounds like a jet. Long story short, the card heated up and the game froze and I had to restart my computer. After a restart I no longer had the ability to change the fan speed of the card. It does still spin, but it never changes speed even under load. I've used MSI Afterburner and Catalyst Control Center to try and change the speeds. There was one very brief moment where I could change the speeds again while using Afterburner, but since then I've had no luck.

My HD 6950 is flashed to 6970.

Here are the rest of my specs:

Case: Coolermaster HAF 932 Advanced
Power Supply: CORSAIR Ethusiast Series CMPSU-850TX 850w
Mobo: ASUS P6X58D Premium
CPU: Intel Core i7-950 Bloomfield 3.06 (OC'd at 4.0ghz)
Heatsink: Corsair CWCH50-1 (Self-contained water cooling)
Video Card: SAPPHIRE Radeon HD 6950 2GB 256 bit (flashed to 6970)
Storage: Seagate 300gb HDD
80GB Intel X25-M SSD
Memory: 12GB G.SKILL Ripjaws DDR3 1333
a b U Graphics card
January 23, 2012 4:37:11 PM

That sucks. Shouldn't the fan automatically ramp up with increased temps? I know it is a silly question but did you uncheck the box to allow manual fan speed control in CCC to see if it would go back to automatically increasing. Did you flash the BIOS or did you buy it already flashed? Maybe you should to flip the switch back to the 6950 BIOS and see if the fan works.
m
0
l
January 23, 2012 4:44:00 PM

It should ramp up according to temps, but it doesn't. I did uncheck the box. I also already tried to flip the switch, but that didn't work either.

I also tried to uninstall CCC and had difficulty doing so at first. My last thought on the whole thing is that there is still residual files from the first install of it that are setting the fan speed.
m
0
l
Related resources
a b U Graphics card
January 23, 2012 8:10:10 PM

I find CCC is funny sometimes. I have found that on more than one occasion i have had to restart because CCC just wasn't registering simple commands. Can you try to reflash it? If the fans still works then it sounds like a software issue or possibly a faulty BIOS. Good luck. I am only talking out of my rear end at this point.

m
0
l
February 3, 2012 6:33:29 PM

Ok, so I FINALLY fixed my problem! I got driver sweeper and ran it, which deleted ALL of the display driver files. I then re-installed CCC and now everything works perfectly. After I heard the fan spin up faster than normal I squealed like a 3rd grade girl. Thanks for your help!!!
m
0
l
February 7, 2012 5:14:49 PM

The above post is only partially true and since posting I am only more confused. The fan controller started working again until I put my computer in sleep mode and started it back up again. After putting it in sleep mode it seemed like there was a huge delay between Afterburner telling the fan to speed up and it actually speeding up. Any other suggestions would be great. Thanks guys.
m
0
l
February 8, 2012 1:37:35 AM

had a simular problem with a flashed 6950. In CCC did you set the power to +20% as the flash instructions state? If so change it back to 0 and your problem should be solved.
m
0
l
!