New Motherboard/CPU can't install Windows 7

Hey everyone, Today I got an ASUS Sabertooth P67 board and the i7 2600k.

I have quite a few hard drives but for the time being I have unplugged all of them and I am just trying to install windows on my 120GB OCZ Vertex 3 SSD

I am booting windows 7 off of my flash drive which has worked on pretty much all my other Windows installs.

I am able to get into the Windows 7 setup however right after clicking Install Now I get a screen saying "Select Driver to be installed" Which has a pop up screen headed "Load Driver" and then information about needing a CD/DVD with the correct driver information on it.

I have tried using the CD that came with the Mobo. But nothing even if I got the list to populate with a choice after clicking on it and choosing next I would get an error that it can't be installed.

I have tried booting in IDE, ACHI, and RAID. All modes I get the same problem. The PC is finding the HDD because it is in the BIOS and I can even boot from it, but since it has an old Windows 7 install it just ends up rebooting.

I have also noticed that in the BIOS there was an option to turn off various storage controllers. I tried disabling them to leave just the Intel RAID controller. Yet still I get the same problems.

Thanks in advanced for reading this, and I do hope we can get this resolved!
2 answers Last reply
More about motherboard install windows
  1. I got it guys, apparently if you dont make the USB a certain way it will not load drivers... So I found my DVD. And I will be installing Windows 7 now! Love you guys though I know you were all getting ready to post really awesome responses!
  2. Of course we were :P
Ask a new question

Read More

Windows 7 Motherboards