Sign in with
Sign up | Sign in
Your question

wireless issues

Last response: in Wireless Networking
Share
August 10, 2005 9:17:56 PM

Just bought a new 802.11g USB card (edimax 7317ug) and installed it on my main computer which is used as a router also (win XP sp2)

i'm trying to connect my centrino laptop (IBM X31) and have limited success only on SSID "default" and "MyWirelessNet" - those nets have very weak signal and the link is often broken.

tried to configure WLAN network on the "big"computer using the ZD tool which edimax gives. I can create new ad hoc networks which optimal gain, and the laptop recognizes the network and connect to it ...... however - the "big" computer gets an invalid IP address "169.254.126.111" and the laptop gets also a similar address (netmask is 255.255.0.0) - no conectivity (no internet using ICS and no ping). whenever i use "default" or "MyWirelessNet" big comuter address is 192.168.2.1 and the laptop has 192.168.2.100 - everything is OK (except for the low signal - and lack of security of course).

i also tried to configre the USB card as an AP but again - no IP connectivity.......

I'm breaking my head for 2 nights in a row - but still nothing - plz help.

Mono.

More about : wireless issues

August 10, 2005 11:00:07 PM

What don't you just use Windows to make the network?

_____________________
<A HREF="http://snipurl.com/fxwr" target="_new">Welcome to the House of Horrors, welcome to the House of a 1000 Corpses</A>
August 11, 2005 5:40:02 AM

i also configured the connection as Ad-Hoc and the physical conection is excellent. but again there's no IP connectivity - if i try to use DHCP - i can automatic private address (169.254.X.X) and if i define the network manually (big comp 192.168.2.1 & 255.255.255.0 ; laptop 192.168.2.100 same netmask and default GW is 192.168.2.1) there's no IP conectivity.

what's next ?
Related resources
August 11, 2005 6:22:52 PM

Start from scratch. You really haven't provided a tremendous amount of information. You've outlined what you've done but it's hard to see if you've made any mistakes via the original and followup posts. Any suggestions would be guesswork. It will definitely be an Ad Hoc wireles LAN if your using a PC as an ICS host to another PC client. Same SSID and same channel on both server and client(s). Also, I'd disable any encrpytion, or any security measure for that matter if you do have anything setup. WEP can be used in an Ad Hoc WLAN. Not sure about WPA in Ad Hoc.
August 14, 2005 11:05:05 AM

kwebb thx, but i could not understand from your message a way to debug the problem.

I do not use any encryption in the ad hoc or station connection.

What i get when i look for wireless networks in my PC or Laptop are usualy 2 networks: one is called "MyWirelessNet" and the other is called "default". since i'm new to wireless, i do not know if those networks are Win XP defaults or i'm just loging in to my neighbours networks (i dont think anyone in this hood knows what wireless means .... :) 

anyway - a basic wireless connection is made - but the IP layer is problematic (acquiring network adress messages etc). I read in some forums that the problem lies within the Netbios protocol - but i did not help in my case ....

any more suggestions will be gladly accepted.

Mono.
August 14, 2005 1:43:37 PM

DHCP problems have absolutely nothing to do with NetBIOS. You mention AdHoc and "station" Not sure what your talking about with the station comment. There is either AdHoc or Infrastructure. Infrastructure would be used if you had an Access Point or "wireless" router. If you just have a wireless card in your internet host machine and one in the client that you want to communicate with then it will be Ad Hoc. So no need to confuse the issue messing with anything else. When setting up AdHoc clients go into the driver details and assign a unique SSID to all clients, the same SSID on each of course. So say you set your SSID as mono. Also set each frequency or "channel" to the same one as well. If you have other wireless devices in your airspace, neighbors, they will typically leave it on the default channel, usually 6, so set your client to either 1 or 11. If you have setup ICS correctly on your host machine then there isn't much else to it.
August 14, 2005 2:46:13 PM

first - station == infastucture (just didn't remember the name).

i defined SSID to be the same on both computers. issue is that my desk computer is using edimax 7137ug USB wireless (802.11b+g) NIC and my laptop uses its built in Centrino NIC. again - the physical link is up but i cannot ping the devices (even with all FireWalls and Anti Virus off) and second the IP address which is determined by the DHCP is of type 169.254.XXX.XXX instead of 192.168.XXX.XXX.
if i try to set static ip in both computers (and the laptop uses the desk computer as its default GW) - there no ping nor internet connectivity......

thx again for the effort - if you need a diagram i'll send it to you happily.

Mono.
August 14, 2005 3:39:02 PM

Getting a 169.254.x.x address means there is no DHCP server available. In your case it means the client cards are probably not communicating, backed up by your not being able to ping when IP's are assigned statically. The channel also has to be the same in an Ad Hoc WLAN. I would also try G only mode on the cards or if your centrino laptop is older it might be .11b so you'd want to go .11b only on both cards.
August 16, 2005 8:00:06 AM

hey,

i'm half way of solving the problem .....

just to answer the questions : both wireless NICs are 802.11b confuguration, and also i cannot determine the channel on the centrino - but again this is not the problem since there an active link

What i've done is to bridge my LAN and wireless on the gateway (big computer) using win XP. Now i have the followiing config:

big comp : 192.168.0.1
little comp (desk) : 192.168.0.85 (DHCP), default GW == 192.168.0.1
Centrino wireless : 192.168.0.191 (DHCP), default GW == 192.168.0.1

therefore - limited connectivty is solved (this is on ad - hoc connection using WEP or without it)

the problem is still that i cannot surf from the laptop and also there's no ping to the big computer (GW) or the other desk computer. I can ping the big comp from the little desk computer.
i also disabled all FW and AV on both machines.

what's next ?

cheers,

mono.
!