Sign in with
Sign up | Sign in
Your question

MSI R6950 Twin Frozr II

Last response: in Graphics & Displays
Share
January 25, 2012 4:49:06 AM

I just bought a new system in parts and built it. I have built systems a million times before so Im pretty aware of what to do. When I plug in the video card, Im not getting any output. The fans are working, its running but my monitor will not accept anything. What can I do?

More about : msi r6950 twin frozr

a c 109 U Graphics card
January 25, 2012 4:54:03 AM

take a pic and list full system specs
m
0
l
January 25, 2012 5:13:53 AM

Motherboard: Gigabyte 990FXA-UD3
RAM: 8GB (2X4) Corsair Vengeance
Video Card: MSI R6950 Twin Frozr III Power Edition
Processor: AMD FX 6-Core Black Edition
Power Supply: Cooler Master Silent ProM 850W

file:///C:/Users/Kateryna/Desktop/409398_10150513625589615_502539614_9063219_296339476_n.jpg
file:///C:/Users/Kateryna/Desktop/407435_10150513625824615_502539614_9063220_281220104_n.jpg
file:///C:/Users/Kateryna/Desktop/399957_10150513626099615_502539614_9063221_580975107_n.jpg
m
0
l
Related resources
January 25, 2012 5:24:14 AM

Also, there are no beeps when I boot. Nothing happens lol. Everything turns on and starts running except display.
m
0
l
a c 109 U Graphics card
January 25, 2012 5:35:58 AM

Are you sure its the card or is it the monitor? Try all of the outputs from the card.
m
0
l
January 25, 2012 5:38:00 AM

I have two monitors here. I have another computer. I tried that monitor and its not working either.
m
0
l
a c 109 U Graphics card
January 25, 2012 5:52:56 AM

With what port on the card?
m
0
l
January 25, 2012 6:05:21 AM

OMG problem solved. The 8pin cpu power connector somehow fell out. I dont get it. It has a very dependable clip on it. Wow man. After like 5 hours of trying to figure stuff out I finally got it. As you can tell on the pics, the stupid oversized heatsink with dual fans was covering it lol. Thank you so much for your help. Problem solved. Time to install a totally legal version of windows.... =D
m
0
l
!