MSI R6950 Twin Frozr II

I just bought a new system in parts and built it. I have built systems a million times before so Im pretty aware of what to do. When I plug in the video card, Im not getting any output. The fans are working, its running but my monitor will not accept anything. What can I do?
8 answers Last reply
More about r6950 twin frozr
  1. take a pic and list full system specs
  2. Motherboard: Gigabyte 990FXA-UD3
    RAM: 8GB (2X4) Corsair Vengeance
    Video Card: MSI R6950 Twin Frozr III Power Edition
    Processor: AMD FX 6-Core Black Edition
    Power Supply: Cooler Master Silent ProM 850W

    file:///C:/Users/Kateryna/Desktop/409398_10150513625589615_502539614_9063219_296339476_n.jpg
    file:///C:/Users/Kateryna/Desktop/407435_10150513625824615_502539614_9063220_281220104_n.jpg
    file:///C:/Users/Kateryna/Desktop/399957_10150513626099615_502539614_9063221_580975107_n.jpg
  3. Also, there are no beeps when I boot. Nothing happens lol. Everything turns on and starts running except display.
  4. Are you sure its the card or is it the monitor? Try all of the outputs from the card.
  5. I have two monitors here. I have another computer. I tried that monitor and its not working either.
  6. With what port on the card?
  7. OMG problem solved. The 8pin cpu power connector somehow fell out. I dont get it. It has a very dependable clip on it. Wow man. After like 5 hours of trying to figure stuff out I finally got it. As you can tell on the pics, the stupid oversized heatsink with dual fans was covering it lol. Thank you so much for your help. Problem solved. Time to install a totally legal version of windows.... =D
Ask a new question

Read More

Graphics Cards Graphics MSI-Microstar