Sign in with
Sign up | Sign in
Your question

Sapphire 6850 issue...

Tags:
  • Graphics Cards
  • Drivers
  • Minecraft
  • FPS
  • Sapphire
  • Graphics
Last response: in Graphics & Displays
Share
January 25, 2012 2:42:45 PM

The issue is, it is performing VERY poorly. I am talking about 20 fps on minecraft.. The first time i used it with the correct drivers it was pulling 70 fps easily. I then restarted my computer and was receiving absolutely horrendous 2-5 fps. I then reinstall the drivers and am receiving around 20 fps on minecraft now... anyone want to help me?

More about : sapphire 6850 issue

a c 232 U Graphics card
a b \ Driver
January 25, 2012 4:03:52 PM

Did you re-install an older driver or the latest drivers from AMD/ATI?

Go here and get the latest and try again if you did not try the most current drivers:

http://support.amd.com/us/Pages/AMDSupportHub.aspx
m
0
l
January 25, 2012 4:35:28 PM

COLGeek said:
Did you re-install an older driver or the latest drivers from AMD/ATI?

Go here and get the latest and try again if you did not try the most current drivers:

http://support.amd.com/us/Pages/AMDSupportHub.aspx



oh hold on with those newest drivers yet...

i would suggest clean driver install, meaning..-> [download.. driver sweeper for complete removal] uninstall drivers, restart computer, start in safe mode, start driver sweeper, remove all the left over amd/ati drivers, restart computer and install drivers those where you were having 70 fps, or try newer ones.
m
0
l
!