CPU Fan Long Delay Before Start-up

Hello,
I recently built my own computer and it's my first build. Everything went well and it runs very nicely except that every time I start it up, the CPU fan does not. I get a CPU FAN ERROR screen at the beginning. If I wait for what seems to be 5 minutes or so, (or until the CPU hits about 42ºC) the fan will turn itself on and I can proceed to use my computer.

This issue has been present from the moment I first started it up, 3 weeks later it has not been any different. Now I'm considering buying a CoolerMaster Hyper 212 aftermarket heat sink to replace my current stock Intel fan, but I want to know if this could possibly be a problem with my motherboard. If it is, then replacing the fan wouldn't solve my problem.

So far, I've made sure no cables obstructing the fan, and I've also tried to attach it to the CPU_OPT header and it was the exact same thing. I've googled this problem but I have not found any similar results. They usually consist of the fan not turning on at all, which, fortunately, is not my issue.

Here are some of my specs:

ASUS SABERTOOTH Z77 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

CORSAIR Professional Series HX750 (CMPSU-750HX) 750W ATX12V 2.3 / EPS12V 2.91 Power Supply

Intel Core i5-3570K Ivy Bridge 3.4GHz (3.8GHz Turbo) LGA 1155

NVidia GeForce GTX 550Ti

Using stock fan.

Any help on this issue would be greatly appreciated, thank you.
1 answer Last reply
More about long delay start
  1. I got this one with mine.

    Plug another fan into the CPU Opt socket next to it.
Ask a new question

Read More

CPUs Fan