Sign in with
Sign up | Sign in
Your question

Screen tearing on brand new setup?

Last response: in Graphics & Displays
Share
January 27, 2012 11:52:16 PM

Hello,

I recently bought myself a brand new computer (parts, built it myself). Intel i7 2600k, Radeon HD 6900 series, Win 7, a nice Harddrive too, can't remember the name... (other parts would be irrelevant, yes?)

So I get screen tearing in basically all of my games. Skyrim, TF2, MW3, BF3 etc etc. Now, the thing is, the computer should be able to play them with near perfection, as far as I understand.

I bought a new monitor as well, a BenQ RL2240H.

I don't understand why I get this very annoying screen tearing. I've tried to mess around with CCC with no luck. Anyone got a clue? This is getting on my nerves, and that's not good.

In advance, thanks.

- Serenity
January 27, 2012 11:59:57 PM

This is caused by your monitor not your computer. Basically, this is what V-Sync is for. It prevents the game from displaying more frames per second than the refresh rate of the monitor. Turn on V-Sync and the problem should go away.
m
0
l
January 28, 2012 12:04:53 AM

Thanks for the quick reply, Puff3r.

However, this is a BRAND new monitor. 1920 x 1080, 2ms response time, etc etc etc- can this still be the problem?

I tried turning on V-sync in BF3 with no result. There's not even an option on most games for V-sync. Optional solution? Some configuration in CCC or something?

PS. When you mention it, if I record with say, Fraps, there's no screen tearing when I watch the video afterwards. Do I have to invest in a new screen?

- Serenity
m
0
l
Related resources
January 28, 2012 12:08:59 AM

With FRAPS running, what FPS are you getting when running a game? Check this with the refresh rate of your monitor. If the FPS is higher than the refresh rate, this is the cause. Other than V-Sync I'm at a loss. Update the drivers for the video card.
m
0
l
January 28, 2012 12:28:35 AM

The age of the monitor doesn't matter in regards to screen tearing, its all in the hz baby. Most monitors have a refresh rate around 60hz but if you were to get a 120hz model you would probably avoid tearing as far as I understand.
m
0
l
January 28, 2012 12:31:34 AM

You should be able to turn on Vsync in CCC.
m
0
l
January 28, 2012 12:36:47 AM

how's about specific hardware.. ? and 64bit or 32 ?
m
0
l
January 28, 2012 12:38:46 AM

So, thank you all for your input!

I did solve the issue somewhat. I get what you mean about the Hertz, as it's the same with TVs. Higher hertz enables you to watch "difficult" angles and such. I.e. panning diagonally with the camera. That's what I saw when I was at the store buying a new TV, hahaha. Anyways, My CCC is in Norwegian, which is why I was so confused.

I turned on something called Triple buffering or something. Reading a bit more carefully, it says that it helps with the vertical synchronization. aka V-sync.

Once again, thanks for helping out, guys!

- Serenity
m
0
l
January 28, 2012 12:49:43 AM

?

Your CCC should be in English. And Triple buffering is different then Vsync. (and only works in OpenGL games.)
m
0
l
January 28, 2012 12:40:36 PM

That is weird, because mine is in Norwegian! :) 

Well, it says: "Improves image/picture frequency for games when vertical synchronization is active and image frequency is lower than the 'update frequency'. Which I assumed was it.

Anyways, my bad I guess :) 

Any other tips then, 4745454b?

- Serenity
m
0
l
January 28, 2012 12:46:39 PM

Quote:
Improves image/picture frequency for games when vertical synchronization is active and image frequency is lower than the 'update frequency'[/fquote]

This is correct. Triple buffering doesn't work unless Vsync is already on. You fix screen tearing by enabling Vsync, not enabling TB. I suggest you continue to look in your drivers for Vsync.
m
0
l
January 28, 2012 3:32:11 PM

Hey, I found the Vsync now, but it's a slider. I slide it all the way to the right, so it's always on. I also turned on the TB.

I still get this annoying screen tearing. I seriously do not know what to do now.

Have you guys got extremely high Hertz on your screens? Mine is standard 60.

Some facts: When I record with Fraps, the video don't have the screen tearing.

I get the screen tearing even if I put the settings in games to low. '

Could it be that the CCC doesn't really turn it on (Vsync)?
m
0
l
February 5, 2012 12:08:02 PM

Hey all, just an update. I made it work/found the solution. It was the fu----- monitor. I'm sending it back for a new one (entirely new product). I discovered it when I wen back to using my old monitor, and it is now perfect.

Thanks for all your input and support though, it has been truly educational.

- Serenity
m
0
l
February 5, 2012 12:44:24 PM

just FYI
tearing happens when the pc is outputting more images per second than the monitor can show, so that the image buffer on the card gets rewriten while the previous image is still being transmitted to the monitor causing the rest of the image to show the newly written one... So lowering the settings in game will only make it worse since it makes higher fps possible.

m
0
l
!