Sign in with
Sign up | Sign in
Your question

Crossfire 6950 2GB Poor Crysis 2 Performance

Last response: in Graphics & Displays
Share
January 28, 2012 3:10:13 AM

Just finished installing the 2nd 6950. Tryed Metro 2033 and noticed a significant FPS increase max setting 1920x1080 50-60 fps average but when i tryed crysis 2 it was horrible. On crysis 2 my resolution is set to 1920x1080 everything ultra getting around 30 fps or lower and dips down.

I've tried installing CAP profiles but that didn't help. Cat version is 11.12

2500k @ 4.1
GA-Z68X-UD3H-B3
2xTwin frozr II 6950 2GB
2x4GB G2 Patriot DDR3 1600
OCZ ELITE X STREAM 800W
Win 7 Ultimate
January 28, 2012 3:30:25 AM

direct 11? High textutres?
January 28, 2012 4:39:23 AM

i've downloaded the direct x 11 addon for patch 1.9 but dont even have the high textures installed. I've manage to somehow fix it so both my graphic cards have the same GPU usage but im still average around 35 - 45 fps is that normal for 2x6950s
Related resources
January 28, 2012 5:04:28 AM

are you running full screen?...not windowed
January 28, 2012 12:59:50 PM

yep full screen v-sync off
January 28, 2012 1:25:05 PM

are you overclocking your cards? or have your tried flashing the 6970 shader cores to the cards? you really shouldn't be having that problem, my 6950's eat that game up. might consider uninstalling and reinstalling the game. ?
January 28, 2012 3:13:54 PM

I didnt flash it to 6970 shaders. Both cards are at 880/1350. With all settings ultra directx 11 1920x1080 my fps is average 40ish
January 28, 2012 11:59:00 PM

try putting them back to stock speeds,not all will run 6970 clocks with stability.800/1250
January 29, 2012 12:05:35 AM

whats your fps with 1 card?
January 29, 2012 12:14:07 AM

Havent tryed 1 card with ultra and direct x 11. I will try stock speeds tonight
January 29, 2012 3:53:59 AM

tryed stock speeds still the same 40fps average =\
February 1, 2012 11:14:14 PM

anyone got any ideas in this using the newest cat and cat app using radeon pro helped a bit and i rename it to f.e.a.r.exe
!